
18
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فصل 2
استانداردهاي نقشه كشي
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تولرانس‌هاي ابعادي عمومي

اندازه نامی

بزرگ‌ترین اندازهٔ مجاز= انحراف بالایی+ اندازه نامی
185+)+1(=186 mm

کوچک‌ترین اندازه مجاز=انحراف پایینی+اندازه اسمی
185+)-0/5(=184/5 mm

تولرانس=کوچک‌ترین اندازه مجاز -بزرگ‌ترین اندازه مجاز
186-184/5=1/5 mm

انحراف‌ها

انحراف‌ بالایی
انحراف پایینی

جدول تولرانس‌های عمومی و آزاد برحسب درجۀ تولرانس 

اندازه نامی
درجۀ 
تولرانس

بالای 30 تا بالای 6 تا 30بالای 3 تا 6از 0/5 تا ۳
120

بالای 120 تا 
400

بالای 400 تا 
1000

بالای 1000 تا 
2000

بالای 2000 تا 
4000

-f±0/05±0/05±0/1±0/15±0/2±0/3±0/5ظریف

m±0/1±0/2±0/3±0/5±0/8±1/2±2متوسط

c±0/2±0/3±0/5±0/8±1/2±2±3±4خشن

v-±0/5±1±1/5±2/5±4±6±8خیلی خشن

محدودۀ انحراف اندازه‌ها برای اندازه‌های شعاع قوس‌ها، پخ‌ها و ارتفاع خزینه‌ها )برحسب میلی‌متر(

اندازۀ نامی             درجۀ تولرانس
 

بالای 6بالای 3 تا 6از 0/5 تا ۳

fظریف
±0/2±0/5±1

mمتوسط

cخشن
±0/4±1±2

vخیلی خشن

محدودۀ انحراف اندازه‌ها برای اندازه‌ زوایا برای اندازه‌های نامی با توجه به ضلعک وتاه‌تر زاویه )بر حسب میلی‌متر(

اندازۀ نامی             درجۀ تولرانس
 

بالای 400بالای 120 تا 400بالای 50 تا 120بالای ۱۰ تا ۵۰تا ۱۰

fظریف
±0/1°±30'±20'±10'±5'

mمتوسط

'c±0/1°30'±1°±25'±15'±10خشن

'v±3°±2°±1°±30'±20خیلی خشن
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نقشه در حرفه‌های مختلف
با آنکه مطالب و عناوین پایه در همه نقشه‌کشی‌ها یکسان است، اما نقشه‌ها در حرفه‌های مختلف 

تفاوت‌هایی را با هم خواهند داشت. به نمونه‌هایی نگاه کنید.

O

U

ریخته‌گریماشین‌ابزار

صنایع چوبساختمان

الکترونیکبرق

صنایع فلزیتاسیسات
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                         کاغذهای نقشه‌کشی
1 استاندارد ساير کشورها

DINآلمانASاسترالیاISIRIایران

ASAآمریکاBSانگلستانUNIایتالیا

FNفرانسهGostروسیهCASچین

CSAکانادا

ضمناً استانداردهای ISO در مورد نقشه‌کشی )و نیز در موارد دیگر( با یک شماره منتشر می‌شوند. 
برای نمونه به چند مورد توجه کنید )که پس از انتشار تا زمانی که منسوخه اعلام نشوند اعتبار 

خواهند داشت(. برای نمونه:

ISO -128اصول نقشه‌کشی

ISO -129اندازه‌گذاری

ISO -206تولرانس‌های ابعادی

ISO -1101تولرانس‌های هندسی

ISO -2768تولرانس‌های هندسی

a
b

= 2
 
1000000mm2A m= =2

0 1
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اندازۀك اغذ هاي نقشه كشي برحسب ميلي متر

۴۲۰×۲۹۷A 3۱۱۸۹×۸۴۱A 0

۲۹۷×۲۱۰A 4۸۴۱×۵۹۴A 1

۲۱۰×۱۴۸A 5۵۹۴×۴۲۰A 2

این جدول، گروه‌های خط و کاربرد آنها در کاغذهای گوناگون را نشان می‌دهد.

خط متوسط خط اصلی dگروه
d'

d" پهنای خط خط نازک
مناسب برایک اغذ اصلی

خیلی بزرگ۱۲۱/۴۱

۲۱/۴۱۰/۷A0

۳۱۰/۷۰/۵A0

۴۰/۷۰/۵۰/۳۵A0 - A1

۵۰/۵۰/۳۵۰/۲۵ A0- A1 -A3-)   (

۶۰/۳۵۰/۲۵۰/۱۸A2 - A3 -A4

۷۰/۲۵۰/۱۸۰/۱۳A4 - A5

A4
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                     تعیین مقیاس نقشه
گاهی با تصویربرداری، چاپ یا کپی نقشه، مقیاس آن تغییر می‌کند. برای تعیین مقیاس نقشه‌ای 
که دارای اندازه‌گذاری است باید یکی از اندازه‌های طولی )ترجیحاً یکی از اندازه‌های بزرگ‌تر( را 
با خط‌کش اندازه‌گیری کرد و آن را بر عدد اندازه‌ای که روی نقشه نوشته شده است تقسیم نمود 
تا مقیاس نقشه به دست آید. با داشتن مقیاس می‌توان بقیه طول‌هایی که اندازه‌گذاری نشده‌اند 

را نیز تعیین کرد.
در نقشۀ داده شده، طول قطعه 42 میلی‌متر اندازه‌گیری شده است. بنابراین مقیاس نقشه 0/75 یا 

42 است. ارتفاع قطعه نیز که اندازه‌گذاری نشده است با خط‌کش 18 میلی‌متر اندازه‌گیری شد که 
56

 18
0/75 = 24 در واقع 24 میلی‌متر است. 
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رسم‌های هندسی با كمك جدول
الف( قطر دایره محیطی چندضلعی منتظم معین است. طبق جدول می‌توان با توجه به تعداد ضلع 
چندضلعی )n( و قطر دایره محیطی )D(، ضریب K مشخص است. پس دهانه پرگار به اندازه 

Ln=KD باز و دایره تقسیم می‌شود )Ln طول ضلع چندضلعی(.

nK'nK'nK'nK'

1---268.93145116.88037624.1985

2---279.24915217.19847724.5167

31.1547289.56685317.51667824.8349

41.4142299.88455417.83477925.1531

51.70133010.20235518.15298025.4714

62.00003110.52015618.47108125.7896

72.30483210.83805718.78928226.1078

82.61313311.15585819.10738326.4261

92.92383411.47375919.42558426.7443

103.23613511.79166019.74378527.0625

113.54953612.10966120.06198627.3808

123.86373712.42756220.38008727.6990

134.17863812.74556320.69828828.0172

144.49403913.06356421.01648928.3355

154.80974013.38156521.33469028.6537

165.12584113.69956621.65289128.9720

175.44224214.01766721.97109229.2902

185.75884314.33566822.28929329.6085

196.07554414.65376922.60749429.9267

206.39254514.97177022.92569530.2450

216.70954615.28987123.24389630.5632

227.02674715.60797223.56209730.8815

237.34394815.92607323.88029831.1997

247.66134916.24417416.88039931.5180

258.61385016.56227517.198410031.8363
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ب( و در صورت داشتن طول چندضلعی می‌توان پس از به دست آوردن قطر دایره محیطی طبق 

، آن را در دایره ساخت. جدول ضرایب ′K را می‌دهد n
n

LD L K
sin n

′= = ×
180

رابطه 

nK'nK'nK'nK'

1---268.93145116.88037624.1985

2---279.24915217.19847724.5167

31.1547289.56685317.51667824.8349

41.4142299.88455417.83477925.1531

51.70133010.20235518.15298025.4714

62.00003110.52015618.47108125.7896

72.30483210.83805718.78928226.1078

82.61313311.15585819.10738326.4261

92.92383411.47375919.42558426.7443

103.23613511.79166019.74378527.0625

113.54953612.10966120.06198627.3808

123.86373712.42756220.38008727.6990

134.17863812.74556320.69828828.0172

144.49403913.06356421.01648928.3355

154.80974013.38156521.33469028.6537

165.12584113.69956621.65289128.9720

175.44224214.01766721.97109229.2902

185.75884314.33566822.28929329.6085

196.07554414.65376922.60749429.9267

206.39254514.97177022.92569530.2450

216.70954615.28987123.24389630.5632

227.02674715.60797223.56209730.8815

237.34394815.92607323.88029831.1997

247.66134916.24417416.88039931.5180

258.61385016.56227517.198410031.8363
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رسم‌های هندسی
خط مماس بر دایره از نقطه‌ای خارج از دایره

روش اول: به کمک دو گونیا 
1 ابتدا یک ضلع قائمه گونیا را طوری قرار دهید که 
از نقطه A گذشته و بر دایره به  صورت ظاهری مماس 

باشد.
2 گونیای دوم را زیر گونیای اول قرار دهید.

اول  گونیای  است  ثابت  دوم  گونیای  که  حالی  در   3
را طوری حرکت دهید که لبۀ قائمه آن از مرکز دایره 
نازک رسم  دایره یک خط  روی  این حالت  در  بگذرد. 

کنید.
4 حال با مشخص شدن نقطۀ مماس، خط مماس را 

رسم کنید.
روش دوم: ترسیمی

1 خطی از نقطه A به مرکز دایره رسم کنید.
2 نقطۀ M وسط OA را پیدا کنید.

3 به مرکز M دایره MA را رسم کنید.
4 نقطۀ N محل تقاطع دو دایره نقطۀ مماس است.

خط مماس دو دایره 
1 ابتدا یک ضلع قائمه گونیا را طوری قرار دهید که بر 

دایره به صورت ظاهری مماس باشد.
2 گونیای دوم را زیر گونیای اول قرار دهید.

اول  گونیای  است  ثابت  دوم  گونیای  که  حالی  در   3
را طوری حرکت دهید که لبۀ قائمه آن از مرکز دایره 
نازک رسم  دایره یک خط  روی  این حالت  در  بگذرد. 

کنید.
4 برای دایره دوم نیز همین مرحله را تکرار کنید.

5 حال با مشخص شدن نقاط مماس، خط مماس را 
رسم کنید.

رسم قوس های مماس
6 برای ترسیم قوس مماس علاوه بر معلوم بودن شعاع 
مماس نیاز به مشخص کردن نقاط مماس و مرکز قوس 

مماس است.
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مماس بین دو خط متقاطع
فاصله  به  اول  موازی ضلع  1 خطی 

R رسم کنید.
فاصله  به  2 خطی موازی ضلع دوم 
دو  این  تقاطع  محل  کنید.  رسم   R

خط مرکز قوس مماس است.
عمود  اضلاع  بر  مماس  مرکز  از   3

کنید تا نقاط مماس به دست آید.

مماس از كي نقطه بر دایره
 R شعاع  به  کمانی   A مرکز  به   1

)شعاع معلوم مماس( رسم کنید.
شعاع  به  کمانی  دایره  مرکز  به   2
شعاع  به علاوۀ  دایره  ) شعاع   r+R
محل  کنید.  رسم  مماس(  معلوم 
تقاطع این دو کمان )O( مرکز قوس 

مماس است.
مرکز  به  خطی  مماس،  مرکز  از   3
 M مماس  نقطۀ  تا  کنید  رسم  دایره 

به دست آید.
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مماس بین خط و دایره
برای تعیین مرکز قوس مماس باید ابتدا توجه 
خارج  یا  و  دایره  داخل  در  مماس  که  نمود 
قرار  کدام سمت خط  در  همین‌طور  و  دایره 
دارد. در صورتی که مماس داخل دایره باشد 
برای   r+R از  بود  دایره  اگر خارج  و   r-R از 

شعاع کمان استفاده کنید.
1 خطی موازی خط به فاصله R رسم کنید 

)بالای خط(.
2 کمانی به شعاع r+R ) شعاع دایره به علاوۀ 
شعاع معلوم مماس( رسم کنید. محل تقاطع 

این خط و کمان، مرکز قوس مماس است.
3 از مرکز مماس بر خط عمود کنید تا نقطۀ 

مماس روی خط به دست آید.
دایره  مرکز  به  خطی  مماس  مرکز  از   4
نیز  دایره  روی  مماس  نقطۀ  تا  کنید  رسم 

به دست  آید.

مماس بين دو دايره )مماس خارج(
با  مماس  قوس  مرکز  فاصله  مماس  این  در 

مرکز دایره مجموع دو شعاع است.
مورد نظر  موقعیت  در  را  معلوم  دایره‌های 

ترسیم کنید.
اول  دایره  )شعاع   r1+R شعاع  به  کمانی 

به علاوۀ شعاع معلوم مماس( رسم کنید. 
دوم  دایره  )شعاع   r2+R شعاع  به  کمانی 

به علاوۀ شعاع معلوم مماس( رسم کنید.
اول  دایرۀ  مرکز  به  خطی  مماس،  مرکز  از 
دایره  این  روی  مماس  نقطه  تا  کنید  رسم 

به دست  آید.
دوم  دایره  مرکز  به  خطی  مماس  مرکز  از 
رسم کنید تا نقطۀ مماس روی این دایره نیز 

به دست آید.
مماس بين دو دايره )مماس داخل(

با  مماس  قوس  مرکز  فاصلۀ  مماس  این  در 
شعاع  با  مماس  شعاع  تفاضل  دایره  مرکز 

دایره  است.
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دایره‌های معلوم را در موقعیت مورد نظر ترسیم کنید.
از مرکـز دایـرۀ اول کمانی به شـعاع R-r1 )شـعاع مماس 

منهـای دایرۀ اول( رسـم کنید. 
از مرکـز دایـرۀ دوم کمانی به شـعاع R-r2 )شـعاع مماس 

منهـای دایرۀ دوم( رسـم کنید. 
از مرکـز ممـاس خطـی به مرکز دایـرۀ اول رسـم کرده و 
امتـداد دهیـد تـا نقطۀ ممـاس روی ایـن دایره به دسـت 

ید. آ
از مرکـز ممـاس خطـی بـه مرکـز دایرۀ دوم رسـم کـرده و 
امتـداد دهیـد تـا نقطۀ ممـاس روی این دایره نیز به دسـت 

آید.

مماس محدب مقعر )مماس ترکیبی(
در ایـن ممـاس فاصلـۀ مرکز قـوس مماس بـا مرکز یکی 
از دایره‌هـا مجمـوع دو شـعاع اسـت و بـا دایـرۀ دیگـر 

تفاضـل شـعاع ممـاس بـا شـعاع دایره اسـت.
دایره‌های معلوم را در موقعیت مورد نظر ترسیم کنید.

کمانـی بـه شـعاع r1+R )شـعاع دایـره‌ای کـه خـارج از 
قـوس ممـاس قـرار دارد به عالوه شـعاع معلـوم قـوس 

ممـاس( رسـم کنیـد. 
کمانـی بـه شـعاع R-r2 )شـعاع ممـاس منهـای شـعاع 
دایـره‌ای کـه داخـل قوس مماس قـرار دارد( رسـم کنید.
از مرکـز ممـاس خطـی به مرکـز دایره اول رسـم کنید تا 

نقطـۀ ممـاس روی این دایره به دسـت آید.
از مرکـز ممـاس خطـی بـه مرکـز دایـره دوم رسـم کرده 
و امتـداد دهیـد تـا نقطـۀ ممـاس روی ایـن دایـره نیـز 

آیـد. به دسـت 
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رسم نما )در روش‌های مختلف(
رسم نما از قطعات در دو روش فرجۀ اول و فرجۀ سوم انجام می‌شود. فرجۀ اول را با علامت‌های 
E یا  مشخص می‌کنند. در ایران این روش متداول است. در این روش نمای افقی در زیر 

نمای رو به رو و دید از چپ در سمت راست نمای رو به رو ترسیم می‌شود.

  مشخص می‌شود، نمای از بالا در بالای نمای رو به رو و دید از  در فرجۀ سوم که با A یا 
راست در سمت راست نمای رو به رو رسم می‌شود.
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                         انواع تصویر مجسم

زاویه و مقیاس انواع تصویر مجسم موازی

نمای مرکزی نمای موازی

یک نقطه گریز دو نقطه گریزسه نقطه گریز نمای عمودی

ایزومتریک دیمتریکتریمتریک

کاوالیرکابینتکلینو گرافیکپلان ایلیک نظامی

نمای مایل

جنرال

نمای مجسم
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روش ترسیم دایره در تصویر مجسم ایزومتریک
مرحله 1ـ ترسيم خطوط محور

 كي  طوريك ه به  مركز  از  دايره  شعاع  فاصلۀ  به  محورها  با  موازي  خطوط  ترسيم  2ـ  مرحله 
متوازي الاضلاع تشيكل شود.

مرحله 3ـ ترسيم خطوط از گوشۀ باز متوازي الاضلاع به محل تقاطع محور ها با اضلاع
مرحله 4ـ ترسيم قوس هاي بزرگ به مركزيت گوشۀ باز متوازي الاضلاع

مرحله 5  ـ ترسيم قوس هايك وچ كبه مركزيت محل تقاطع خطوط ترسيمي از گوشه ها

ترسیم دایره در تصویر مجسم دیمتریک



34

ترسیم منحنی‌های نامنظم در تصویر مجسم

روش ترسیم دایره به روش نقطه‌یابی در تصویر مجسم
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ISO اصول و قواعد برش براساس استاندارد 
اصول زیر در مورد هاشور در برش باید رعایت شود:

 A3 و A4 هاشور با خط نازک رسم می‌شود. فاصلۀ هاشورها بین ۲ تا ۳ میلی‌متر در کاغذهای
مناسب است.

زاویه هاشورها معمولاً ۴۵ درجه است. هاشور به خط‌چین تکیه نمی‌کند. هاشور می‌تواند گاهی به 
خط محور یا خط نازک متکی شود.

هاشور از روی خط اصلی نمی‌گذرد. در داخل هاشور می‌توان اندازه‌گذاری کرد )در محل نوشتن 
عدد اندازه، باید خطوط هاشور پاک شود(.

هاشور در سطوح بزرگ می‌تواند ناقص باشد. در قطعات با ضخامت کم می‌توان به جای هاشور 
سطح را سیاه کرد.

فاصله داد. هاشورهای معرفی شده  به هم  را می‌توان کمی نسبت  قطعات کنار یکدیگر در برش 
عمومی است، اما برای برخی مواد هاشور مخصوص وجود دارد.
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انواع هاشور براساس جنس مواد

فولاد ـ فلزات سخت 
ـ چدن

شیشه و سایر اجسام 
شفاف

چوب در جهت الیاف

چوب در مقطع

شن و ماسه

غیر فلزات به استثنای 
آنهاک ه در جدول هست 
و همچنین برخی فلزات 
نرم مثل روی و سرب

بتن

بتن مسلح

آجر

مایعات

آجر نسوز ـ آجر 
ضد اسید

خاک
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ISO – 129 اصول اندازه گذاري مطابق
در نقشه هیچ اندازه‌ای نباید تکرار شود.

نقشه باید کاملًا اندازه‌گذاری شود و نیاز به اندازه دیگری نداشته باشد.
واحد اندازه‌گیری در نقشه‌های صنعتی میلی‌متر است و باید اندازه واقعی قطعه نوشته شود.

اندازه‌های کوچک تر قبل از اندازه‌های بزرگ تر درج شود تا خطوط اندازه و رابط یکدیگر را قطع 
نکنند.

فلش اندازه می‌تواند به خط اصلی و در صورت نیاز به خط‌چین تکیه کند.
اندازه‌ها را می‌توان در صورت نیاز داخل نقشه و روی نماهای مختلف درج کرد.

اندازه هر جزء باید در جایی درج شود که بهتر آن جزء را نمایش دهد.
اجزای یک اندازه باید تماماً در یک نما باشد.

اندازه‌گذاری طولی
 این اندازه‌ها شامل اندازه‌های افقی، عمودی و مورب است.

در اندازه‌های افقی عدد اندازه وسط خط اندازه و بالای آن نوشته می‌شود.
در اندازه‌های عمودی عدد اندازه وسط خط اندازه و سمت چپ آن )از پایین به بالا( نوشته می‌شود.

اندازه‌گذاری طولک مان، طول وتر و زاویۀ رأسک مان 
در اندازه‌گذاری طول کمان، قبل از عدد اندازه و یا بالای آن یک کمان گذاشته می‌شود.

اگر زاویه رأس کمان بیشتر از 90 درجه باشد، خطوط رابط اندازه به صورت شعاعی خواهد بود.
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اندازه‌گذاری پخ ها
پخ‌های 45 درجه با یک اندازه طولی مشخص می‌شود.

پخ‌های غیر 45 درجه با یک اندازه طولی و یک زاویه و یا دو اندازه طولی نشان داده می‌شوند.

اندازهک وتاه شده
اگر طول قطعه‌ای که دارای شکلی یکنواخت است زیاد باشد می‌توان آن را با خط شکسته کوتاه 

کرد اما اندازه آن باید کامل نوشته شود.

اندازه‌گذاری زنجیره‌ای
 در این روش تمام اندازه‌ها به صورت ردیفی روی یک خط اندازه مشترک داده می‌شود. انتهای 

یک اندازه، ابتدای اندازه بعدی است.
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اندازه‌گذاری پله‌ای
اندازه  خطوط  بین  فاصله  می‌شوند.  گذاشته  مبنا  سطح  یک  به  نسبت  اندازه‌ها  روش  این  در 

7  میلی‌متر است.

اندازه‌گذاری مختصاتی
در این روش اندازه‌ها نسبت به یک نقطۀ مشترک )نقطه صفر یا نقطه مبنا( گذاشته می‌شوند.

اندازه‌گذاری جدولی
زمانی  سوراخ‌ها  موقعیت  اندازه‌گذاری  برای 
که تعداد آنها زیاد باشد از این روش استفاده 
مرکز  موقعیت  بر  علاوه  در جدول  می‌شود. 
سوراخ می‌توان قطر، عمق و دیگر مشخصات 

سوراخ را نیز قید کرد.
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علائم و نشانه‌ها
علائم و نشانه‌هایی که در اندازه‌گذاری مورد استفاده قرار می‌گیرند عبارت اند از:

 )فی(: قبل از عدد اندازه قطر دایره نوشته می‌شود.
R : همیشه قبل از عدد اندازه شعاع دایره و کمان حرف ‌R گذاشته می‌شود.

S : قبل از درج شعاع یا قطر کره باید حرف S که مخفف )Sphere( است آورده شود.
°)علامت درجه(: در اندازه‌گذاری زاویه باید حتماً علامت درجه و در صورت نیاز علامت دقیقه و 

ثانیه درج شود.
□ )مربع(: اگر اندازه مربوط به یک مقطع مربعی باشد قبل از عدد اندازه علامت مربع درج می‌شود.

  ͡ )کمان(: در اندازه‌گذاری طول کمان قبل یا بالای عدد اندازه کمان گذاشته می‌شود.
SW : آچارخور را با حروف SW نمایش می‌دهند.
t : ضخامت قطعه کار را با حرف t نشان می‌دهند.
) (: اندازه‌های کمکی داخل پرانتز نوشته می‌شود.

ــ : زیر اعداد اندازه‌هایی که با مقیاس نمی‌خواند خط کشیده می‌شود.
][: اندازه خام و پیش‌ساخته قطعه را داخل کروشه نشان می‌دهند.

سفارش‌دهنده  توسط  خاصی  دقت  با  که  اندازه‌هایی  و  کنترل  و  بازرسی  اندازه‌های  گرد:  کادر 
خواسته شده است در کادر گرد قرار می‌گیرد.

کادر چهارگوش: اندازه‌های دقیق تئوری در کادر چهارگوش قرار می‌گیرد.
: شیب سطوح را به درصد یا به صورت یک نسبت عددی بعد از این علامت که جهت آن   

باید مطابق با شیب سطح باشد نشان می‌دهند.
: میزان باریک شدگی مخروط و هرم به صورت یک نسبت عددی بعد از این علامت نوشته   

می‌شود. جهت این علامت نیز باید مطابق با باریک‌ شدن قطعه باشد.
به نقشه‌های زیر که علائم فوق در آنها نشان داده شده است دقت کنید.
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خط راهنما
خط راهنما خطی است که به یک جزء اشاره می‌کند و اطلاعاتی را به آن نسبت می‌دهد.

اگر انتهای خط راهنما داخل جزء باشد با یک نقطه توپر نشان داده می‌شود.
اگر خط راهنما به لبه یک جزء اشاره کند با فلش معمولی نشان داده می‌شود

انتهای خطوط راهنمایی که به یک خط اندازه یا خط راهنمای دیگر اشاره می‌کنند فلش یا نقطه 
توپر گذاشته نمی‌شود.

در اندازه‌های مورب عدد اندازه طبق الگوی زیر نوشته می شود.
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وقتی طول خط اندازه کمتر از 10 میلی‌متر باشد فلش بیرون ترسیم می‌شود. عدد اندازه نیز اگر 
فضای کافی نداشته باشد می‌تواند در امتداد خط اندازه نوشته شود.

در اندازه‌های پی‌درپی اگر فضای کافی برای درج فلش توپر نباشد به جای آن از نقطه توپر استفاده 
می‌شود. در این اندازه‌ها اگر فضای کافی برای درج عدد اندازه نیز نباشد می‌توان با خط راهنما 

عدد اندازه را نمایش داد.

اندازه‌گذاری قطری و شعاعی
این اندازه‌ها شامل اندازه‌های قطر و شعاع دایره و کمان است.

اندازه‌گذاری شعاع با حرف R و اندازه‌گذاری قطر با حرف  نشان داده می‌شود.
خط اندازه یا امتداد آن باید از مرکز دایره بگذرد.

در صورتی که داخل دایره یا کمان جای کافی برای درج عدد اندازه و فلش نباشد می‌توان آنها را 
در بیرون درج کرد.

  را نباید فراموش نمود. اندازه قطری را به صورت طولی نیز می‌توان ارائه کرد اما علامت 
اندازه قطری با یک فلش و بیرون دایره نیز قابل ارائه است.

باشد  با نماهای دیگر تداخل داشته  یا  از کادر و نقشه بوده و  در صورتی که مرکز دایره خارج 
می‌توان با شکستگی خط اندازه آن را کوتاه کرد.

قبل از عدد اندازه شعاع و قطر »کره« با حرف S نوشته شود.
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اندازه‌گذاری زاویه‌ای
خط رابط اندازه در امتداد اضلاع زاویه ترسیم می‌شود.

خط اندازه کمانی است که مرکز آن همان رأس زاویه است.
بعد از عدد اندازه علامت درجه گذاشته می‌شود.

جهت و موقعیت عدد اندازه زاویه مطابق با الگوی زیر است.

اندازه سوراخ
اطلاعات مربوط به سوراخ را در صورت لزوم می‌توان با یک اندازه نشان داد.

عمق سوراخ با یک اسلش از قطر سوراخ جدا می‌شود )21/20(.
.)M10  × 1/5( گام سوراخ با یک ضربدر از اندازه اسمی سوراخ جدا می‌شود

طول رزوه و عمق سوراخ با یک اسلش از هم جدا می‌شوند
.)M14 × 18/23(
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 U سوراخ‌های پله‌دار زیر هم نوشته می شوند. اندازه بزرگ تر اول نوشته شده و عمق پله با حرف
.   مشخص می‌شود 

. در سوراخ‌های خزینه‌‌دار قطر بزرگ و زاویه خزینه ابتدا نوشته می‌شود 
 

اندازه‌گذاری عناصر تکراری
در اندازه‌گذاری عناصر و سوراخ های یکسان کافی است تعداد آنها را در ابتدای اندازه یکی از آنها 

ذکر کرد.
در عناصر تکراری یکی از عناصر به صورت مجزا اندازه‌گذاری می‌شود )مثلًا فاصله 20 در شکل زیر(.
تعداد عناصر و اندازه بین آنها نوشته می‌شود. می‌توان فاصله کلی را نیز به صورت اندازه کمکی 

قید کرد.

اندازه جای خار
اندازه جای خار روی شفت ب شکل زیر توجه 

کنید.
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Line l Home > Draw Pline pl Home > Polyline 

ترسیم پاره‌خط. هر بخش از خط به صورت مجزا قابل 
ویرایش است.

ترسیم چند‌خطی. یک موضوع یکپارچه مشتمل بر خط و 
کمان با ضخامت‌های مختلف.

Circle c Home > Circle >  Circle c Home > Circle > 

ترسیم دایره با تعیین نقطه مرکز و قطر.ترسیم دایره با تعیین نقطه مرکز و شعاع.

Circle c Home > Circle > Circle c Home > Circle > 

ترسیم دایره با تعیین نقطه مرکز و قطر.ترسیم دایره با تعیین دو نقطه قطری.

Circle c Home > Circle > Circle c Home > Circle > 

ترسیم دایره مماس بر سه موضوع.ترسیم دایره مماس بر دو موضوع با شعاع معین.

خلاصه دستورات کاربردی در اتوکد
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Arc  a Home >Arc >  Arc  a Home > Arc > 

ترسیم کمان با تعیین نقطه شروع، مرکز و نقطه انتهای ترسیم کمان با تعیین سه نقطه.
کمان.

Arc  a Home >Arc >  Arc  a Home > Arc > 

ترسیم کمان با تعیین نقطه شروع، مرکز و طول وتر.ترسیم کمان با تعیین نقطه شروع، مرکز و زاویه.
  

Arc  a Home > Arc >  Arc  a Home > Arc > 

ترسیم کمان با تعیین نقطه شروع، نقطه انتهای کمان 
و زاویه.

ترسیم کمان با تعیین نقطه شروع، نقطه انتها و راستای 
مماس بر نقطه شروع.

Arc  a Home > Arc >  Arc  a Home > Arc > 

ترسیم کمان با تعیین مرکز، نقطه شروع و نقطه انتهای ترسیم کمان با تعیین نقطه شروع، نقطه انتها و شعاع.
کمان.
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Arc  a Home > Arc >  Arc  a Home > Arc > 

ترسیم کمان با تعیین مرکز، نقطه شروع و طول وتر.ترسیم کمان با تعیین مرکز، نقطه شروع و زاویه.
  

Arc  a Home > Arc >  Rectang  rec  Home > Rectangle   

ترسیم مستطیل چندخطی با تعیین دو گوشه مقابل هم.ترسیم کمان مماس بر آخرین کمان یا خط ترسیم شده.

Polygon  pol  Home > Polygon Ellipse  el  Home > Ellipse >    

ترسیم چندضلعی منتظم با تعیین مرکز و شعاع دایره 
محیطی یا محاطی.

ترسیم بیضی با تعیین نقطه مرکز و دو نقطه رأسی.

Ellipse  el  Home > Ellipse >   Ellipse  el  Home > Ellipse >    

ترسیم کمان بیضی.ترسیم بیضی با تعیین نقاط رأسی.
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Hatch  h  Home > Hatch >    Gradient  gd  Home > Gradient >    

سایه‌زنی با کلیک کردن در داخل محدوده‌ها.هاشورزنی با کلیک کردن در داخل محدوده‌ها.

Boundary  bo  Home > Boundary >    Spline  spl  Home > Spline Fit >    

در  کردن  کلیک  با  بسته  چندخطی  یا  ناحیه  یک  ایجاد 
محدوده‌ها. داخل 

ترسیم منحنی با تعیین نقاط مختلف آن.

Xline  xl  Home > Construction Line >    Ray    Home > Ray>    

ترسیم خطوط دو سر بی‌انتهای ساختاری )افقی، عمودی، 
مورب، نیمساز و آفست(.

ترسیم نیم‌خط.

Point  po  Home > Multiple Points >    Divide  div  Home > Divide>    

تقسیم یک موضوع به چند قسمت مساوی.ترسیم نقطه.
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Measure  me  Home > Measure >    Move  m  Modify >  Move    

جابه‌جا کردن یک یا چند موضوع از یک نقطه به یک نقطه جدا کردن تقسیمات مساوی روی یک موضوع.
دیگر.

Rotate  ro  Modify > Rotate >    Trim  tr  Modify >Trim >    

حذف بخشی از موضوعات که با موضوعات دیگر برخورد دوران موضوعات حول یک نقطه.
دارد.

Extend  ex  Modify > Extend >    Erase  e  Modify >Erase >    

حذف موضوعات انتخاب شده از نقشه.امتداد موضوعات تا یک لبه مشخص.

Copy  co  Modify > Copy >    Mirror  mi  Modify >Mirror >    

ایجاد تصاویر متقارن موضوعات انتخاب شده.تکثیر موضوعات ترسیم شده.
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Fillet  f  Modify > Fillet >    Chamfer  cha  Modify >Chamfer >    

پخ زدن گوشه‌ها با طول و یا زاویه مشخص.گرد کردن گوشه‌ها با شعاع مشخص.

Explode  x  Modify > Explode >    Stretch  s  Modify >Stretch >    

تجزیه چندخطی‌ها و احجام صلب به اجزای تشکیل دهنده 
آنها.

کشیدن یا فشردن موضوعات در یک راستای مشخص.

Scale  sc  Modify > Scale >    Offset  o  Modify >Offset >    

کوچک یا بزرگ کردن اندازه موضوعات با ضریب مقیاس 
مشخص.

ایجاد تصاویر موازی با یک فاصله مشخص.

Array  ar  Modify > Rectangular Array >    Array  ar  Modify >Polar Array >    

ایجاد آرایه یا الگویی قطبی )دایره‌ای( از موضوعات.ایجاد آرایه یا الگویی سطری ستونی از موضوعات.
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Array  ar  Modify > Path Array >    Break  br  Modify > Break >    

بریدن بخشی از موضوعات.ایجاد آرایه یا الگویی مسیری از موضوعات.

Break  br  Modify > Break at Point >    Join  j  Modify > Join >    

اتصال خطوط و کمان‌های متصل به هم یا در راستای بریدن یک موضوع و تبدیل آن به دو موضوع مجزا.
یکدیگر و تبدیل آنها به یک موضوع.

Mtext  t  Annotation > Text >Multiline Text    Text  dt  Annotation > Text >Single Line Text    

ایجاد یادداشت یا متن‌های چندسطری.
 

نوشتن حروف یا متن‌های ساده یک‌سطری.

Style  st  > Text Style>    Dim    Annotation > Dimension >    

اندازه‌گذاری انواع موضوعات با یک دستور.ایجاد، ویرایش و انتخاب سبک متن.
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Dimlinear  dli  Annotation > Linear >    Dimaligned  dal  Annotation > Aligned >  

اندازه‌گذاری هم‌راستا با موضوعات.اندازه‌گذاری خطی افقی و عمودی.

Dimangular  dan  Annotation > Angular >    Dimarc  dar  Annotation > Arc Length >  

اندازه‌گذاری هم‌راستا با موضوعات.اندازه‌گذاری زاویه.

Dimradius  dra  Annotation > Radius >    Dimdiameter  ddi  Annotation > Diameter >  

اندازه‌گذاری هم‌راستا با موضوعات.اندازه‌گذاری شعاع کمان و دایره.

Dimcontinue  dco  Annotate > Dimension > 
Continue>    

Dimbaseline  dba Annotate > Dimension > 
Baseline>    

اندازه‌گذاری پلکانی در ادامه اندازه قبلی.اندازه‌گذاری زنجیری در امتداد اندازه قبلی.
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Dimedit    Annotate > Dimension > Oblique>    Dimstyle  dst  Home > Annotation > Dimen-
sion Style>    

ایجاد، ویرایش و انتخاب سبک اندازه‌گذاری.اریب کردن خطوط کمکی اندازه.

Layer  la  Home>Layers > Layer Properties >     Matchprop  ma  Home > Properties > Match 
Properties >    

اعمال خواص عمومی موضوع انتخاب شده به موضوعات لایه‌گذاری: ایجاد، ویرایش و انتخاب لایه.
دیگر.

Color    Home> Properties > Object Color >     Lweight lw   Home > Properties > Lineweight >    

تعیین و تغییر ضخامت خط موضوعات.تعیین و تغییر رنگ موضوعات.

Linetype    Home> Properties > Linetype >     Transparency   Home > Properties > Trans-
parency >     

تعیین و تغییر شفافیت موضوعات.تعیین و تغییر نوع خط موضوعات.
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Quickcalk    Home> Utilities > Quick Calcula-
tor >     

Measuregeom    Home > Utilities > Measure> 
Distance >     

اندازه‌گیری و نمایش فاصله بین دو نقطه.نمایش و استفاده از ماشین‌حساب علمی و هندسی.

Measuregeom    Home > Utilities > Measure> 
Radius >     

Measuregeom    Home > Utilities > Measure> 
Angle >     

اندازه‌گیری و نمایش زاویه بین دو خط یا زاویه یک کمان.اندازه‌گیری و نمایش قطر و شعاع یک کمان یا دایره.

Measuregeom    Home > Utilities > Measure> 
Area >     

Measuregeom    Home > Utilities > Measure> 
Volume >     

اندازه‌گیری و نمایش مساحت موضوعات بسته.
 

اندازه‌گیری و نمایش حجم موضوعات صلب.

Ucsicon    View > Viewport Tools > UCS Icon >     View Cube    View > Viewport Tools > >      

نمایش و عدم نمایش جعبه دید.نمایش و عدم نمایش نماد سیستم مختصات.



55

Navigation Bar    View > Viewport Tools > 
Navigation Bar  >     

Tool Palettes  Ctrl+3 View >  Palettes >  Tool 
Palettes >      

نمایش و عدم نمایش پالت ابزار.نمایش و عدم نمایش نماد سیستم مختصات.

Command Line  Ctrl+9  View >  Palettes > 
Command Line  >     

Design Center Ctrl+2  View >  Palettes >   
Design Center >      

نمایش و عدم پالت مرکز طراحی.نمایش و عدم نمایش پنجره فرمان.

File Tabs     View > Interface > File Tabs  >     Layout Tabs   View >   Interface >   Layout 
Tabs >      

نمایش و عدم نمایش نوار لی‌آت.نمایش و عدم نمایش نوار تب یا سربرگ فایل.

Box     Home > Create > Box Tabs  >     Cylinder    Home > Create > Cylinder >      

مدل سازی استوانه.مدل سازی یک مکعب صلب.
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Cone     Home > Create > Cone >     Sphere    Home > Create > Sphere >        

مدل سازی کره.مدل سازی مخروط.

Pyramid     Home > Create > Pyramid >     Wedge    Home > Create > Wedge >        

مدل سازی گوه.مدل سازی هرم و منشور.

Extrude   ext   Home > Create > Extrude >     Revolve  rev   Home > Create > Revolve >        

مدل سازی احجام دورا.حجم دادن به شکل‌های بسته دوبعدی.

Loft     Home > Create > Loft >     Sweep     Home > Create > Sweep >        

مدل سازی با استفاده از حرکت یک شکل در یک مسیر.مدل سازی بین مقاطع.



57

Presspull     Home > Edit > Presspull >     Union  uni   Home > Edit > Union >        

یکپارچه کردن احجام و نواحی، ترکیب احجام با استفاده برجسته و فرورفته کردن سطوح و وجوه مدل.
از جمع کردن.

Subtract   su  Home > Edit > Subtract >     Intercect  in   Home > Edit >  Intercect >        

ترکیب احجام با استفاده از فصل مشترک.ترکیب احجام با استفاده از کسر کردن.

Filletedge     Home > Edit > Fillet Edge >     Chamferedge     Home > Edit >  Chamfer 
Edge >        

پخ زدن لبه‌های مدل.گرد کردن لبه‌های مدل.

Slice     Home > Edit > Slice >     Mirror3d     Home > Modify >  3D Mirror >        

پخ زدن لبه‌های مدل.بریدن مدل با تعریف یک صفحه برش.
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3dalign     Home > Modify > 3D Align >     3darray     Home > Modify >  3D Array >        

ایجاد آرایه سه‌بعدی.تراز کردن احجام در مدل سازی.

Vertex     Home > Selection > Vertex >     Edge     Home >  Selection >  Edge >        

انتخاب لبه‌های مدل.انتخاب گوشه‌های مدل.

Face     Home > Selection > Face >     Solid History     Home >  Selection >   Solid 
History >        

انتخاب احجام زیرمجموعه مدل.انتخاب وجوه مدل.

Move Gizmo     Home > Selection >  Move 
Gizmo  >     

Rotate Gizmo     Home > Selection >  Rotate 
Gizmo  >         

دوران احجام حور محورهای مختصات.جابه‌جایی مدل در راستای محورها یا در صفحات مختصات.
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Ucs     Home > Coordinates >  World  >     Ucs     Home >  Coordinates >  X  >         

چرخاندن سیستم مختصات حول محور X.برگرداندن سیستم مختصات به حالت پیش‌فرض.

Ucs     Home > Coordinates >  Y  >     Ucs     Home >  Coordinates >  Z  >         

.Y چرخاندن سیستم مختصات حول محور.X چرخاندن سیستم مختصات حول محور

Ucs     Home > Coordinates >  3 Points  >     Ucs     Home >  Coordinates >  Z  >         

فراخواندن سیستم مختصات قبلی.تعریف سیستم مختصات با استفاده از تعیین سه نقطه.

Ucs     Home > Coordinates >  View  >     Ucs     Home >  Coordinates >  Face  >         

تعریف سیستم مختصات منطبق بر یکی از وجوه مدل.تعریف سیستم مختصات منطبق بر نمای جاری.
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Ucs     Home >  Coordinates >  Object  >         Base     Layout >  Create View >  Base  >         

نماگیری از مدل )ایجاد نمای پایه(.تعریف سیستم مختصات تراز با یک موضوع.

Viewproj    Layout >  Create View >   Project-
ed   View >         

Viewsection  Layout > Create View >  Section 
View  >         

ایجاد نماهای برش‌خورده ارتوگرافیک از نمای موجود.ایجاد نماهای ارتوگرافیک از نمای موجود.

Viewdetile    Layout >  Create View >   Detile >         Viewedit     Layout >  Modify View >  Edit 
View  >         

ویرایش نمای موجود.ایجاد نماهای جزء یا دتایل از نمای موجود.


