ek, =g

sl giws 5l eolaiul ch
.| .

3

2‘5)&5) ‘SLQJM
il b, asly ol (il )35 51 e 51,8

o] el

v




i ot 051y -

LINE le ol o peebaZo)ly oyl o cnl 5l eslaal b -
3959 Sl by 4ed l aly o ) nl slp oS

Ribbon :Home tab» Draw panel » Line e el labais ol

Menu :Draw » Line

Toolbar :Draw /

= Command entry :line or |

el Lyl BB 9,409, slo o, 5l (S 4 j90ms ol

COMMEANG: LINE correeremmeeereeesssimssesseeesssssssssssssessssssssssssssssssesssessssssssssssssssssessssssssessssssssssees s (gl )
Specify first point: oo (Sl 00l SIS gl byl o p0d 40 ) S aseiio |y ol alads -Y
Specify next point or [Undo]: 4 e (pgo alaii) .auS astive | son alads -Y
Specify next point or [Undo]: 3 v (pgw aadl) WuS jasive |, gox aki -¥
Specify next point or [Close/Undo]: 4 ... (ool ahai) S asin|) gow ahii -0

Specify next point or [Close/Undo]: ¢
adats 4 alads 1,31 ol oS 0,88 g leyd b 0 C B> ol g Close jgiws 5l soliul b ¢
gl se @ s 5l il alS (50,88 L & jgoinl 28 )3 5 e pled jgiws 5 ode )

next point L=4 3next point
< el 0o soliwl O1tho lpl 51 IS cpl s 5 50 -

™ ™
I 1
— + * —

Close 5 — 5

1 L=4 next point

start point

S a5 03,5 iy sative bl 59, LipSe 095 e el : Snap = F4

oS o bl gz o sl s 59,58l b b |, sogas g bl bghas aslsi oo 2l oyl 45 : Ortho = FA
D9 0L Jloasgly bglas v 5 Cae o 390 oo el 3l ol - Polar Tracking = Fy o

Aok 5 03,5 B> I loyd Las S o 4 algs o LIl cpl 5l eslazsl L :Dynamic Input = FyY
« Polar Tracking 4 Ortho U 5l cpl auics poai axio 0 |, oSl slaply 5 (539,9 Sledlbl
S oo 5 sy

Dg g0 0010 sl JulS jeb 4y Sty e ;0 YU o oal ol 3

YA
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XLINE ol B 3o s P B e utes ol Sl esliil -
Ribbon :Home tab» Draw panel » Construction Line Mb WLG‘J‘-?

Menu :Draw » Construction Line

Toolbar :Draw /

oo .
B3 Command entry :xline or x|

Ll Lzl BB g9, slasog, 51 (SO jgiws ol

Command: XLINE vl ) 5w (G121 =)
Specify a point or [Hor/Ver/Ang/Bisect/Offset]: - b 1S 0 lgicds dads SO 40,5 adein -V
SPECIfY throUGh POINET oeeeeeeereeeeerercesisreseessesseseessssessesssesessssssssssseessesssssessssseseesss pgo alads 0,8 3l -V
Specify through POINE: oo pow aladi 50,5 5l -
Specify through POiNt: ..o oolez abhis 0,5 o190
SPeCify throUGh POINt: e oy aladi 18 ST lg -F

COMMEANG: XLINE  ceeeeeereeereceesusmeeeesssmnessssssnessssssneessssssessssssssesssssssnessssssssessessssnssssssnesssssssessssssnssssssss gewd gl
Specify a point or [Hor/Ver/Ang/Bisect/Offset]: h .o a8l a8 5l eolatl

;58 Hor —
S5 oo mmms 5 g g2 b 58 B8l s S S aseiea ) (slabai 45 i sl a3 ol 5l eolial

i35 Ver -
N
wawfw%@d#sor{alﬁb&’c..\.u.SGSJMbd‘dbmdsds.?w.«odb)b@;w‘)‘oéw‘b

Y4



Slasle gbaisi g o5gil R D L

DS o 5 ol o B,k 90 Sl jatuine asgly b s G alg e a5 ol 5l eolaiwl b aggl; Ang -

ComMMEANd: XLINE  coeeeeeeessmmmseessesssmssssessssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssss D ygiwd gl
Specify a point or [Hor/Ver/Ang/Bisect/Offset]: @ i agly an S
Enter angle of xline (0) or [REFErenCe]: 45 s L agsly 59,5 3l
SPECGify through point: = alads S 0,5 atein

leews Bisect -
S e ) sl wim b So sl 0l oe a5l sl eslasal b

Command: XLINE sy gosd (§]y2]
Specify a point or [Hor/Ver/Ang/Bisect/Offset]: h s Sl 435
SPECify angle Vertex point; aqly u*j) OO, At
Specify angle start point; = asly dlo sl 63, alais Sy 3,5 At
Specify angle end point; asl; c.La e (59, aladi S 0,5 ez

Start point

Vertex point

ol b slse o5 Offset

Command: XLINE Specify a point or [Hor/Ver/Ang/Bisect/Offset]: 0 -wweeeees Silge (5 anS
Specify offset distance or [Through] <30.0000>:  -ooooovviiiivininiivnnnnes Silse oS alold 5,5 o lg
Select a ||ne ObJeCt .............................................................................. 09».) LSS CA.M.»‘ )‘]é 45 ‘SCWBA %JBLG‘
Spec|fy side to offset: o}w ﬁL?u‘ Lg.f S )‘)9 as N uo)f ua;v.w.a

P

¥fo
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el ""’LQ"LS' & C)‘ L;l.e‘;l.u‘ ‘;5 B Q‘ L;‘..\S.g‘ as
Ribbon :Home taby Draw panel » Ray
Menu :Draw » Ray '//‘ o ‘)}‘ k)"b 979 L;LQL)’"?) )‘ é" a )3:'”"& U"‘

= Command entry :ray

COMMANG: RAY  ceeeerrmrsssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssss Lygiwd (gl ! =)
SPeCify Start POINt: e Eoyis alads 10 S aseie -V
Specify through point: e 5,38 o ol 89, 5l g oo JuSis oz a5 glalais 0,5 asuie Y
Specify through PoiNt: e G alady 10,5 aseie -

Start point

KWLy los SO dusles wwd ool 3l solaiwl b -

= TRACE )‘95 PO - M;‘-’uﬁ-")ﬁ-’ - 9-&5" )5*-“’" A ) ‘
JSiS aygly awlez oo ez (g (o8 do 4 jets o

Sg ol Cde g § )0 adall SO dliad s asii 1) s

Command: TRAGE s g (gl,>l =)
Specify trace width <1.0000>:3 s b by 0,5 atin =Y
SPECIfY Start POINT: (1) ooeoeeeeeeeeeeeeeeeeeeeeeeeses e eeeesssssseseessssssssesssssesssssenes (V) £gyi alais 820 -V
SPECITY NEXE POINE: (2) oo seee s sese s eses s (V) o aais 3,0 ¥
Specify next point: (3) ) | — (¥) o alaii 3 ne -0

5

Start point
4 3

R
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CIRCLE ol Sl b1y o plo ailes o ygiws ol 5l oolaswl b -
DS w5 ] calisee bl 51 ledlb|

Ribbon :Home taby> Draw panel » Center ,Radius
Ll 1,1 LB b oy, 5 L Hgwd Oy
Menu :Draw » Circle — JJ 979 SRO9) ""SJ POFt O

| )Ja_9 Diameter |

T

Toolbar :Draw I"r"":h
L

-.- Command entry :circle or ¢ T

oﬁ‘o C‘f)

Command: CIRCLE  crreeessssmssssesesssssssssseseeens el aliwgds 0 1o o )i 1 jgiwd (gl =)
Specify center point for circle or [3P/2P/Ttr (tan tan radius)]: ... o pls 35 0 40,5 astine Y
Specify radius of circle or [Diameter] <1.0000>: 2 vrmrrssmrrssinrissneees opls glads 0,5 5,9 Y
1 Radig S E88 g gy Jle 4

2
Command: CIRCLE  cerermmmmsmesessssssssnesssssssssssnsssssssssnns s aliwgds 0 1o s i 1 gt (gl =)
Specify center point for circle or [3P/2P/Ttr (tan tan radius)]: ... opls 35 0 30,5 azin -V

Specify radius of circle or [Diameter] <1.0000 >: D

il oS 0,28 g 48 4T sl eslatwl gl D ST ol -Y
Specify diameter of circle <2.0000>:4 5 Jake 5 o s ¥

O, du..».{ RS 959, JL..O 4 3k

Y
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o) bame (59, alais aw il bopls o i TP (Three Points) -
Specify center point for circle or [3P/2P/Ttr (tan tan radius)]: 3P

Specify first point on circle: (1) . opls Lo (59, alaii gl 40,5 atie Y

Specify second point on GIrcle: (2)..........rrscsrssrsecsee aads yaogd (40,5 astine -

Specify third point on circle: (3) 1

b SO g, wlo aladi aw ol aS 0uS dxgi o

3P
2P (Two Points) —
sl ol lad g0 A;J‘sssn aladi g0 cpl o plo laxe (g9, aadi g0 ilo Lo gls o

Specify center point for circle or [3P/2P/Ttr (tan tan radius)]: 2P ... YP s 5 olbsesl -
Specify first end point of circle s diameter: .. opls yhad il alads (Jol oS asin -Y
Specify second end point of circle's diameter:

................. ay‘.)).’aﬂ‘s:l;bmué; S =Y

2

2P
TTR (Tangent ,Tangent ,Radius)

el SO g wlew 90 (blo bopls g

Specify center point for circle or [3P/2P/Ttr (tan tan radius)l: TTR .. TTR as ;5 Gl -\

Specify point on object for first tangent of circle: .. o pls wloe pdgl 40,5 aseine =Y

Specify point on object for second tangent of circle: .. 0515 Lolon ymagd (33,8 aseiue —Y

Specify radius of circle <1.8000 >: 2 opls glads 0,5 5 )lg - F

1 Radius=2

Radius=2 1

tan tan radius
Yy



slasle sbaidi g useil e

Ribbon: Home taby> Draw panel 3 Tan ,Tan ,Tan 2979 ployp bz )0 0 pls e i S h9) 9z

S L0 ) 5009, e Sel S ey 00l
Menu: Draw » Circle » Tan ,Tan,Tan

TTT (Tangent, Tangent, TANGENt) s oobes dus ilo Lo o w3 -
D4 a5 010 0 LS el olows Loy | 5 0 1o 45 gad90 dw (59, ol (B a5 ) Sl L

2
1
1 : JL"“ ke
3
2 3

Center
Radius
1 2
S gl
Center , Radius 2P (Two Points) 4k 52
3
Tangent
1 2
abii 4w 3p (Three Points) TTR (Tangent ,Tangent ,Radius)

£
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ARC GleS e IS o5 OleS Sl oo Hims Sl eslaal L
Oleyp b3 30 S e slaghy, 4o 9z

Ribbon :Home taby» Draw panel 3 3-Point S Byb ) et cpl el g o)l 979
Menu :Draw » Arc ooliinl (yloS pn 5 Ghgy 093k Sl 5 0S8 ‘)-'.’i:;‘

Toolbar :Draw f

= Command entry :Arc or a

;
(¥ g L=
Snet, Cinitind, DA

Sat, Covaes, agle:
s, Camtes, Langin

Lemt, End dngle

5wt End Domben
Samy, End Reden

Comvim, T, [
Gy, S, Sy

TAAS ATTR ARAD

oS Glasin -

E
£

;
4

Chord Length
kb akis End

oS 3, Center

o



Slosis b Lo i g o5 gil

COMMANG (ARG crreeeeemsmmmesessssssssmeesssssssssmsesssssssssssessssssssssmasessssssssssaessssssssssnsssssesees ObeS jews gl >l -)
Specify start point of arc or [Center]: e Ol Egypi aladi 0,5 jaseio =Y
Specify second point of arc or [Center/End]: - oS g aads 0 ST jastin -V
Specify end PoiNt Of @rC: e oS SLL ahis 0, asis . f

( Start' Center'End ) -
ObL 55y (g9 b alals Slaseiia (1Sl b (oS oo

OleS g9,% alali 3 5 aseie -)

ObeS 35 30 99,5 asine =Y
3 2 oS bl oS aseie Y
End 1

Center Start

( Start' Center ' Angle ) -
OleS g9y abai (0,5 azedis -

1 ObeS 3550 03,5 pasudee -V
Start oS agly 0,5 0)lg =Y

OleS aiS 3)ly (i 1) GleS sl ST
Center D9l g JoSLS uSe Zu 5o

( Start ' Center ' Length ) -
59 ok 55 e o, alali Slaseine (1Bl b GleS e 3
OleS g9,% alali (3 5 Azl -)
ObeS 35 30 9,5 asine =Y
OleS Sy Job 2,5 o)ls ¥
Length

Start

\

Center

s




o2k 515 9>y

( Start' End ' Angle ) -
42315 <0l < b 4l Dlasetin (18I b 0aS rms 5

Eoy alais 3,5 jasine =)
End v ! Sbb abis (50,5 Lasuive -V
’ Start ObS asly 53,5 8,1y =Y

( Start ' End 'Direction’) -
oy alais p oles Lo (L o8 abaki Slaseie 23 b Gl pen 5

30 R
YR ol bl el g8 Y
/,(')'o

Sz Gess -V
End Start

( Start' End 'Radius ) -

el (Ll gy alads Olasein (il b LS s )3

QLJ&)&MQo;QM—\

2 o 1 Okl ahd (9,5 (asie =Y
<
®

Ol gy 9 39800 S OleS Cuz WS O)lg wSen | (L g g9y0 abali gl 2l Gl ST

( Center ' Start'End ) —

OS5 30 59,5 pasie -
; Eort ahail (13,5 jasie -V

g ol alais 55,8 asie Y

Start

Center
v



i ot 051y -

( Center " Start 'Angle )
gl (Eay Sy aladi Slaswine dlo b GlaS guw )i

OS5 0 (8,5 At -

’ Start oS asgly 0,5 5 lg =¥
1
Center

( Center ' Start 'Length ) -
F9 dob 5 955 55 e Slasine b b GleS oo 5

3 OleS S0 (53,5 i -)
Length 2 OleS 9,8 alali (3 5 [aseie -V
>1</\Start Fydsb 5,5 o)ls =Y

Center

( Continue ) -
OO 3y b g o9 ce Jog GLeS L a3 g5 5l o v 5 abas (3T 4 093 leS g (g cnl o
223 oo bl o> 5 4 gum abads
Command: _arc . . e s
g oo ey 4l 90 b oleS (l @Bl 5o
Specify start point of arc or [Center]:

Specify end point of arc:

2
1 /2 1
End Start Y End Start

Line or Pline or Arc

\ / S o5 5ied Cnl lage, Sl S bl e 5l S e

A
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PLINE S>> e ) Sty Ol b b s g o Hews pl 5leslaul b -
kS s Jos o2 @ izl () 45 05 oy oo e
Ribbon :Home taby Draw panel » Polyline slcwbes L Q‘53t5'° I b o pl wbl o

Menu :Draw » Polyline b g colus (g5 o0 (S0 90,5 oo M
Dgad Ol 1) byl
Toolbar :Draw __:;

= Command entry :pline or pl

COMMAN: PLINE e sssssssssss s ssssssssssssssssssssssssssssssssssssssssssssssssssssssssssses g gl =)
ST e 11 A 21 10 1| R ———— Jol alais 0 S jasie -Y
Current line-width is 0.0000  --wreeressssmsmssmsmssseeeeesesssssssssssssssssssssssssssssssines ShFais Cubs 1 158 &l
Specify next point or [Arc/Halfwidth/Length/Undo/Width]: 4 - pgo ki 0,5 jasie -

Specify next point or [Arc/Close/Halfwidth/Length/Undo/Width]: 2 9~ aladi 0,5 jasie -¥
Specify next point or [Arc/Close/Halfwidth/Length/Undo/Width]: 4 = e o ke aladi -0

Specify next point or [Arc/Close/Halfwidth/Length/Undo/Width]: C
Lol alass g locul aads e 9 C 2SS 51 oolizwl L -#

. L=4 2 .
next point next point
-—

o\ o\
I * * I
— —

Close X_start point

4 —» 1 Arc —

Ol jeiwd (slaysild dan auS eolaiul 50 leS 5l edad a5 a0 j0 wlg o 43T ol 5l eslaial b
A5l glawas Lol 4o

Close —
Al albls dny datais SO ales o 43S ol 5l eslatll

Halfwidth —
DS asin |y s Culis aal 0lgs oo 4 S cpl 5l eolaiul
Specify starting half-width <2.5000>:3 ... AuS jasie £oyh a0 |y Sl aai )
Specify ending half-width <3.0000>: ... S aseie Gbl ahds o) cwlho aai -Y

- j: Halfwidth

4



e gl 5 055 S

Length —
S8 ol b Job @ (L8 b o wlyion b 5 0o 5 a5 nl sl ool L

Specify next point or [Arc/Close/Halfwidth/Length/Undo/Width]: L ... Job 435 5l eolaiul

Specify length of [IN€: 20 s AuS ylg 1y as Jeb yals adlal e

/’/
1 2 Undo —

28,5 5l e 4y Al e S als oo 43Sl Sl oslaal b

Width —
WSS 0lg 1y b culs S ailgs oo a5l 5l eslal b

Specify next point or [Arc/Halfwidth/Length/Undo/Width]: W ..., Ly 43S 5l oolaul
Specify starting width <1.0000>: 3 il e Sslite wa b bl 5 £grd 5o b s Jlie cpl 4o
Specify ending width <3.0000>: 8

Starting width = 3 i ‘ :]:E”ding width = 8

Specify starting width <3.0000>: 8 el sl il 5 oy Al s L caali e ol o

Specify ending width <8.0000>: 8

Specify starting width <8.0000>: 0 Al )5 5 a0 abis s bt caalied e cpl 0
Specify ending width <8.0000>: 8 bl se St SLLG

ol oad pg e S LSas el b i Jlie oy

Starting width = 0 < :]:Ending width = 8

Do
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RECTANGLE ax LS Jibies & b dhins alg go jeiws (pl 5l eolasal b
S o 5 Az LSS

Ribbon :Home tab» Draw panel » Rectangle

Cwlylo 1) o Jadaiz cools gy o)
Menu :Draw » Rectangle ’

Toolbar :Draw E

cm 3
o Command entry :Rectangle or rec

Command: RECTANG  ceerrrmmssssesmssmssssssssssssissssssssssssssssssssssssssssssssssssssssssssssssssssssses Hgewd gl =)

Specify first corner point or [Chamfer/Elevation/Fillet/Thickness/Width]:
o,z adsS gl (9,5 ateie Y
Specify other corner point or [Area/Dimensions/Rotation]: @70,30
ol 00l oolainl s g, 3l ] jo (pgd dlgS 0,5 asuine -Y

2/ @70,30

o
M

First corner

70

—4—

——

Area
S 5 E5ose crbas (5558 85 b el 45l 1) alo Loz ol Lo aS e a3 ol 51 oolial L
D9l oo o (o2 ez e ]

Specify other corner point or [Area/Dimensions/Rotation]: A ... Colune 435 olasl -)

Enter area of rectangle in current units <230.0000>: 120
ool AdST 10 188 g Coluce (0,5 o)lg Y
Calculate rectangle dimensions based on [Length/Width] <Length>: L
Ao Slas ) ol adS awm g ]y oye b aaS o)lg 1) b aales o auS asein -V
Enter rectangle length <22.0000>: 10 e AS 8lg |y Jsb Jlade -F

S=120m’
1
10

First corner

O



Sl slaaiils 5 o5l P
Dimensions —
S bl IS cam calyd 10 g 00uwp alBlax 1) oy g Job ade wSgl an S ol 5l ool b

Specify other corner point or [Area/Dimensions/Rotation]: D ... Lo 31l ass 35 el - )
Specify length for rectangles <20.0000>: 22 oerrveivenressssinenennnns Jsb Jlade 50,5 o,lg -Y

Specify width for rectangles <15.0000>: 16 e 2 lade 0,8 5 lg =Y

Specify other corner point or [Area/Dimensions/Rotation]:
MSWLNQ&AJPL‘)GA@)LQ}MP—\C

I
To
= 1
First corner
22
length
Rotation -
Ot asly b (ldjlez (b o B oS o)y ) (bl 2552 jlade wilgs e S cnl sl eslaal b
Sg o i 00D
Specify other corner point or [Area/Dimensions/Rotation]: R ... LSy a5 ol -
Specify rotation angle or [Pick points] <0>: 45 e agly Jlade 43,5 o)lg =Y
Specify other corner point or [Area/Dimensions/Rotation]: oo Jgl &S 18,5 Laseine =Y
Command: SpGley Opposite COMNEL: coeercerermsommamsinisissimsetssamsssssuasssssassssssassssssass £y M; uo; 9)15 -f

First corner

oY
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Chamfer —
3l & s O slaaiss a5 w3 ol ez il a3 Cal 5l eslial L

Specify first corner point or [Chamfer/Elevation/Fillet/Thickness/Width]: C = 4035 ol -)
Specify first chamfer distance for rectangles <5.0000>: 8 = - g abold gl oS 05l =Y

Specify second chamfer distance for rectangles <5.0000>: 8 & alold pwgs 3,5 8 lg =¥
8

‘_\ First Distance

OOT Second Distance

Fillet —
Aol alils o5 sledlgS a5 auS e i 2o i ».\.u‘s.:‘sc ‘&L’..is Sade pudaid g a5 ol 5l eolansl b

Specify first corner point or [Chamfer/Elevation/Fillet/Thickness/Width]: F

............................ aheS 0,5 elad Jlade (0,5 o)l Y
Specify fillet radius for rectangles <8.0000>:

@
Fillet Radius

DS o 5 B ) 2ok bshs auly oo a5 cnnfidse! b

Specify first corner point or [Chamfer/Elevation/Fillet/Thickness/Width]: W
................................ b Cols Jade 0,5 o lg =Y

Specify line width for rectangles <0.0000>: 2
WDl )55 s adgl Sl a4 1YL sloas 35 slaedas oS Sloj U rasgise
width

1,

-

width Silo oo (B Hgiws (59, lapudass oyl
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. X B Poligons ol ] eslas!l b

POLYGON phie alodis o u’| 5 -k
O'P Pog=°

Ribbon :Home taby- Draw panel » Polygon /\ )'| ‘5"L°g5’J“‘““'>
VoVF b oo ¥

Menu :Draw » Polygon

. 255 o s
Toolbar :Draw |

= Command entry :Polygon or pol

COMMEAND: POLYGON  cooeeverrrmessisssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssss g gl -
Enter number of sides <4>: 6 sues )Lid |, sl adS g osS Jasin |, (aloais edol sloas -¥
Specify center of polygon or [Edge]:  -eerererremsmsssssisiisisiseeeeeeee S atin |y aloais S e =Y
Enter an option [Inscribed in circle/Circumscribed about circle] <I>: |

(Dgd o0 2,8 opld 1o blxe alodiz iy, (pl jo) ( dblxe g, ol -F
SpecCify radius Of CIFCIE: 8 wereeeeeeeeeeeeeeeeseeeeeseeseeessssssssssssssssssssssssssssssssssssssssssssssssssssees opls gl 0,5 54l9 -0

*

X Xz X ke

Radius Radius
Inscribed in circle Circumscribed about circle +

Enter an option [Inscribed in circ]e/Circumscribed about cirgle] <|>'¢c . '
(09.“6,4; 0)‘,"0 x Ja'“'?u G*J"éw P9 u" )5) ‘(;IG-A-?-A,, P9 ubu..,‘ -¥

Specify radius Of CIrCIE: 8 ... opls glads (50,5 0,15 -0
i Edge —
23S e Ol e sk Gosbo I (rldaiz adlgie 43S ol sl eolizul b
Specify center of polygon or [EAQe]: E v o 4§ bl -)
Specify first endpoint of edge: oo alass gl 0,5 asie Y
Specify second endpoint of edge: 16 vocccrrrirrccerriesnececereniesees Sbb aadi 0 5 5 ls -V
First Point =3 Second Point

Of
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A SN T S B

Jses Slgd (o0 )5
4 a5 3 sk dgzar sasbe

Revision Cloud =k

Ribbon :Home tab» Draw panel » Revision Cloud

Menu :Draw » Revision Cloud ls )L"’ Sy ooy

[ o |
Toolbar :Draw ool

om .
rox Command entry :revcloud

COMMANA: FEVCIOUM  rrrrerrereerernesrssssesssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssenes Hgwd gl =)

Minimum arc length: 0.5000 Maximum arc length: 0.5000 Style: Normal
5l lapelass 1 G515 sl =Y

Specify start point or [Arc length/Object/Style] <Object>:  ......... Egyn aladi 10,5 aseie -V
Guide crosshairs along cloud path... .. Sgd on dlul ol plamas o LS oS > L -
Revision cloud finished. ... Do oo s g 0l S ol ¢ Jol adads 4y Lad)So 90,5 Soo 5 L -0
/‘\/‘f/‘ (s glgS Joe
Style =Normal Y Style =Calligraphy
AT ~ ~ Arc Length —

DS ez |y bapleS Job jiSTas g Jlas ales e 438 ol 1ol b

Specify start point or [Arc length/Object/Style] <Object>:a . oS Job an 8 sl -)
Specify minimum length of arc <5.0000>: 8  -werrrsmrssvrsnrsson oS Jsb J8las 0,5 04lg =Y
Specify maximum length of arc <8.0000>: 12  ereveessemnenseesssss oS Job giSlas 0,5 o lg -V
Object —

S R Gl Rl ]y 4z lSs slaggdge asil oo an S cnl 5l eslanal L
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5 30,5 1 s 5 dzio 45 5 obsL |, Brase jgiws lwg ool Bi> g5090 0,51 il o OOPS jgiws
Sl 6,3l gadae cpl (g9, Erase jgiwo jloslaisl jl arisds e lade

Yy
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Copy legsoges 3l sylop aeai b (o5 Eyoge 5l s iz b S wSlgi oo st cnl L
’ S S | e bk

Ribbon :Home tab» Modify panel 3 Copy
Menu :Modify » Copy w‘ ‘P‘ J.tlﬁ 9)4"5) GL‘”u’"ﬁ) )‘ L;" b )9:"“") L)"‘
Toolbar :Modify ':-f',;

Shortcut menu :Select the objects to copy ,
and right-click in the drawing area .
Click Copy Selection.

Command entry :copy or co

COMMEANd: COPY  commssssmmssssmsssssssssssmsssssssssssssssssssssssssisssssssssssssssssssss s sssss gewd gl =)
Select objects : 1 found s (Egog0 bl Globs,) bEgoge b ggoge wlswl -Y
SElECt ODJECES 1 coovoeeeceeeeeeeesissssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssens sl oS 0,8 L el ML: _y
Current settings : Copy mode = Multiple e oS g it 5l 1S &)

Specify base point or [Displacement/ mOde] < Displacement>:

S o sl (lgreas abais S Ol Y

Specify second point or <use first point as displacement >:

S 7o ahts flgiedas pgo alais CLsl -0

Specify second point or [Exit/Undo] < Exit >:

5 95550 oy b 2 poo ala g w3gumel (o (S 23l oo Mulltiple 4S5 05z
DS s o ahts lgieas | g0l slaalass ailyr oo Lo

base point
4 o
2
2

Mode -
b ogd oo el anyS opl ol
0055 (oS Ry 9SSl L
gamal b ail SO

(Al
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Move laggoge (15,5 ral> Sl Glaggoge b gad5e aiilyi oo j5ims nl L
S Ll g 5 amio ) |, a0l

Ribbon :Home tab » Modify panel » Move
e ——— el 12l BB g g5 slashe, 51 S b ygims
Toolbar :Modify —E-.-

Shortcut menu :Select the objects to move ,
and right-click in the drawing area .
Click Move.

Command entry :move or m

Command: MOVE vttt )G LS‘)" -\
Select ObJeCtS 1 found ................................ (&9@5.0 AT)l?L;.J" Glﬁwa)) lﬁws& l% 69.&5.& ;'Al?c.u" —Y
SEIECt ODJECES : o Sl oS 0,28 b el b ol al -

Specify base point or [Displacement | < Displacement>:
s sl lyea abis S Sl -F

Specify second point or <use first point as displacement >:
Qaie aadi lgieds pgo alats Ol -0

base point

Yo
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MIRROR sl g ol 5 ble wrlee wile plaglasle wis o
50 e 4B Glaile I end 45 )l

Ribbon :Home tab » Modify panel » Mirror 2,5 oolaiwl jaiws cpl 5l les o il o
Menu :Modify » Mirror )
Toolbar Modity /]l 2l Glhas jyiwd cnl jo CoS anl lgd

Command entry :mirror or mi

Command MIRROR .................................................................................................................... 1)9:».».0») LQ‘).’?" —\
Select objects 1 1 fouNd e lggoge b goog0 bl =Y
SeleCt ODJECES & v il oS 0,8 b bl ML -y
Specify first point of Mirror iNe: e anl s sl adais fpdgl 0,5 asin -
Specify second point of mirror line: ... anl sl adas fpegs 48,5 asuie -0
Erase source objects ? [Yes/ No] <N>:

4X sl aulds - aﬁsppbowdpwlwyblf

i —_— _— _—
2 || -
5

Erase source objects ? [ Yes/No] <Y>:

4 sl ads - oﬂ5¢pbowd»&@|é}@5ﬁbl\/

:Z/Z/M H\:
5 —— | —
Command: Mirrtext ..o lodiis oo aisl 390 1O  soltw uiio
Enter new value for MIRRTEXT <0>:1 erererererneeenns Ml.s‘sn sSJ 9 ).9..4 SAE 9Oy ).u.?.o u.s‘
R3
W+12V vgr+<]WH +12v<]WH
10k AOT 10k
MIRROR MIRROR 3l s MIRROR 5l as
MIRRTEXT 1 MIRRTEXT = O

\id
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ROTATE laggoge (i, b oly90 Sl slaggoge duiles oo jgiws (pl 5l oolaiul b
A oles alads G j0 |y oall

Ribbon :Home tab » Modify panel » Rotate

Menu :Modify )» Rotate JB g,y sloss, 5l o 5l eslaul b g (5l
Db o 1y
Toolbar :Modify O et T

Shortcut menu :Select the objects to rotate ,
and right-click in the drawing area .Click Rotate.

Command entry :rotate or ro

Command: ROTATE s )G LS‘)'." -\

Current positive angle in UCS : ANGDIR = counterclockwise ANGBASE =0 )
O9d &30 9 090 Lz 9,90 50 (5,155 &l

Select objects : Specify opposite corner : 1 found s loggoge b ggog0 ool -Y

SEIECE ODJECES | vttt sl alS 0,28 b Sl al -

Specify base PoiNt s 3190 35 pe Hlgreas alnds SO Slesl -f

Specify rotation angle or [Copy/ Reference] <0>:90 e e asgly 9,5 8 )ls -0
S/ S/

base point

ANGDIR = counterclockwise ANGBASE =0
Cote Zelo slaayie D Gligs Cuzr ¢ oligs asly £9,5 @z

s poss Unit jgiws g,k 5l b g Command & ,b 5l oslgs oo |y jexie 98 0l

Yy
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Copy —
Aapd ol g0, u,J,‘al J PARE Mly‘sfa ainyS ool 5leslaiwl b

Specify rotation angle or [Copy/Reference] <0 >: C Rotating a copy of the

selected objects. ol bl 9090 5l oS SG g0
Specify rotation ang|e or [Copy/Reference] <K2T70>1 s Q‘)S’) Qg‘j Qo; o)|9

2 — > \ / - s
4 base point

5X

Reference —
Db ooy sl ple laggdge ()90 a0 i sl 43S 0l
Command: ROTATE ............................................................................................................ :)9:.».00) ‘5‘)?‘ _\

Current positive angle in UCS: ANGDIR=counterclockwise ANGBASE=0 _
5 Ol sl e 51 (3155 )|

Select ObJECtS: 1 fOUNT s Sao90 ol =Y
SEIECH ODJECES: s Sl alST 0,28 b Sl al -
SPeECify DASE POINE: oo s 3 e bl =¥
Specify rotation angle or [Copy/Reference] <O0>: R v, B o S A8 bl -0
Specify the reference angle <0>: s Olygs 35 e 0 bgs bl -#
Specify second point: i (oL Y o # ahats o Wilgs o alads cpl) pgo alnds Ol -V
Specify the new angle or [Points] <0>: 0 coeceveeceeeeeeeeeeeessnnninn Olygs agly 0,5 o,ls -A
2
7 —

base point © 4 base point

Points —
S oolaiwl 4 64, alive adadi g0 5l 190 asgly 50,5 0l sloay wlgl ge 43T ol 5l eolaiul b

YA
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OFFSET il oS ol ! EPee Sl e st ol Sl eslanl L
S s Sl S

D)l g0l 98 M ey Gl s )
ool asles oo g9, sl g, 3l SOl eolal
DS Tl giws

a2 90010 0550 50 jgws (plaS Cawl SS @ eV
Command entry :offset or o "))‘;\fcs‘ )_’| QT él'”*’ $9)

Ribbon :Home tab » Modify panel » Offset
Menu :Modify » Offset

Toolbar :Modify -{_]3_

ComMmMAaNd: OFESET  cerrrreeeeesssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssss fgiwd (gl -

Current settings: Erase source=No Layer=Source OFFSETGAPTYPE =0

5 cnl slaedas 5l )15 4l
Specify offset distance or [Through/Erase/Layer] <Through>: 2
Eyoye (o5 abols (3,5 5l Y
Select object to offset or [Exit/Undo] <Exit>:
(b oo Single g, 5l s jgiws cpl j0 Ol oS Okl ) ggoge o > ol yo Y
Specify point on side to offset or [Exit/Multiple/Undo] <Exit>:
AS S 05 oS Ea0g0 dudler 0 dS e b Cg> o Wb Al e ol o -F
Select object to offset or [Exit/Undo] <Exit>:
S Bl (595 (oS Sz |y oedee 95l 0 0 )kgs O
Through —
S Ol g g ge Dlads b Ll a2 o 03l dlold Canslgz o ygs el o jud (2,8 i 4S 43S (0l
Erase —
> b ogh Bds Lol gadge cad (o5 5l aw aF sy oo Lol a5l
Layer
Bgbee 2 pj by an3S al Gzl o
Enter layer option for offset objects [Current/Source] <Current>:
Current —
255 I8 Gl Y jo eal oS £adge 09d o0 Eel 4T
Source —
S o] Lol gaoge Y J0 0l LS £abge g o Cuel 43T oyl
Multiple —
adgl ooy cpns alols lea L) Lol g0 sl oS st slaSCIS U ailes o 438 ol 5l oolazwl b

///K:\x\
- .
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STRETCH lggoge (Sois P 1y lgsdse ail oo jaiws nl 5l ool L
DS 00,08 b 0ty sl o 45 S
Ribbon :Home tab » Modify panel » Stretch
Menu :Modify » Stretch

Toolbar :Modify E

Command entry :stretch or s

Command: STRETCH  rerererrrersssssssssmmsssssssssssssessssssssssssssssssssssssssssssssssssssssssssssssssssee fgewd gl =)

Select objects to stretch by crossing-window or crossing-polygon...
2L oo Crossing-window or Crossing — Polygon jgiws oyl jo ggo90 ol ol Lo

Select objects: Specify opposite corner: 1 found .o, Eaog0 oLl =Y
Select objects; ....................................................................... )MJ KWLy Qo)&é )‘| oolaiul L ol M‘L ol
Specify base point or [Displacement] <Displacement>: ... b alai 0,5 jasin -F

Specify second point or <use first point as displacement>: 6
el o0 45T Sz )0 Jsb 50,5 9)ls b pgs alal 0 ST etk -0

crossing -window or crossing-polygon

2 4

| |

[ | Q| g (g | I

—» L=6 . ><1

base point

&S oo Joe MOVe jgiws Jolae jaiws ol 0,8 )18 Gl o,y (9,0 laggdge dnn ST jgiws ol jo

Ao
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ARRAY oz Qlj‘_il z° e b oS asle o Hetws pl 5l eolaiul b
S ol (Glheo by (Sow 9 sl )90n
Ribbon :Home tab » Modify panel » Array RPWs 3L e IS d;Ua.o 6o (jgws 6‘)_?'| L

Menu :Modify » Aray ib oo Polar gRectangular as ;5 g0 Jolis a5

Toolbar :Modify HH

Command entry :array or ar

CommaNnd: ARRAY et ssmssssssssssssssssssssssssssssss s gawd (gl >

Rectangular Array (Sgww 3 & law & jgod oo

65.00 EJ
20.00

By defanult, il the now off sl is negative,
rows are sdded downmwand, I the

oy, alold

Row offset
110

) L

s

lil QLQ%_? ‘%I} Angle of array

Column offset (g alolé

i

AN



3 oleduz dgly g9 baygiw g lacmys, alold 0,5 o4ls sloay ailed oo aeSs (! 5l eolazul b 1
AS Ol b clilo p ands g9, 3l agly b alold lea b blas g a8 5 S wglo

5 090 o0 pll ol Caawds Hleduz aiS o)ly aie dae G O jgod | s,y alols Ll 31
D on JoSis o Caomnds loduz AiS olg ke dae | b ygiw alold 31

Argle of amay:

®

bS.0000

By cafiault, i the v offesd s nagative,
i ot DU, Dok

i magEiive, am
added to the leht

©

. 660
| 260 260
@“J&Flﬁ
| | |
& IF1 Fi F1
. %M%Flﬁ
a | ‘ F1
F1\ F\1 \
- F1 Fl

| Ol dinh oy
(Se:1/100)

oS 959, Ogwliod O 4
e s SoaS
Oledez )0 jgiws cnl o8

AY



& Seacnr
Olisd 35 o5 (At umwmy ;
Corterpont: X 10520000 Y. 31.0000 m

Miethod and values

Method: )50 (%9,
| Total number of Bems 3 Angle to i -]

Tetal nusnbar of § M g
pgesl % (@

g0 dsgls

Oy &gl

Arighe Bt wriln R T

begoge (e gl

(1) Forangleiofil, & posteve value specifies s -
counbenciockwiae retation, A negathee value 3wl DI

T specihes clockwss molation
. st [ Coed_]

[

- A8 oS Blae Db 4

S bz ses 2L O cnl ey Gl
// ooy doygin g oo |y (ol O g0
\> Q.v‘ )l ool Lu Ao l.b(sj-\.uo 9 Lbuj...m).w
el 00 M)J )9;.“40
/y A\
Ly Te—d k="
L

GROUND FLOOR PLAN

AY



For anght 10 fill, & posteve value spaciios
counianmiociowise roistion. A negative value

+ Rotste bems a5 copied 3

Total Number of Items

loggoge slowi (40,5 5]y b,

Angle to Fill

(655 yo alais 590 ool Sl slaggoge (4590 argly 0,5 0)ly b, | 1
Angle Between ltems

E3o30 99 (e dagly 50,5 3,1y (b,

Sas (53,5 3)ls g 05b 0 el slaayydie IS (590 cels agly sol> Cude dae (0 S 015 | 5
g Selo ladyyie Cu 0 laggdge 132 cel (pledaz gly sl ke

Rotate ltems as Copied | 3
03ls 0ly9d G 635y abali 93 ledemr Glojy 4o end Sl gedge aniS (nl pad Jls L
e 2Bl Jbd e 515 090 0

i i Jlsé Rotate Jus . Rotate

AY
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SCALE R - Sl slaggoge auiles oo jgiws (pl 5leolaiul b
S S5 L S eS bggdge ;K00 4y S | 00
Ribbon :Home tab » Modify panel » Scale 09,...;‘5@ 1)_?1 929, dlﬁui’j) ).| é-‘ L 5w Q—.’.‘

Menu :Modify » Scale
. e |
Toolbar :Modify DJ

Shortcut menu :Select the objects to scale ,
and right-click in the drawing area .Click Scale.

Command entry :scale or sc

COMMANG: SCALE s smsssssssssssssssssssssssssssss s sssssssssssssssssssssssssssssssssssssssseee g gl - )
Select ODJECtS: 1 FOUNT v loggoge b ggog0 ol =¥
SEIECE ODJECES: worrrmrtmtmsitssssstss Sl 0S8 b beobesl ol -
SPECIfy DASE POINt; s biw abads 0,5 adein ¥

(Sgd oo Sy g SzoS ahaii () 4 s lag poge plos 45 (slalais)
Specify scale factor or [Copy/Reference] <1.0000>: 2

(35 o0 50 Sy adgl g9b90 (B B Dot WS G) ulide upo (59,5 9,l9 -0

ﬂ —> 2
base point> y

Specify scale factor or [Copy/Reference] <2.0000>; C  wwrrwermvrssesssssseere S A bl

Scaling a copy of the selected objects .
D9 o 02 oliie b g9.550 o 51 (o5 5 wiley ol sl £5.050 b 05 co el 43S ol Sl

2

ya
base point I

AD
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Reference —

COMMANG: SCALE  eerrreeermmmmeeesmmsnecsssssmessssssnessssassesssssssmssssssmsessssssnsssssssmssssssnnessssssnssssssons g gl =)
Select 0bJects: 1 FOUN s lggoge b goog0 ool =Y
SEIECE ODJECES: s Sl 0l o886 b ol anb -y
SPECIfY DASE POINt; o (SAS) Lo alaiis 10,5 aseie -
Specify scale factor or [Copy/Reference] <1.5000>: R oo, &S o yedd 4SOl -0
Specify reference length <1.0000>: 1/100  ccoverrsicerssicseessiiines 28 wlae b Job 10 S 0 )lg-F
Specify new length or [Points] <1.0000>: 1/50 «eeeerreeessssnnenen el olde b Job 0,5 5l =Y

base point ||

GRD

o

§C:1/100

SC:1/50 Points —
Sy SeS Al (g5, ahad 9o 5l ales lide b sk (59,5 9)ly sl wsilg e 43S cnl Sl ool b

aile 6 mS b (s liel slacl 51 adlgy oo (Jg ausS eolainl aie sae 3l aley cad wlhide jews (o iaxgite

S oslitl YU Jlie
b s 1S5S Al gadge 4 Cand Jool> JSE 03l 5SS V5l 58 b (s Liel sue By -

AF
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TRIM i< 4 G loggdge (o dg> ol £ 9590 Wilel co jgiws ol sl ool b
DS aad e S A Cad )

Ribbon :Home tab » Modify panel » Trim B g9, lo g, 31 (SO 5l eolaiwl b giws oyl
Menu :Modify » Trim wob oo 12l

Toolbar :Modify .-J.n'.-_

Command entry :trim or tr
CommMaAaNd: TRIM oo ssssssssss s ssssssssssssssssssssesssssssss JYVORREPJEH B

Current settings: Projection=UCS, Edge=None s (2l ool nulais slo it 51 3,155 &1 |

Select cutting €dges ... e sy Sl 5550 j0 WS gl g
Select objects or <select all>: 1 found e ON e ol =Y
SEIECE ODJECES: oo Sl ol e 28 b ol an b -
Select object to trim or shift-select to extend or Dgd Bl aublys o a5 ted bl -F

[Fence/Crossing/Project/Edge/eRase/Undo]: ’ 2’ ’

| i Crossing

Crossing

)

AY



Slosis b Lo i g o5 gil

Fence —
[Fence/Crossing/Project/Edge/eRase/Undo]: f ..o 0o, L Fence 4 35 Ll
Specify first fence PoiNt: e sseesieaane 00, 3l akads gl 08 e
Specify next fence point or [UNdo]: e, (pgo ahad)) (gawy aadi 10,5 jastiv
Specify next fence point or [UNdo]: e (pyw abai) o alaili 15 S Azl

>4< >< Fence

X

Project —
Al doles 00ls sl (gum dw ol o

Edge —
Al aeles ol g el 43S ol 5leslawl b
[Fence/Crossing/Project/Edge/eRase/Undo]: e RN S o EY

Enter an implied edge extension mode [Extend/No extend] <No extend>:

. Extend —
Al aslo ébl.@.* gy bl o> Gglpw’ | £ gS90 ;s Q.l‘ ol b
No extend —
eRase —
DS SU 1) cilisee slaggoge b gaoge duilys oo joimws Gl Gloy ,o asS ol bl b

[Fence/Crossing/Project/Edge/eRase/Undo]: r

Select objects to erase or <exit>: 1 found ) _
Trim Jyvenn 6‘)’." )‘| S )5‘ D As-gid
dod oo Hlad | ol alds LS

— _B_ — R — — —_—
—» T E‘J > T g o PamIte (i e dxho (49,0 Saggdge

erase

AN
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EXTEND ro < b goipn 4 i, 0275 €9250 sn s5iod Gl jleslitl -
S5l 4 baio e ool ales o a5 (65,0 U
Ribbon :Home tab . Modify panel 3, Extend E3:050 Jawsg 3l Haww) Cuz 4 gadge Sl e

Bad plol Gl ) e Comods
Menu :Modify y, Extend F Rl e BE i

UEalEzr el oty S yuio Extend o Trim jgiws (glogulass :asgis
Command entry :extend or ex il oo alin g
CommaNnd: EXTEND o yghwd Ls‘)"’" -\

Current settings: Projection=UCS, Edge=None  ,guwo (2l ool pdais slo pnito 51 5,155 &1

Select boundary €dges ... s 3% ol 90 4O .,\59.3" Toog
Select objects or <select all>: 1 found s Oy a0 ul:v.u‘ -y
Select ODJECES: i s ol adS” o s b o] ..\.._:L -y

Select object to extend or shift-select to trim or w50 4 aalss oo a5 cgdg90 Sl -F
a5 b 1) Shift oS > cpl jo 31 .08 solitul ead S ggog0 bl slael, oles 51 alys oo
[Fence/Crossing/Project/Edge/Undo]: Sy e TTM & Jos jgiws ol agls

____________________ FH- —

A4
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BREAK Oy Iy 2Bl ggoge auily co jgiws (pl 5l eolanul b
Al ggog0 90 4 g 0iSiy alall g0 b SO
Ribbon :Home tab » Modify panel » Break A_._.S J_.M

Menu :Modify . Break

Toolbar :Modify

Command entry :break or br

COMMEANG: BREAK  rreeeeerseseesssesees s sseses e85 58 58 Hgiwd gl
Select ObJect : i (S5 oo Cgme CanSlls gl alaii calads pl) fadge bl )
Specify second break point or [First point]: e, CanSls pgo alads Ol -
1 2
N - -

Specify second break point or [First point]: f First Point —
S Ol 6,bg 1, gl abais cogbga el i3 ol ol

Specify first Dreak PoiNt: s eeessssmssssessessssssnne CenSls alats gl Sl -
Specify second break point: s ConSlls adadl pogs ol -Y
2 1

+//>$\ +//>§\ '\\

\ yﬂ — \ yﬂ —

/ /
N~ N
Break at Point [~ alais G0 Sl ol

Command: _break Select object:
Specify second break point or [First point]: _f
Specify first break point:

Specify second break point: @
1 2

Q0
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JOIN Silwaz LS ) g5oge 2z b 9o alys oo j5ims cal jleslial b
Loggose 4SSl by ay i az LSy 5 Jato o2 &y
Ribbon :Home tab » Modify panel » Join ML u)f )‘)5 l.lwl) &’ I

Menu :Modify 3. Join

Toolbar :Modify —f#—

Command entry :jion or j

CommMaAaNd: JOIN et ygmd 6‘)9-‘—\
Select source object: ........................................................................................................ Jﬁ‘ &ms.o uL?u." -Y
Select lines to join to source: 1 found s p9d Egog0 il -V

Select lines to join to source: w5 bl asly oo il S9>g0 o0 (6,508 ggog0 STl 10 (pl )0

11lin€ JOINE 10 SOUIMCE oo ssssssssssssssss s ssssssssssssassss e Golw az LSS 5,158
1 2
g g
1 2
- —g- = R
CommandJC)lN .......................................................................................................................... :)9@‘) 6‘?‘—\
Select source ObjeCt ....................................................................................................... uLQS AS.) uL?L«." —Y
Select arcs to join to source or [CLOSG]Z L e oﬁb uS.a O uLQS ud..w J.n.\.u -y
Arc converted to a circle.
A=EN
: e
//
CoMMANA: JOIN  coeeeeeererrersesesseiseisti sttt Dy ghwd Lg|):.>\—\
Se|ect source object: ............................................................................................... ‘_g.a.u uLQS ASJ ul?v.u‘ -y

Select elliptical arcs to join to source or [cLose]: L
Ellipse successfully closed. JU e SO pan S ul oS =Y

E’_—
/
\ -~ D

)
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CHAMFER zo ol aS L g0 o led co Hetws ol 5l solal
PSS S99 lalold o by g ules S akad | 508
Ribbon :Home tab » Modify panel » Chamfer IRVES I E 9| r TS VIPRVEL g S SU R

Menu :Modify 3. Chamfer

Toolbar :Modify Ie-’"

Command entry :chamfer or cha

COmMMANd: CHAMEER  ceeeerrmssssssssssssssssssssssssissssssssssssssssssssssssssssssssssssssssssssssssssssssssss Hgewd gl =)

(TRIM mode) Current chamfer Dist1 = 150.0000, Dist2 = 100.0000
o5 Ol sl e ) 3155 |
Select first line or [Undo/Polyline/Distance/Angle/Trim/mEthod/Multiple]:
L | als sl Gl -Y
Select second line or shift-select to apply corner: ..., b | als pregs Sl -Y
first line

1

=

150
—
- 3
second line | 2 -
| —Pp
Distance —

DS et |y 90 g Jol ald (59, alold wile o0 4S5 ol 5l eolazl L
Select first line or [Undo/Polyline/Distance/Angle/Trim/mEthod/Multiple]: d

Specify first chamfer distance <15.0000>: 100 «eererreeesssseneennees Jol alo (59, alald 0,5 o)lg
Specify second chamfer distance <150.0000>:; 100 weeveseesse p9d &ho (59, alols (10,5 o)1y
,1_| 100 ,1_| 120
1 2 \I ] 2
—> —>
Polyline —

S Jloel loaissS wan (53, |y ¢ 9l o0 2l 42 LSs Lo £5050 45 S50 50 43 (nl  eslital L

Select first line or [Undo/Polyline/Distance/Angle/Trim/mEthod/Multiple]: P
Select 2D PolYliNg: s 4:>)l..5.a Ego90 ol
4 lines were chamfered . g 8,Sles 51 3155 &l

Rectangle >

¥
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Angle
DS Sl 1) sl w4y S pgs @ls aygly 5 @ho S Jsb wilgiooe an S cnl 5 ool L
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