
    واحد کار
سوم
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اهداف رفتاری:

پس از آموزش این واحد کار از فراگیر انتظار می‌رود:

1. سیستم مختصات را تعریف نماید.

2. دستگاه مختصات کارتزین و قطبی تعریف کند.

3. مختصات نقاط یک نقشه ترسیمی را به صورت مطلق نسبی و قطبی استخراج نماید.

4. روش‌های وارد کردن مختصات بصوت مطلق نسبی و قطبی را در نرم افزار اتوکد شرح دهد. 

هدف کلی : شناخت روش‌های مختصاتی

پیش آزمون:)20 دقیقه(

1.منظور از مختصات z،y،x جهت مشخص کردن یک نقطه چیست؟

2.ی��ک مربع ب��ا ابعاد 80×100 در صفحه ترس��یم نماید بطوریکه مح��ور مختصات در مرکز آن 
باشد.

3.یک نقطه با مشخصات )80و50( را در صفحه مشخص نماید.
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سیستم مختصات

در ترسیمات هندسی و ریاضیات به منظور ترسیم اشکال مختلف از قبیل نقطه، خط، منحنی، صفحه و حجم به 
سیستم مختصات نیاز داریم.

فاصله هر طولی و عرضی نقطه روی ترسیم نسبت به یک مرجع سنجیده می‌شود که به آن مرکز محور مختصات 
می‌گویند.

- سیستم مختصات کارتزین

برای تعریف مختصات در یک صفحه به دو مولفه x،y و در فضا به سه مولفه x،y،z نیاز داریم.

مولفه x بیانگر فاصله طولی )افقی(نسبت به نقطه مرجع )مبنا( می‌باشد.

مولفه x بیانگر فاصله عرضی )عمودی( نسبت به نقطه مرجع )مبنا( می‌باشد.

- مثلا مختصات یک نقطه در صفحه که فاصله آن از محور x ،30 میلی متر و از محور y ،40 میلی‌متر اس��ت به 
صورت )40وp)30 نمایش داده می‌شود.

40

30

y

p

x

در صورتیکه فاصله همین نقطه از محور z ،50 میلی باش��د مختصات نقطه به صورت )P)30.40.50نمایش داده 
می‌شود z=50 ، y=40،x=30 ، بدین معنا است که نقطه از صفحه ترسیمی 50 میلی‌متر بالاتر است.

     

 

    

z

40

30

y p

x

50
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                       نکته

بر اساس استاندارد در ماشین‌های افزار محور Z در امتداد محور اصلی ماشین )اسپیندل( و محورهای x،y بر 
روی میز ماشین فرض گردیده‌اند.

                        

40

100

y

Ax

x

x=0

y=0

)0،0(

مثال: مخصات نقطه)Aَ)َ100.50 را ترسیم نمایید.              

1.ف��رض می‌کنی��م می‌خواهی��م از مرج��ع محور 
مختص��ات به صورت افقی و روی محورx  به اندازه 

100 میلی‌متر جلو برویم.تا به نقطه AX برسیم.                                         

                            

50

A

x
x=0

y=0

100
)0،0(

                   
Y 2. از ای��ن نقط��ه بطور عمودی و م��وازی محور
 A ب��ه اندازه 50 میل��ی متر بالا رفته ت��ا به نقطه

برسیم.            

 

                                    

- مختصات مطلق و نسبی

در سیستم مختصات کارتزین یک نقطه به دو صورت تعریف می‌شود. 

1. مختصات مطلق:

در این سیستم موقعیت تمام نقاط یک ترسیم نسبت به مرجع و مبداء مختصات سنجیده می‌شود.

در این حالت مختصات نقاط P1تاP4 به صورت زیر است:

P1)10.20(
y

                                                                   P2)100.20(

P3)100.50(

P4)10.50(

x
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- مختصات نسبی

در این سیس��تم موقعیت هر نقطه نس��بت به نقطه قبلی خودش س��نجیده می‌ش��ود.یعنی برای بدس��ت آوردن 
مختصات هر نقطه محور مختصات را در نقطه قبلی قرار داده و نقطه جدید را نسبت به آن می‌سنجیم.

مختصات نقطه P1  نسبت به مبدا مختصات )10.20(P1 )یعنی از مبدا مختصات می‌خواهیم به نقطه P1 حرکت کنیم.

مختصات P2نسبت به 90.0(P1(P2)یعنی از نقطه P1می‌خواهیم به نقطه P2حرکت کنیم.

   

y

x

y

x
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مختصات P3  نسبت بهP3)0.50( :P2 یعنی از نقطه P2 می‌خواهیم به نقطه P3حرکت کنیم.

مختصات P4نسبت به P4)-90.0( :P3یعنی از نقطه P3 به نقطه P4حرکت کنیم.
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AUTOCAD مختصات مطلق و نسبی در نرم افزار -

برای وارد کردن مختصات به صورت مطلق در نرم افزار CAD کافیس��ت ابتدا یک دس��تور ترسیمی اجرا نماییم 
در قسمت خط فرمان )COMMAND( اگر جملات:

 Specify First Point نقطه اول را مشخص نمایید -

Specify LAST Point نقطه آخر را مشخص نمایید -

Specify NEXT Point نقطه بعدی را مشخص نمایید -

 Specify CENTER Point نقطه مرکز را مشخص  نمایید -

ظاهر گردید بدین معنی است که بایستی مختصات یک نقطه را وارد نماییم

در صورتی‌که مختصات نقطه را به صورت دو عدد که بین آن‌ها ویرگول قرار د ارد وارد نماییم مختصات به صورت 
مطلق در نظر گرفته می‌شود

و اگر قبل از وارد کردن مختصات نماد نسبی  )Shlft +2( @ را بنویسیم مختصات نقطه به نقطه قبلی درج شده 
و در نظر گرفته می‌شود
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ااگر در نرم افزار Auto Cad در قسمت Statusbar بر روی DYN مخفف Dynamic input کلیک راست 
کرده و گزینه Settings را بزنیم پنجره مربوط به تنظیمات این قسمت نمایان می‌شود.

گزینه Enabel Dimension input where possible را فعال نماییم برای درج مختصات به صورت نسبی 
دیگر نیازی به وارد کردن نماد @ نمی‌باشد.
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- مختصات قطبی 

در سیس��تم مختص��ات قطب��ی برای نش��ان دادن موقعیت یک نقطه واقع ب��ر یک صفحه از دو پارامتر اس��تفاده 
می‌شود.

- طول و یا فاصله نقطه تا نقطه قبلی

-  زاویه خط )و اصل نقطه تا نقطه قبلی( با زوایه صفر درجه

- قطبی مطلق

α فاصله نقطه p تا مبدا مختصات 

x زاویه بین این خط و محور  Ɵ

که از نقطه قبلی می‌گذرد.   

               
- قطبی نسبی

α فاصله نقطه P1  تاP2  به صورت نسبی

 زاویه خط P1P2   با خطی که به صورت افقی 

از P1  می‌گذرد.

مثال: مختصات نقاط داده شده را به صورت قطبی نسبی بنویسید.
p1=22/3>63ο  نسبت به مبداء مختصات

p1 نسبت به  P2=90>0ο

p2 نسبت به  P3=30>90ο

p3 نسبت به   P4=90>180ο

y

p

x

Ɵ

y p

x

Ɵ

α

P1
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Auto Cad نحوه اعمال مختصات نقطه به صورت قطبی نسبی در -

برای این منظور کافیست در قسمت خط فرمان و زمانی که مختصات یک نقطه را از ما می‌خواهد به صورت شکل 
مختصات قطبی نسبی  را وارد نماییم.

اگر مطابق ش��کل از قسمت Starusbar گزینه Setting را زده و ...  Enabel Dimension input را فعال 
نماییم هنگام ترسیم کافیست با نمایشگر زاویه دلخواه را مشخص کرده و طول مورد نظر را وارد نماییم.
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AUTO CADتعیین مختصات یک نقطه در

برای مشخص کردن مختصات یک نقطه به ترتیب زیر عمل می‌نماییم

1. بر روی ترس��یم کلیک کرده تا انتخاب ش��ود و مربع‌های آبی رنگ بر روی آن ظاهر ش��ود. این عمل باش��د 
.command هنگامی انجام می‌دهیم که در قسمت خط فرمان فقط کلمه نمایشگرCursur را بر روی مربع آبی 

رنگ قرار داده تا به رنگ سبز در آید..

3. در این حالت مختصات نقطه در نوار مختصات مشخص می‌شود.
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1. سیستم مختصات را تعریف کرده و مختصات کارتزین را شرح دهید.

2. تفاوت تعیین موقعیت یک نقطه به صورت مطلق یا نسبی چیست؟

3. در سیستم قطبی زاویه یک نقطه نسبت به چه مکانی تعیین می‌شود؟

عملی 45دقیقه

1. تنظیمات DYN را انجام دهید

2. مختصات نقاط شکل‌های زیر را به صورت مطلق و نسبی بنویسید.

نظری 15 دقیقه

ارزشیابی پایانی 



    واحد کار

چهارم
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توانایی‌ها:
1. توانایی اجرای دستورات ترسیمی و ویرایشی

Line -Circle-Erase-Trim-Ortho-Rectangle-Undo-Redo-Units

2. توانایی اجرای دستورات ترسیمی و ویرایشی
Arc-Osnap-Copy-Move-Fillet-Chamfer-List

3. توانایی اجرای دستورات ترسیمی و ویرایشی 
Rotate-Scale-Array-Mirror-Offset-Hatch

هدف کلی : اجرای فرمان‌های ترسیمی ویرایشی و 
AUTOCAD کمک ترسیمی‌توانایی‌ها نرم افزار

اهداف رفتاری توانایی 1:

پس از آموزش این واحد کار از فراگیر انتظار می‌رود:

1. ترسیم خط و دایره را به روش‌های مختلف در اتوکدتوانایی ترسیم کند.

2. روش‌های پاک کردن موضوعات با استفاده از دستوراتErase,trim را انجام دهد.        

3. خطوط افقی و عمودی را ترسیم کند.

5. مستطیل را به روش‌های مختلف ترسیم کند.

6. یک شکل هندسی شامل خط و دایره را ترسیم کند.

هدف کلی :توانایی اجرای دستورات ترسیمی و ویرایشی
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1. به چه طریق می‌توان مختصات یک نقطه را به صورت مطلق نسبی و قطبی در نرم افزار وارد کرد؟

2. علامت مختصات قطبی یک نقطه چیست؟

3. برای )cancle(کردن یک دستور از چه کلیدی در keyboard می‌توان استفاده کرد؟

4. کدام کلید برای پاک کردن در صفحه keyboard استفاده می‌شود؟

5. برای ترسیم یک پاره‌خط چه مشخصاتی لازم است؟

6. اگر نقاط C،B،A مطابق شکل قرار داشته باشند مطلوبست:

الف: مختصات نقطه B نسبت به نقطه A به صورت مطلق 

ب: مختصات نقطه B نسبت به نقطه C به صورت نسبی

ج: مختصات نقطه C نسبت به نقطه A به صورت قطبی 

 

پیش آزمون

C

A

B

40

100



56

دستور کار 1
قبل از آموزش لازم است معانی و کاربرد لغات و اصطلاحات زیر فرا گرفته شود،

LINE     خط                                                                            

CIRCLE   دایره                                                                      

RECTANGLE مستطیل                                                     

ERASE  پاک کردن                                                               

TRIM  برش موضعی                                                           

ORTHO افقی و عمودی کردن مکان نما                                  

UNDO خنثی کردن دستور                                                    

REDO                                                                 undo معکوس

UNITS   واحدها                                                                  

COMMAND خط فرمان                                                  

SPECIFY                                                    مشخص کردن

FIRST POINT                                                 اولین نقطه 

NEXT POINT نقطه بعدی                                               

SECOND POINT                                            نقطه دوم

CORNER   گوشه                                                               

OTHER دیگری                                                                

CENTER   مرکز                                                                 

RADIUS شعاع                                                                  

DIAMETER قطر                                                            

CLOSE          بستن                                                                    

DRAW   ترسیمی                                                                   

MODIFY اصلاح کردن                                                         
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line  فرمان
از این دستور برای ترسیم یک پاره خط به صورت‌های مختلف استفاده می‌شود.

را از سه طریق می‌توان اجرا کرد

Menubar: draw>line

Toolbar: draw>line

Command : line  یا L   

همانطور که می‌دانید برای ترسیم یک پاره خط مشخص کردن نقطه ابتدا و انتهای آن لازم است بنابراین می‌توان 
برای ترسیم یک پاره‌خط نقاط ابتدا و انتها را به دو صورت زیر وارد کرد.

1.تایپ مختصات ابتدا و انتها در خط فرمان 
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2. انتخاب دو نقطه با استفاده از نمایشگر موس

در صورتی که بخواهیم مختصات دو نقطه را به وسیله نمایشگر موس به صورت مطلق مشخص نماییم لازم است 
تنظیمات مطابق شکل را در قسمت DYN انجام دهیم

                           نکته:
برای فعال و غیر فعال کردن DYN از کلید F12 صفحه کلید می‌توان استفاده کرد

در این حالت کافیست نمایشگر را در صفحه ترسیمی حرکت داده تا مختصات مورد نظر ظاهر شود.

و ب��ا کلیک کردن این نقطه به عنوان اولین نقطه انتخاب می‌ش��ود نقاط بع��دی را نیز می‌توانیم به همین ترتیب 
انتخاب نموده و ترسیم را انجام دهیم.
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                            نکات:
1. فرمان line برای ادامه محدودیتی ندارد و می‌توان به تعداد دلخواه پاره‌خط ترسیم کرد.

2. با وارد کردن گزینهUndo آخرین نقطه انتخاب شده لغو می‌شود.

ORTHO دستور -

به وسیله این دستور می‌توان حرکت نمایشگر را در حالت‌های افقی و عمودی محدود کرد.

ORTHO  نحوه فعال کردن

1. ازقسمت Status bar بر رویORTHO کلیک نماییم 

2. کلید F8 )بر روی keyboard( را بزنیم

                        نکته:
کلید ORTHO فقط هنگامی عمل می‌کند که یک دستور ترسیمی مثلا line اجرا شده باشد.
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UNITS فرمان

از این دستور برای تنظیم واحدهای طولی و زوایا استفاده می‌شود 

برای اجرای فرمان بر دو روش عمل می نماییم تا جدول تنظیمات UNITS ظاهر شود  

MENU BAR : FORMAT>UNITS

COMMAND : UNITS

تنظیمات UNITS در تمامی قسمت‌های زیر تاثیر می‌گذارد.

 1. نمایش مختصات مکان‌نما

DYN 2.نمایش موقعیت در هنگام ترسیم و فعال بودن

.LISTو  DIST 3. در هنگام استفاده از دستورات
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دستور کار 1

1. ترسیم یک مربع با ابعاد 50 ×100 به 5  روش‌های زیر :

استفاده از مختصات گوشه‌های شکل به صورت مطلق: دستور line را اجرا کرد و در قسمت خط فرمان 
)command( به ترتیب مختصات نقاط P4، P3، P2 ،P1 را وارد می‌نماییم تا شکل ترسیم شود.

توجه:
در حالت ترسیم کلید DYN غیر فعال باشد.

 نکته:
بعد از وارد کردن نقطه P3 کافیست حرف C در خط فرمان را تایپ کرده تا شکل کامل گردد.

  نکته:

بعد از وارد کردن هر مختصات کلید ENTER را می‌زنیم.

نکته:
استفاده ازu )مخفف undo( به جای مختصات در جلوی فرمان  

Specify next point or [undo]

باعث لغو مختصات داده شده  قبلی می‌شود و می‌توان مختصات جدیدی را وارد کرد
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2. استفاده از مختصات گوشه‌های شکل به صورت نسبی:  
نقطه P1 نسبت به مبدا مختصات  

  P1 نسبت به نقطه P2 نقطه
 P2 نسبت به نقطه P3 نقطه
P3 نسبت به نقطه P4 نقطه

و در نهایت از گزینه Close برای رسم خط
 از P4 به P1 استفاده می‌کنیم.

بعد از اجرای دستور LINE مختصات را به صورت نسبی)با قرار دادن علامت @ قبل از مختصات( وارد می نماییم.               

   نکته:

مختصات نقطه اول را به صورت مطلق وارد می‌نماییم. 

3. استفاده از مختصات شکل به صورت قطبی نسبی :    

نقطه P1 به صورت مطلق 

نقطه P2 نسبت به P1  به طول 90 و زاویه صفر

نقطه P3 نسبت به P2  به طول 30 و زاویه 90

نقطه P4 نسبت به  P3 به طول 90 و زاویه 180  

 P1 به P4 برای رسم از  close و در نهایت از گزینه

استفاده می‌کنیم.

                      

                           نکته:
اگر طول و زاویه نقطه P1 نسبت به نقطه قبلی را نداشتیم مختصات آن را به صورت مطلق وارد می‌نماییم.
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بعد از اجرای دستور LINE مختصات را به صورت قطبی نسبی وارد می‌نماییم. 

زاویه خط نسبت به نقطه قبل < طول خط با علامت مثبت@

4. با استفاده از طول پاره‌خط و فرمان ORTHO کلید F8 را می‌زنیم تا فرمان ortho  فعال شود و حرکت مکان 
نما محدود حرکت افقی و عمودی گردد.

- دستور LINE را اجرا کرده و مختصات اولین نقطه را به صورت مطلق وارد می نماییم.

- مکان نما در حالت افقی به سمت راست قرار داده و مقدار 90طول پاره خط P1 P2  را وارد می‌کنیم.

- مکان نما در حالت عمودی و رو به بالا قرار داده و مقدار 30 طول پاره خط P2 P3  را وارد می‌کنیم.

- مکان نما در حالت افقی و سمت چپ قرار داده و مقدار 90طول پاره خط P3 P4  را وارد می‌کنیم.

- حرف c مخفف close را زده تا شکل کامل شود.

DYN 5. با استفاده از مختصات شکل و فرمان

تنظیم��ات DYN  را همانطور که قبلا توضیح داده ش��ده انجام می دهی��م و با کلید F12 آن را فعال می‌کنیم و 
دستور LINE را اجرا می‌کنیم.

توجه: فرمان  ORTHO  را غیر فعال کنید. 

 Precision نمایش اعداد به صورت بدون اعشار باشد یعنی قسمت UNITS توجه:در تنظیمات
بر روی صفر باشد.
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برای ترسیم شکل کافیست بوسیله موس به مختصات نقاط P1  رفته و کلیک نماییم به همین ترتیب سایر نقاط 
را پیدا کرده و کلیک می‌نماییم.                                                                  

                          نکته:
برای کامل شدن شکل بعد از انتخاب نقطه P4 حرف C  را تایپ کرده و ENTER می‌نماییم.

ERASE فرمان

از این فرمان جهت پاک کردن یک ترسیم استفاده می‌شود 

اجرای فرمان
Menubar:Modify> Erase
Toolbar : Modify> Erase

Command: Erase یا E

بعد از اجرای دستور موضوعات مورد نظر را انتخاب کرده و کلید ENTER را می‌زنیم.
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  نکته:

ب��رای پ��اک کردن موضوعات ترس��یمی می‌توان ابتد آن‌ها را انتخاب کرد تا Highlight ش��وند و س��پس کلید 
DELETE روی KEY BOARD را می‌زنیم.

CIRCLE فرمان

اجرای فرمان

Menubar : Draw> Circle>...

Toolbar : Draw> Circle

Command :  Circle یا c

بعد از اجرای فرمان از نوار ابزار DRAW یا تایپ آن در خط فرمان لازم است ابتدا مختصات مرکز و سپس شعاع 
دایره را وارد نماییم.

 نکته :
اگر بخواهیم دایره را با اندازه قطر رسم نماییم کافیست در قسمت

Specify radius of circle or [Diameter]: D 

حرف D را تایپ کرده تا جمله زیر ظاهر شود و در این قسمت می‌توانیم مقدار قطر را وارد نماییم.
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Specify Diameter of circle

روش‌های دیگر ترسیم دایره-
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CENTER-RADIUS 1.رسم دایره به کمک مرکز و شعاع

- انتخاب مرکز دایره 

- وارد کردن مقدار شعاع  

 

CENTER-DIAMETER2.رسم دایره به کمک مرکز و قطر

- انتخاب مرکز دایره

- وارد کردن قطر دایره

2POINT 3.رسم دایره به کمک دو نقطه

- انتخاب دو نقطه

3POINT 4.رسم دایره به کمک سه نقطه

- انتخاب سه نقطه
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TAN.TAN.RADIUS.5. رسم دایره مماس بر دو شکل و شعاع دایره

- انتخاب دو شکل

- وارد کردن شعاع دایره

TAN.TAN.TAN 6. رسم دایره مماس بر سه شکل

- انتخاب سه شکل

یاد آوری 

جهت وارد کردن یک نقطه مثلا مرکز دایره به 3 روش می‌توان عمل کرد:

1. بوسیله مکان‌نما بر روی صفحه ترسیمی کلیک نماییم.

 2. مختصات نقاط را به روش مطلق و یا نسبی در خط فرمان تایپ نماییم.
3. از DYN کمک گرفته و بوسیله موس مختصات نقطه را بطور دقیق تنظیم کرده و کلیک نماییم.

RECTANGLE  دستورمستطیل
 از این دستور جهت ترسیم یک چهارضلعی استفاده می‌شود.

Menubar: Draw> Rectangle

Toolbar : Draw> Rectangle

Command :  Rectangle یا Rec

برای ترسیم چهار ضلعی مختصات دو نقطه لازم است.
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بعداز اجرای دستور مختصات دو نقطه خواسته شده را وارد می‌نماییم برای این منظور می‌توانیم در خط زمان 
مختصات را تایپ نماییم و یا با فعال کردن DYN و تنظیم units بوسیله موس چهار ضلعی را ترسیم نماییم.

TRIM دستور پاک کردن موضعی

هنگامی که دو یا چند ترس��یم با هم برخورد داش��ته باشند و بخواهیم قس��مت یا بخش‌هایی از ترسیم را حذف 
نماییم از این دستور استفاده می نماییم

Menubar: Modify> Trim

Toolbar : Modify> Trim

Command:  Trim یا Tr
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 ABبعد از اجرای دستور ابتدا بایستی لبه یا مرزهای برش را انتخاب کرد: مثلا برای پاک کردن پاره خط

خطوط 1.2 بعنوان مرزهای برش انتخاب کرده و پس از زدن ENTER پاره خط  AB را انتخاب می نماییم.

نکته:

اگر در قس��مت انتخاب مرزهای برش >SELECT OBJECT OR <SELECT ALL بدون هیچ انتخابی کلید 
ENTER را بزنیم تمامی ترس��یم بعنوان لبه‌های برش انتخاب می‌شوند در این حالت هر قسمتی را که بخواهیم 

می‌توانیم حذف نماییم.

UNDO فرمان

به کمک این فرمان می‌توانیم دس��تورات اجرا ش��ده قبلی را لغو نماییم و یا به بیان دیگر با اجرای هر بار فرمان 
UNDOیک مرحله به عقب باز می‌گردیم.

Menubar: Edit> Undo
Toolbar : Standard> Undo
Command:  Undo یا U یا Ctrl+z

REDO فرمان

در صورتیکه از  فرمان  UNDO استفاده کرده باشیم به کمک دستور REDO می‌توانیم دستور مراحل لغو شده 
را باز گردانیم و با اجرای هر بار آن یک مرحله به جلو برویم

Menubar: Edit> Redo
Toolbar : Standard> Redo
Command:  Redo یا Ctrl+y

انتخاب مرزهای برش ..........................

Command:  Trim

SELECT OBJECTS OR<SELECT ALL>2خطوط 1و

SELECT  OBJECT TO TRIM:AB انتخاب پاره خط 
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دستور کار 1

شکل روبرو را ترسیم نماییم
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دستور کار 2
شکل زیر را به کمک دستوات فرا گرفته ترسیم نمایید
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1. فرم��ان line را از چن��د طریق می‌توان اجراکرد و روش‌های ترس��یم یک پاره‌خط را ش��رح 
دهید؟

2. تنظیمات unit در چه مواقعی کاربرد دارد؟

3. روش‌های پاک کردن یک ترسیم را توضیح دهید؟

4. معنای جمله Specify first point چیست؟

5. اصطلاح خط به زبان انگلیسی ..................................... می‌شود.

5- اصطلاح دایره به زبان انگلیسی....................................می‌شود.

7. برای فعال و غیر فعال کردن DYN از چه کلیدی استفاده می‌شود؟

F10 )د                    F3 )ج                       F8)ب                     F12)الف

8. برای فعال کردن دستور ORTHO از چه کلیدی استفاده می‌شود؟

F10 )د                    F3 )ج                       F8)ب                     F12)الف

9. برای ترسیم دایره به روش دو مماس و شعاع از چه دستوری استفاده می‌شود؟

Tan-Tan-Radiv )ب                           Tan-Tan-Tan )الف

circle  .  Diameter )د                                      point 3 )ج 

10. مخفف دستور Trim چیست؟

الف(T                     ب(Tr                       ج( Tri                    د( هیچکدام

نظری 15 دقیقه

ارزشیابی پایانی 
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شکل‌های زیر را در کاغذ A4 ترسیم کرده و هر کدام را با نام متفاوتی ذخیره نمایید.

عملی 15 دقیقه

ارزشیابی پایانی 
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توانایی 2 :توانایی اجرای دستورات ترسیمی و ویرایشی

Arc-Osnap-Copy-Move-Fillet-Chamfer-List-Dist-Grip

اهداف رفتاری:

پس از آموزش این توانایی از فراگیر انتظار می‌رود:

1. معنای کاربردی دستورات و فرامین این قسمت را بداند.

2. توانایی ترسیم کمان برش‌های مختلف را فرا گیرد.

3. توانایی استفاده از گیره‌های شی :Objectsnap در ترسیم را فرا گیرد

4. مشخصات یک ترسیم را با استفاده از دستور List استخراج نماید.

5. توانایی اندازه‌گیری فاصله بین دو نقطه را با استفاده از دستور Dist فرا گیرد.

6. از خطوط کمکی Tracking در ترسیم یک شکل استفاده نماید.

7. توانایی جابجایی یک ترسیم را با استفاده از دستورات Grip،Move،Copy فرا گیرد.
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پیش آزمون

    1- برای پاک کردن پاره خط AB و سپس BC از چه دستوراتی بایستی استفاده کرد؟

                                  2 - اگر شکلی را توسط دستور Erase پاک کرده باشیم  به کمک چه دستوری می‌توان آن را باز گرداند.

               3- نقاط Grip را چگونه می‌توان فعال کرد؟

               4- جهت جابجا کردن یک ترسیم بکمک نقاط Grip چه عملی را بایستی انجام داد.

               5- به کمک چه دستوری می‌توان شکل روبرو را ترسیم کرد.

         

               6- روش‌های اجرای یک دستور را توضیح دهید.

C

B

A

R50  

50  

50  
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Start             شروع

Point            نقطه

Center           مرکز

End   انتها

Lenght   طول وتر

Continue   ممتد

Arc   کمان

Object snap   گیره‌های شی

Copy   کپی

Move   جابجایی

Fillet   گرد کردن گوشه

Chamifer   پخ زدن گوشه ها

List   مشخصات ترسیم

Dist   فاصله

Grip   نقاط کمکی

Tracking   خطوط کمکی

Base point   نقطه مبنا

End point   نقطه ابتدا و انتهای خط پایان یا کمان

Midpoint   نقطه میانی

Tangent   مماس

Intersection   محل برخورد

Perpendicular   عمود

Parallel   موازی

Angle   زاویه

Radius   شعاع

Circumference   محیط

Area   مساحت
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Arc   فرمان -

به کمک این دستور می‌توان یک کمان به روش‌های مختلف ترسیم کرد.

اگر دس��تور کمان را در خط فرمان تایپ نماییم در این صورت با انتخاب س��ه نقطه می‌توان یک کمان رسم کرد 
هم چنین اجرای دستور کمان از قسمت نوار ابزار نیز به همین صورت اجرا می‌شود.

فرمان کمان را می‌توان به روش‌های زیر اجرا کرد.
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)Object snap) osnap ابزارهای -

به کمک این ابزار می‌توان نقاط مشخصی از شکل را انتخاب کرد و در ترسیمات جدید مورد استفاده قرار داد به 
عنوان مثال می‌خواهیم یک دایره در وس��ط یک خط ایجاد نماییم و یا از مرکز یک دایره خطی به مرکز دایره‌ای 

دیگر ترسیم نماییم. ابتدا لازم است نقاط یک ترسیم شناخته شود.

Osnap فعال کردن -

به چند طریق زیر می‌توان گیره‌های شی را فعال کرد

1-در قس��مت Status bar بر روی Osnap کلیک راس��ت کرده و گزینه Setting را انتخاب می‌کنیم تا پنجره 
مربوطه باز شود سپس در قسمت Object snap موارد مورد نیاز را تیک می‌زنیم تا به طور دائمی فعال شود.


