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كليات
يک��ي از موارد مهم��ي که در طراحي اهميت دارد، حروف‌نگاري و تايپ متون اس��ت. در 
طراحي موضوعاتي نظير کاتالوگ، س��ربرگ، طرح بس��ته‌بندي و ... علاوه‌ بر تصوير، نيازمند 
عناصر متني نيز هستيد.   FreeHand توانايي‌هاي بسياري در زمينه تايپ، ترازبندي و ايجاد 
جلوه‌ه��اي بصري دارد و يکي از ويژگي‌هاي برجس��ته اين برنام��ه، کيفيت بالاي چاپ متون 

نسبت به نرم‌افزارهاي پيکسلي است. 
در  FreeHandنمي‌توان متون فارس��ي را تايپ کرد، بنابراين کاربران بايد براي دسترسي 

به امکان تايپ فارسي از برنامه‌هاي جانبي استفاده کنند.
Text 1-9 ابزار

ب��ه ط��ور كل��ي در برنام��ه FreeHand MX متن به دو ص��ورت س��اده و پاراگرافي ايجاد 
مي‌شود. 

1-1-9 نگارش متن ساده

براي شروع به تايپ متن ساده مراحل زير را دنبال کنيد:
1- صفحه جديدي ايجاد کرده و ابزار متن )Text( را از جعبه ابزار انتخاب کنيد.

2- در محل موردنظر از صفحه کليک کنيد تا مکان‌نماي چش��مک‌زن به همراه خط‌کش 
ويژه تايپ نمايان شود )شکل 9-2(.

   		                   

شکل 2-9 متن ساده 	Text شکل 1-9 انتخاب ابزار              

 نكت�ه: خط‌ک��ش متن براي افزاي��ش دقت عمل در هنگام تاي��پ از طريق منوي 
View   Text Rulers يا کليد ميانبر /  +  Ctrl   قابل دسترسي است.

3-  اکنون مي‌توانيد متن موردنظر را تايپ کنيد يا متن تايپ ش��ده در برنامه ديگري را 
وارد اين محل کنيد.
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4- براي خاتمه دادن به کار تايپ کافي است توسط ابزار Pointer  در نقطه‌اي خارج 
از محيط تايپ، کليک کنيد.

2-1-9 نگارش متن پاراگرافي

براي ايجاد متن پاراگرافي به صورت زير عمل كنيد:
1- ابزار Text را از جعبه ابزار انتخاب كنيد.

2- يک کادر مس��تطيل با درگ ماوس )بلوک متن( ايجاد کنيد. فاصله كش��يدن ماوس 
اندازه بلوك متني را تعيين ميك‌ند. 

 3- پ��س از ره��ا ك��ردن م��اوس بل��وك متن��ي و خطك‌ش مت��ن را مش��اهده ميك‌نيد 
)شكل 9-3(.

4- متن را تايپ کنيد. 

شکل 3-9 متن پاراگرافي

3-1-9 اعمال تنظيمات روي متن 

مي‌توانيد قبل يا بعد از تايپ متن تنظيمات مختلفي را روي متن اعمال کنيد، براي اين 
منظور كيي از سه روش بعد را برگزينيد:

 Text 1- استفاده از نوار ابزار
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Text شکل 4-9 نوار ابزار

براي ظاهر کردن اين نوار ابزار در بالاي صفحه، دو روش وجود دارد:
	Window→Toolbars→Text انتخاب گزينه
	Text کليک راست در محدوده خالي نوار ابزارهاي ديگر و انتخاب گزينه

Text 2- استفاده از منوي
تنظيمات متون، جلوه‌هاي ويژه متن و ساير فرامين در اين منو قرار دارند.

 Object 3- استفاده از پنل
با انتخاب ابزار Text و کليک روي صفحه يا انتخاب متن نوشته شده، گزينه‌هاي کنترلي 
آن ب��ه طور خودکار در پنل Object ظاهر مي‌ش��وند. اين پن��ل کامل‌ترين تنظيمات را براي 

کنترل متون سطري و پاراگرافي در خود جاي داده است )شکل 9-5(.       

     شکل 5-9 پنل Object مربوط به خواص متن
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2-9 انتخاب و تنظيمات متن  
قبل از تايپ متن مي‌توانيد تنظيماتي نظير تغيير اندازه و نوع قلم را انجام دهيد و در صورتي 

که بخواهيد بعد از تايپ متن به ويرايش آن بپردازيد، بايد ابتدا متن را انتخاب  کنيد.
روش‌هاي انتخاب متن

1-2-9 انتخاب محدوده‌اي از متن

1- توس��ط ابزار Pointer روي متن دابل کليک کنيد تا علامت چشمک‌زن در متن ظاهر 
شود.

2- با استفاده از كليد  Shift در محلي که مي‌خواهيد انتخاب متن تمام شود، کليک کنيد 
يا با کشيدن نشانگر ماوس روي متن، آن را به حالت انتخاب درآوريد.  

2-2-9 انتخاب کل متن 

توس��ط ابزار Pointer روي متن کليک کنيد تا دس��تگيره‌هاي کنترلي در اطراف آن ظاهر 
شود در اين صورت کل متن در حالت انتخاب قرار مي‌گيرد.

پ��س از انتخاب متن مي‌توانيد تنظيماتي نظير تغيير نوع و اندازه قلم را روي متن اعمال 
کنيد.

3-2-9 تنظيمات متن 

تغيير تنظيمات از طريق يکي از روش‌هاي ذکر ش��ده در بخش 3-1-9 انجام‌پذير اس��ت 
که به طور نمونه با اس��تفاده از پنل Object به توضيح آن مي‌پردازيم. توجه داشته باشيد که 

دکمه Character  در حالت انتخاب باشد.
تغيير نوع قلم: از منوي بازشويFont  Name در پنل Object	 قلم‌   موردنظر را انتخاب 

کنيد. تعداد ‌اين قلم‌ها به تعداد فونت‌هاي نصب شده در ويندوز بستگي دارند.  
تغيير اندازه قلم: از منوي بازش��وي Type Size در پنل Object	 اندازه قلم را تعيين 

کنيد.
 : Text از منوی Size نکته: در انتخاب گزینة 

با اس��تفاده از گزینة smaller یا فش��ردن کلید ) , + Ctrl + Shfit	 ( اندازه قلم یک سایز 
کوچکتر می شود.

با اس��تفاده از گزینة smaller یا فش��ردن کلید ) . + Ctrl + Shfit	 ( اندازه قلم یک سایز 
کوچکتر می شود.
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. با استفاده از گزینة other برای تایپ اندازه دلخواه به کار می رود	

	
 

		                  شکل 7-9 تغيير اندازه قلم                  شکل 6-9 تغيير نوع قلم

مي‌توانيد ب��ا وارد کردن مق��دار مثبت يا منفي  تغيي�ر فاصله بين ح�روف کلمات: 	
برحس��ب درصد در کادر Kerning واقع در پنل Object، فاصله بين حروف را افزايش 

يا کاهش دهيد.

شکل 9-8

اگر دس��تگيره‌هاي کنترلي وسط در س��مت چپ يا راست کادر را بکشيد، مي‌توانيد  	
فاصله بين حروف متن )Kerning( را افزايش يا کاهش دهيد )شکل 9-9(.

شکل 9-9 تغيير فاصله بين حروف متن

 ، 	Object در پنل Baseline Shift انتقال خط مبنا: با وارد کردن مقادير مثبت در کادر
حرف به بالاي خط مبناي مربوط به متن منتقل مي‌شود و مقادير منفي، حرف را به 
پايين خط مبنا انتقال مي‌دهد.شکل10-9 نحوه عملکرد اين کادر را نشان مي‌دهد.

شکل 9-10
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4-2-9 اعمال رنگ به متن

براي اين منظور عمليات زير را انجام دهيد:
1- متن موردنظر را انتخاب کنيد.

2- رنگ موردنظر را از ابزارهاي رنگ واقع در جعبه ابزار Tools برگزينيد.
اب��زارFill Color ، داخل متن و اب��زار Stroke Color، خطوط پيرامون متن را رنگ مي‌کند. 
براي مش��اهده تغييرات رنگ بهتر است اندازه متن را بزرگ کنيد )توضيحات بيشتر در مورد 

انواع روش‌هاي رنگ‌آميزي در واحد کار 7 ذکر شده است(. 

 مثال 1: براي بالا بردن توانايي عمليات روي متن، مراحل زير را انجام دهيد:
1- صفحه جديدي به اندازه A5 با واحد سانتي‌متر ايجاد کنيد.

2- نوار ابزار Text را نمايش دهيد.
3- قل��م Arial  را از من��وي Text→Font انتخ��اب کرده و اندازه 36 را ب��راي آن تعيين 

کنيد.
FreeHand MX is Vector based drawing                   .4- جمله روبه‌رو را تايپ کنيد

5- با استفاده از پنل Object سبک قلم را پررنگ )Bold( کنيد.
6- با استفاده از پنل Object فاصله ميان حروف کلمه FreeHand را 10% افزايش و کلمه 

Vector را 20-% کاهش دهيد، سپس به حالت اوليه بازگرديد.

7- کل سطر را در زير سطر جاري کپي کنيد.
8- ب��ا اس��تفاده از نوار ابزار Text ان��دازه قلم کلمه drawing س��طر دوم را به 14 کاهش 

دهيد.
 Object يا قلم نازک را از پنل Plain را از سطر اول انتخاب کرده و سبک Vector 9- کلمه

برگزينيد.

تمرين 1: براي كلمه "خرد" طراحي حروف كنيد.
 Text 3-9 منوي

با اس��تفاده از من��وي Text و زيرمنوهاي آن مي‌توانيد علاوه ب��ر تنظيمات مربوط به نوع 
فونت، اندازه، سبك )Style( و ترازبندي متن، جلوه‌هاي ويژه‌اي نيز به متن اعمال كنيد.
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)Text Effects( 1-3-9 جلوه‌هاي متن

در FreeHand MXa ب��راي زيبات��ر و هنري ش��دن کار از جلوه‌هاي ويژه متني اس��تفاده 
مي‌شود. روش‌هاي دسترسي به اين جلوه‌‌ها به صورت زير است:

	Text در منوي Effect استفاده از گزينه
	Object در پايين پنل Effect استفاده از منوي بازشوي

Object واقع در پنل Effect شکل 11-9 گزينه‌هاي موجود در منوي

Inline 1-1-3-9 جلوه
اين جلوه براي رسم خط يا قاب، دور حروف متن انتخابي به‌کار مي‌رود. گاهي در طراحي 
براي برجسته شدن متن يا تمايز بهتر حروف از زمينه زير آن، لازم است از اين جلوه استفاده 

شود.
ايجاد جلوه Inline روي متن

1- متن موردنظر را برگزينيد.
  Effectرا از منوي بازشوي Inline را انتخاب کنيد )گزينه Text→Effect→Inline 2- گزينه
 در پن��ل Object برگزيني��د.( تا کادر مح��اوره Inline Effect روي صفحه نمايش ظاهر ش��ود 

)شکل 9-12(.
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Inline Effect شکل 12-9 کادر محاوره

اين کادر شامل قسمت‌هاي زير است:
Count: تعداد خطوطي را که در اطراف حروف متن قرار مي‌گيرد، تعيين مي‌کند.	

Stroke: در اين قسمت ضخامت و رنگ خط دور متن تعيين مي‌شود.	

، فاصل��ه بين خط دور تا لبه حروف  	Width ب��ا اين گزينه در قس��مت :Background

تعيين مي‌ش��ود و با انتخاب رنگ در اين قس��مت، فضاي بين خط تا حروف از اين 
رنگ پر مي‌شود.

تمرين 2:
1- در چه صورت خط به دور حروف مي‌چسبد؟

2- متن شكل 13-9 را تايپ کنيد.

شکل 9-13

 Highlight 2-1-3-9 جلوه
اين جلوه يک کادر رنگي در پشت متن انتخابي قرار مي‌دهد که به منظور شاخص کردن 
متن ب��ه کار مي‌رود. با اجراي اين گزينه از مس��ير Text→Effect→Highlight، کادر محاوره 

مربوط به اين جلوه روي صفحه نمايش ظاهر مي‌شود )شکل 9-14(.
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شکل 14-9 کادر محاوره Highlight Effect  و دو نمونه کاربرد اين جلوه

اين کادر شامل قسمت‌هاي زير است:
Position:	 مح��ل قرار‌گيري کادر را در زير متن به صورت عددي تعيين کرده، اعداد 

مثب��ت ‌کادر را از مت��ن بالات��ر مي‌برد و اعداد منف��ي کادر را پايين‌ت��ر از متن قرار 
مي‌دهد.

اي��ن منوي بازش��و کادر رنگي زمينه را به صورت خطوط هاش��ور مش��خص  	 :Dash

مي‌کند.
توس��ط گزينه‌هاي اين قسمت مي‌توانيد ضخامت، رنگ پس‌زمينه يا هاشور  	 :Stroke

را تعيين کنيد.

 توجه: گزينه Overprint روشي است براي جبران خطاي ترکيب رنگ که در زمان 
چاپ رخ مي‌دهد.

 Shadow3-1-3-9 جلوه
يک��ي ‌ديگر از جلوه‌هاي ‌جالب��ي که مي‌توانيد روي‌ متن و حروف اعمال‌ کنيد، س��ايه‌دار 
‌کردن آن‌هاس��ت. با اجراي گزينه Text→Effect→Shadow کادرمحاوره Shadow Effect ظاهر 

مي‌شود )شکل 9-15(.

شکل 15-9 کادرمحاورهShadow Effect  و تأثير آن روي متن
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اين کادر شامل گزينه‌هاي زير است:
Offset: در کادرهاي x و y	 محل دقيق قرار گرفتن سايه براساس محورهاي مختصات 

تعيين مي‌شود.
Color:	 در اين قسمت رنگ سايه تعيين شده و توسط دکمه لغزنده ميزان تيرگي و 

روشني سايه تنظيم مي‌شود.
مثال 2: جلوه‌هاي نشان داده شده در شکل 16-9 را اعمال کنيد.

شکل 9-16

1- ابتدا متن را تايپ کنيد به طوري که اندازه قلم 120 باشد.
2- کل متن را انتخاب کرده و جلوه Highlight را با تنظيمات ش��کل 17-9 به آن اعمال 

کنيد.
3- ح��روف C و R را جداگان��ه انتخاب کرده، جلوه Shadow را همراه با تنظيمات ش��کل 

17-9 به آن‌ها اعمال کنيد.

شکل 9-17

 Strikethrough 4-1-3-9 جلوه
اين جلوه خطي رسم ميك‌ند كه از روي متن مي‌گذرد. 

با اجراي گزينه Text→Effect→Strikethrough کادر محاوره اين جلوه مطابق شکل 9-18 
نمايش داده مي‌شود كه در اين شکل، جلوه نقطه‌چين و خط، نشان داده شده است.      
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شکل 18-9 کادر محاوره Strikethrough Effect  و تأثير آن روي متن

اين کادر محاوره شامل قسمت‌هاي زير است:
Position: محل قرار‌گيري خط را در روي متن تعيين مي‌کند.	

Dash: نوع خط را تعيين مي‌کند.	

Stroke: در اين قسمت ضخامت و رنگ خط تعيين مي‌شود.	

 Underline 5-1-3-9 جلوه
 از اـين جلــوه بــراي کشيدن خط در زير متن استفـاده مـي‌شود. بدين منظور کافي است گزينـه
"Text→Effect→Underline را انتخاب کنيد تا کادر محاوره آن مطابق شکل 19-9 ظاهر شود. در 

ش��کل 19-9 دو نوع جلوه زيرخط به صورت خط- نقطه و خط، نش��ان داده شده است. کليه 
گزينه‌هاي کنترلي اين کادر مانند تنظيمات کادر محاوره Strikethrough Effect است.

شکل 19-9 کادر محاوره Underline Effect  و تأثير آن روي متن

 Zoom 6-1-3-9 جلوه
يک��ي از جلوه‌هايي که تا حد زيادي در زيباي��ي متن و حروف در يک کار تبليغاتي تأثير 
مي‌گ��ذارد، جلوه Zoom اس��ت که اين جلوه به متن و عبارت حالت پرس��پكتيو س��ه بعدي 
مي‌بخشد. براي اعمال اين جلوه کافي است گزينه Text→Effect→Zoom را انتخاب کنيد تا 

کادر محاوره آن مطابق شکل 20-9 ظاهر شود.
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شکل 20-9 کادر محاوره Zoom Effect  و تأثير آن روي متن

اين کادر محاوره شامل قسمت‌هاي زير است:
کوچکي حالت سه ‌بعدي را برحسب در‌صد تعيين  Zoom To: اين قس��مت بزرگي و 	

مي‌کند. به عبارت ديگر درصد بزرگنمايي و پخش‌شدگي جلوه سه بعدي را مشخص 
مي‌کند.

قرار دارند که توس��ط آن‌ه��ا مي‌توانيد محل  	 y و x در اي��ن قس��مت دو کادر :Offset

دقيق قرار‌گيري اين جلوه را تعيين کنيد. اعداد بزرگ‌تر به عمق س��ه بعدي حروف 
مي‌افزايد.

From: اين قسمت رنگ شروع جلوه سه بعدي را مشخص مي‌کند.	

To: اين قسمت رنگي را تعيين مي‌کند که جلوه سه بعدي به آن خاتمه ميي‌ابد. 	

رنگ در حالت پيش‌فرض از سياه به سفيد است.

 توج�ه: انتخاب گزينه None از مس��ير Text→Effect هر نوع جلوه متني را از بين 

مي‌برد.

تمرين 3:
1- مت��ن Working with text blocks را تايپ‌کرده، س��پس اثرجلوه‌هاي ‌متني ‌را روي ‌آن 

بررسي‌کنيد.
2- طرح زير را همراه با جلوه‌هاي متني آن رسم کنيد )شکل 9-21(.
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 شکل 9-21 

 Attach To Path2-3-9 گزينه
يکي از جلوه‌هاي هنري در طراحي، متصل کردن متن به مس��ير رس��م ش��ده اس��ت؛ از 
اين ويژگي براي پيچ و تاب دادن متون در مس��يرهاي منحني، بيضي و نظير اين‌ها اس��تفاده 

مي‌شود. براي اين منظور مراحل بعد را انجام دهيد:
1- متن موردنظر را تايپ کرده و به وسيله ابزار Pen مسير دلخواهي را روي ‌صفحه رسم 

کنيد )از اشکال دايره، بيضي، چند ضلعي و ... نيز مي‌توان استفاده کرد(.
2- ابتدا متن را انتخاب کرده، سپس کليد Shift را نگه داريد و مسير را برگزينيد.

3- دستورText→Attach To Path  را اجرا کنيد يا روي آيکن  از نوار ابزار Text کليک 
 کنيد. در اين صورت متن به مسير مي‌چسبد و با آن تراز مي‌شود و مسير حذف خواهد شد 

)شکل 9-22(.

شکل 22-9 نحوه اتصال متن به مسير     

 Text on a path در س��اختار درختي بخش Object نكت�ه: در صورت��ي كه در پنل 
را انتخاب كنيد، گزينه Show Path ظاهر مي‌ش��ود‏، ب��ا فعال كردن اين گزينه مي‌توانيد پس 
از اجراي فرمان Attach To Path مس��ير را همراه متن داشته باشيد و از حذف آن جلوگيري 

كنيد.

تمرين 4: طرح شكل 23-9 را رسم کنيد.
براي حرکت دادن متن در امتداد مس��ير، ابتدا با ابزار Pointer مسير را انتخاب کنيد؛ در 
اين صورت يک مثلث سفيد رنگ کوچک ظاهر مي‌شود. اکنون مي‌توانيد مثلث کنار متن را 

بکشيد تا متن در امتداد مسير حرکت کند.
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         شکل 23-9                               شکل 24-9 نمايش مثلث كنار متن

 نكته: کليد ميانبر گزينه Ctrl+Shift+Y ،Attach To Path است.

 Detach From Path3-3-9 گزينه

براي جدا كردن متن از مس��ير، فرمان Detach From Path در منوي Text يا آيکن  
در نوار ابزار Text را انتخاب كنيد.

 توجه: براي تغيير جهت متن در روي مسير كافي است كليد Alt را نگه داشته و با 

 Modify→Alter Path→Reverse Direction مسير را انتخاب كنيد سپس فرمان Pointer ابزار
را اجرا كنيد )شكل 9-25(.

شکل 25-9 تغيير جهت متن

 مثال 3: شکل 26-9 را رسم کنيد.
1- صفحه جديدي را باز کنيد.

2- عبارت زير را تايپ کنيد.
Macromedia Freehand MX With Attach To Path

3- ابزار رسم ستاره را انتخاب کرده و يک ستاره سه پر رسم کنيد.
4- اکن��ون روي ابزار Pointer کليک کرده و کليد Shift را پايين نگه داريد و روي متن و 

ستاره کليک کنيد تا هر دو انتخاب شوند.
5- ح��ال فرمان Attach To Path را از منوي Text يا از نوار ابزار Text اجرا کنيد. با انجام 
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اين عمل متن به مسير مي‌چسبد.

شکل 9-26

تمرين 5: آرم زير را طراحي کنيد.

 شکل 9-27 

تمرين 6: كي بروش��ور تبليغاتي در كاغذ A4 براي "هنرس��تان كاردانش گلشن" 
طراحي كنيد و آرم شكل 27-9 را در آن استفاده كنيد.

Convert To Path 4-3-9 گزينه

گاهي اوقات در هنگام طراحي لازم است يک متن از حالت نوشته خارج شده و به مسير 
يا ش��کل تبديل ش��ود. در اين صورت خصوصيات يک شکل را پيدا مي‌کند. براي اين منظور 

مراحل زير را انجام دهيد: 
1- متن موردنظر را تايپ کرده و آن را انتخاب کنيد.

2- از منوي Text گزينه Convert To Path يا آيکن  را از روي نوار ابزار Text انتخاب 
کنيد، در اين صورت متن به مسير يا موضوع تبديل مي‌شود )شکل 9-28(.

شکل 9-28
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 توجه: کليد ميانبر اين گزينه Ctrl+Shift+P  است.

 نكته: پس از تبديل متن به مس��ير، متن تمام خصوصيات متني خود را از دست 
مي‌دهد و ديگر قابل ويرايش )نظير تغيير قلم( نخواهد بود.

ب��راي تغيير دادن و جابه‌جايي ح��روف به صورت جداگانه در مت��ن مي‌توانيد متن  	
 ungroup آن را Modify تبديل شده به مسير را انتخاب کرده، سپس از طريق منوي
ک��رده يا کليد Alt را در هنگام کليک روي هر مس��ير مج��زا نگه داريد تا يک حرف 

انتخاب شود، سپس بعد از اعمال تغييرات دوباره آن‌ها را Modify→Group کنيد. 
 تمرين 7: نشانه‌هاي بعدي را رسم کنيد.

شکل 9-29

Editor 5-3-9 گزينه

به منظور ويرايش متون و نوشته‌ها مي‌توانيد به دو صورت عمل کنيد: 
1- روي متن تايپ ش��ده توس��ط ابزار Pointer دابل کليک کنيد ت��ا علامت مکان‌نماي 

چشمک‌زن ظاهر شود، در اين صورت مي‌توانيد به اصلاح متن بپردازيد.
 Text روي متن کليک کنيد تا انتخاب ش��ود، س��پس از منوي Pointer 2- ابت��دا با ابزار
گزين��هEditor  را اجرا کنيد يا روي آيکن  از نوار ابزار Text کليک کنيد. در اين صورت 

کادر محاوره Text Editor ظاهر مي‌شود و مي‌توانيد متن را به سادگي ويرايش کنيد.
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 توجه: اگر به وس��يله ابزار انتخ��اب subselect  روي متن دابل کليک کنيد، کادر محاوره 

Text Editor  به‌طور خودکار باز مي‌شود.

اگر گزينه 12Pt Black	 انتخاب ش��ود، متن به اندازه واقعي نمايش نميي‌ابد يعني در 
حقيقت متن کوچک مي‌شود تا تمامي آن در صفحه قابل مشاهده باشد.

اگ��ر گزين��ه Show Invisibles	 انتخاب ‌ش��ود، باعث نمايش کاراکتره��اي مجازي و 
غيرقابل‌چاپ مثل Space ،Tab و Enter مي‌شود )‌شکل 9-30(.

Text Editor شکل 30-9 محيط

 Flow Inside Path6-3-9 گزينه

از اين گزينه براي قرار دادن متن در داخل ش��کل يا درون يک مس��ير استفاده مي‌شود، 
به طوري که متن، قالب محيط شکل را به خود مي‌گيرد. اين جلوه بيشتر براي زيباتر کردن 

ترکيب‌بندي متن و شکل در طراحي کاتالوگ و بروشور به‌کار مي‌رود.
نحوه اجراي اين گزينه به صورت زير است: 
1- متن پاراگرافي دلخواهي را تايپ کنيد.

2- شکل يا مسيري را ترسيم کنيد.
3- شکل و متن موردنظر را با هم انتخاب کنيد.

4- از منوي Text گزينه Flow Inside Path يا آيکن  را از نوارابزار Text انتخاب ‌کنيد 
)شکل 9-31(.                             
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Flow Inside Path شکل 31-9 تأثير فرمان 

 توجه: کليد ميانبر اين گزينه Ctrl+Shift+U است.

نکاتي در مورد کادر لينک
ب��ه مربع کوچکي که در پايين، س��مت راس��ت کادر متن قرار گرفت��ه، کادر لينک گفته 

مي‌شود.
يک��ي از کاربردهاي آن زماني اس��ت که متن در کادر مت��ن جاي نمي‌گيرد و داخل کادر 
لين��ک داي��ره توپر قرار مي‌گي��رد. در اين حال��ت مي‌توانيد با کليک روي داي��ره توپر داخل 
کادر لينک و کش��يدن آن به طرف ش��کل ديگر، ادامه متن را در آن شکل وارد کنيد )شکل 

.)9-32

شکل 9-32

در صورتي که کادر لينک سفيد باشد، نشان دهنده اين است که کل متن در شکل  	
جا گرفته و قابل مشاهده است )شکل 33-9 سمت راست(.

در صورتي که يک دايره توپر در داخل کادر لينک وجود داش��ته باش��د نشانگر اين  	
است كه متن موجود در داخل کادر جا نمي‌گيرد يا به عبارتيOverflow  است )شکل 



Free Hand پیمانه مهارتی : کاربر
239واحد کار نهم: توانایی کار با متن 

33-9 سمت چپ(.
‌در کادر لينک وجود داش��ته باش��د، نشانگر اين است که  در صورتي که علامت 	

کادر به کادر يا شکل ديگري مرتبط يا لينک شده است )شکل بالا 9-32(.

         

شکل 9-33

تمرين 8: شكل زير را با استفاده از قابليت Flow Inside Path طراحي کنيد.

 

شکل 9-34

 Flow Around Selection 9-3-7

به منظور قرار دادن متن پاراگرافي در اطراف يک ش��کل رس��م ش��ده يا وارد شده به‌کار 
مي‌رود )شکل 9-35(. 
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Flow Around Selectionشکل 35-9 تأثير فرمان

روش کار به صورت زير است: 
1- ابزار تايپ را انتخاب کرده و با انجام عمل درگ يک کادر مستطيلي براي نوشتن متن 

پاراگرافي روي صفحه ايجاد کنيد، سپس متن موردنظر را  داخل آن تايپ كنيد.
2- يک تصوير را وارد FreeHand کرده يا يک ش��کل دلخواه را ترس��يم کنيد. بهتر است 
ش��کل را رنگ کنيد تا تغيير مشخص‌تر شود، سپس شکل را به محلي که قرار است در متن 

قرار گيرد، منتقل کنيد. توجه داشته باشيد كه شكل جلوي بلوك متني قرار گيرد.
 Flow Around Selection فرمان Text 3- متن و ش��کل را با هم انتخاب کرده و از منوي
 را برگزيني��د ي��ا روي ‌آيکن در نوار ‌ابزار Text کليک‌ کني��د. در ‌اين ‌صورت کادرمحاوره

Flow Around Selection ظاهر مي‌شود.

4- در ب��الاي اي��ن کادر محاوره دو دکمه براي تعيين وضعيت قرارگيري ش��کل در متن 
و ح��ذف اين ويژگي وجود دارد. در اين کادر مي‌توانيد با انتخاب آيکن Text Wrap )س��مت 
راست( و با استفاده از کادرهاي موجود در قسمت  Standoff)فاصله متن از شكل( فاصله‌هاي 

چپ، راست، بالا و پايين متن از شكل را تعيين كنيد )شکل 9-36(.
5- روي‌دكمه OK كليك‌كنيد. متن به‌طور خودكار در‌ اطراف ‌ش��كل قرارمي‌گيرد )شكل 

.)9-35

 توجه: براي حذف اين ويژگي ابتدا موضوع را انتخاب کنيد، سپس از کادر محاوره

Flow Around Selection دکمه Remove Text Wrap را برگزينيد.
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Flow Around Selection شکل 36-9 کادر محاوره

Remove Transforms 9-3-8

 اجراي گزينه Text→Remove Transforms سبب حذف برخي از جلوه‌هاي متن انتخابي نظير
Attach To Path و Flow Inside Path مي‌ش��ود و مت��ن ب��ه حال��ت اوليه خ��ود باز مي‌گردد. 

 Scale ،Skew ،Rotate اعمال شده به متن مانند )Transform( همچنين همه تغيير شكل‌هاي
و Reflect بجز Move را حذف ميك‌ند.

براي انجام اين عمل مراحل زير را پيگيري كنيد:
1- با استفاده از ابزار Pointer بلوك متني را انتخاب كنيد.

2- گزينه Remove Transforms  را از منوي Text برگزينيد.

 Remove هايي ك��ه در جعبه ابزار وجود دارد ب��ا فرمانTransform نكت�ه: كلي��ه 
Transforms حذف مي‌شود.

Special Characters 9-3-9

درج كاراكترهاي ويژه در هنگام تايپ متن سبب كنترل نماي متن مي‌شود.

شکل 9-37

براي استفاده از كاراكترهاي ويژه مراحل بعد را انجام دهيد:
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1- در محل مورد نظر در متن، كليك كنيد تا نقطه درج مشخص شود.
2- گزين��ه Text→Special Character را انتخ��اب كرده س��پس از زير منوي ظاهر ش��ده 

كاراكتر ويژه را برگزينيد.
Spelling 10-3-9 گزينه

اگر بخواهيد اطمينان يابيد كه متن سند موردنظر از لحاظ املايي صحيح است، مي‌توانيد 
.)Text→Spelling(استفاده نماييد )Spelling( از غلط‌گير كلمات تايپ شده

شكل 9-38
Leading 11-3-9 فرمان

گاه��ي براي زيبايي مت��ن يا کمبود فضا لازم اس��ت به تنظيم فاصله س��طرها در متون 
پاراگراف��ي بپردازي��د. ب��راي اين منظور از من��وي Text  گزين��ه Leading  را انتخاب کنيد يا 
دستگيره‌هاي کنترلي وسط در سمت بالا يا پايين کادر انتخاب متن را بکشيد تا فاصله بين 

       			  سطرها کاهش يا افزايش يابد

شکل 9-39

در اين گزينه سه زيرمجموعه به صورت زير وجود دارد:
با توجه به ‌اندازه‌ فونت انتخاب شده در‌متن‌جاري، فاصله را به‌صورت ‌خودکار  	 :Solid

تنظيم ‌مي‌کند. 
Auto: فاصله سطرها را 120% بيشتر از حالت Solid در نظر مي‌گيرد.	
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Other: با انتخاب اين گزينه کادر محاوره Leading مطابق شکل 40-9	 ظاهر مي‌شود 

که مي‌توان با اس��تفاده از گزينه‌هاي منوي بازش��وي آن براي س��طرها فاصله ايجاد 
کرد.

شکل 9-40

گزينه Extra:	 به ميزان عدد وارد شده، به فاصله سطرها مي‌افزايد. اين گزينه معادل 
علامت + در نوار ابزار Text  است.

گزينه Fixed:	 فاصله س��طرها را دقيقاً بر اس��اس عدد وارد شده تنظيم مي‌کند. اين 
گزينه نيز معادل علامت = در نوار ابزار Text  است.

گزين�ه Percentage: فاصل��ه را 100% در نظر مي‌گيرد. اع��داد کوچک‌تر از %100	 
باع��ث کاهش فاصله و اعداد بزرگ‌تر از 100% منجر به افزايش فاصله س��طر جاري 

مي‌شوند. اين گزينه معادل علامت % در نوار ابزار Text  است.

 نكت�ه: از گزين��ه Leading  در پنل Object  مربوط به Text نيز براي تغيير فاصله 
بين خطوط متن استفاده مي‌شود )شکل 9-41(.

شكل 9-41

Convert Case 12-3-9 فرمان

ب��ه کم��ک اين گزينه مي‌توانيد حالت حروف انگليس��ي را از بزرگ به کوچک يا برعکس 
تبدي��ل کني��د. اين تبديل مي‌توان��د روي همه حروف صورت گيرد ي��ا از قواعد جدول 9-1 

پيروي کند. 
گزينه Convert Case را از منوي Text انتخاب کنيد. منو شامل اين زيرمجموعه‌هاست:
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جدول 9-1

 Upper.کل حروف متن انتخاب شده را به حروف بزرگ انگليسي تبديل مي‌کند

 Lower.کل حروف متن انتخاب شده را به حروف کوچک انگليسي تبديل مي‌کند

Small Caps
حروف کوچک متن انتخاب شده را به حروف بزرگ با اندازه کوچک تبديل مي‌کند )به طور 

پيش‌فرض 75% اندازه فونت جاري است(.

 Title.حروف ابتداي همه کلمات را در متن انتخاب شده به حروف بزرگ تبديل مي‌کند

 Sentence
متن انتخاب شده را به عنوان يک جمله در نظر مي‌گيرد و فقط حرف اول جمله را به حرف 

بزرگ تبديل مي‌کند.

Settings
در اين گزينه مي‌توان توسط دکمه Add کلمه‌اي را وارد ليست کرد تا در صورت تغييرات متن 

توسط گزينه Convert Case بدون تغيير باقي ‌بماند و کلمه‌ موردنظر تغيير نکند.

             

تمرين 9:
1- جملات زير را تايپ کنيد.

To copy from another application and paste into FreeHand,
to specify a size for small caps.                                        

2- حرف اول کلمات دوم و پنجم سطر اول را به حروف بزرگ تبديل کنيد.
3- کليه حروف کلمهFreeHand  را به حروف بزرگ تبديل کنيد.

4- نخستين حرف کلمه اول سطر دوم را به حرف بزرگ تبديل کنيد.
5- ح��روف ابت��داي کلمات س��طر دوم را بجز کلمهsize  و caps به ح��روف بزرگ تبديل 

کنيد.
6- فاصله بين 2 سطر را دقيقاً 40 تعيين کنيد.

Object در پنل Text Block 9-4
در صورتي كه متني نوش��ته باش��يد در پنلObject  بخش��ي به نام  Text Blockبه صورت 
س��اختار درختي نمايان مي‌ش��ود. با كليك روي اين بخش، كنترل‌هايText Block  مطابق با 

شكل 42-9 نشان داده مي‌شوند.
فيلدهاي Dimensions به صورت زير تنظيم مي‌شوند:

l: موقعيت لبه چپ بلوك متني را كنترل ميك‌ند.	
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t: موقعيت لبه بالايي بلوك متني را كنترل ميك‌ند.	
اين فيلدها به شما امكان مي‌دهند تا بلوك متني را به محل خاصي جابه‌جا كنيد.

عرض بلوك متني را تنظيم ميك‌ند. 	 :w
ارتفاع بلوك متني را تنظيم ميك‌ند. 	 :h

اين فيلدها براي تغيير اندازه بلوك متني به كار مي‌روند.
اگر به بلوك متن حاش��يه داده‌ايد براي اضافه كردن فضاي س��فيد بين متن و حاشيه از 

قسمت Inset استفاده كنيد. 

Object در پنل  Block Text  9-42شکل

left( l( از س��مت چپ، t )top( بالا، r )right( س��مت راس��ت و b )bottom( پايين حاشيه 
ايجاد ميك‌ند.

 : وقتي اين آكين برجس��ته است يعني در حالت انتخاب نيست، براي تنظيم عرض 
بلوك متني در حالت اندازه ثابت )Fixed-Size( به كار مي‌رود.

وقتي اين آكين به صورت فرورفته يعني در حالت انتخاب است، براي تنظيم عرض بلوك 
متني در حالت گسترش خودكار )Auto-Expand( استفاده مي‌شود.

 : وقتي اين آكين برجسته است و در حالت انتخاب نيست، براي تنظيم ارتفاع بلوك 
متني در حالت اندازه ثابت )Fixed-Size( به كار مي‌رود.

وقت��ي اين آكي��ن در حالت فرورفته و در وضعيت انتخاب ق��رار دارد، براي تنظيم ارتفاع 
بلوك متني در حالت گسترش خودكار )Auto-Expand( استفاده مي‌شود.

فعال بودن كادر علامت Display border	 به شما امكان مي‌دهد كه حاشيه بلوك متن 
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را مشاهده كنيد ولي خط دور )Stroke( ايجاد نميك‌ند.

 توجه: براي اعمال حاش��يه به بلوك متني انتخاب شده، روي Add Stroke در پنل

Object  كليك كنيد، سپس كيي از انواع خط دور را براي حاشيه برگزينيد.

FreeHand MXa 5-9 فارسي‌نويسي در
يکي از مسايلي که کاربران فارسي زبان FreeHand با آن مواجه هستند؛ نوشتن متون به 

زبان فارسي است، زيرا در اين برنامه امکان فارسي‌نويسي وجود ندارد.
براي فارسي نوشتن در FreeHand MX ابتدا بايد در يک برنامه فارسي‌نويس، متن موردنظر 

.)Paste( بچسبانيد FreeHand را تايپ کنيد، سپس متن را کپي کرده و در
براي اين منظور مراحل زير را دنبال کنيد:

1- برنامه فارسي‌ساز را اجرا کنيد و متن موردنظر را تايپ کنيد )شکل 9-43(.
2- متن تايپ شده را انتخاب کرده و آن را کپي )Ctrl+C( کنيد.

3- برنامه FreeHand را باز کرده و ابزار تايپ متن را از جعبه ابزار انتخاب کنيد.
4- روي صفحه کليک کنيد تا علامت مکان‌نماي چشمک‌زن ظاهر شود، اکنون متن کپي 

.)Ctrl+V( شده را در صفحه بچسبانيد
توجه داش��ته باشيد که نام فونت در FreeHand بايد همان نام فونت در برنامه فارسي‌ساز 

باشد.

شکل 9-43  
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FreeHand MX شکل 44-9 نمايش متن فارسي در محيط 

 مث�ال كاربردي: در ادامه مثال كاربردي واحد كار پيش��ين مراحل زير را انجام 
دهيد:

1- فايل Project.fh11 را باز كنيد.
2- با اس��تفاده از ابزار Text عبارت متني ش��كل را در كارت به رنگ دلخواه تايپ كنيد، 

سپس آدرس و تلفن مورد نظر خود را در كارت وارد كنيد.
3- فايل را ذخيره کنيد.                                                           

شكل 9-45
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واژه‌نامه
Attachمتصل‌کردن، الصاق‌کردن

Effectجلوه

Pathمسير

Plainساده، عادي

Positionموقعيت

Spellهجيك‌ردن

Specialمخصوص، ويژه

	
	
	

خلاصه مطالب 
به‌طور‌کلي در FreeHand	 مي‌توانيد از قابليت تايپ متن به عنوان يک برنامه واژه‌پرداز 

يا يک برنامه صفحه‌بندي استفاده کنيد.
موارد زير از قابليت‌هاي اين نرم‌افزار براي انجام عمليات روي متن است: 	

تغيير تنظيمات متن از جمله اندازه و نوع قلم 	
	)Leading( تغيير فاصله بين حروف و سطرها
	Effect ايجاد جلوه‌هاي متني با استفاده از گزينه
	)Attach To Path( قرار دادن متن در داخل يا خارج يک مسير
	)Flow Inside Path( قرار دادن متن در داخل يک موضوع يا مسير
	 )Convert To Path( تبديل متن انتخابي به موضوع يا مسير
	)Special Characters( درج كاراكترهاي ويژه در متن
	)Spelling( غلط‌گيري كلمات تايپ شده
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آزمون نظري
درستي يا نادرستي گزينه هاي زير را تعيين کنيد.

1- گزينه Leading از نوار ابزار Text، براي تغيير نوع قلم به کار مي‌رود.
2- جلوه Zoom براي سه بعدي کردن حروف در متن به كار مي‌رود.

Spelling -3 بررسي ميك‌ند كه متن سند موردنظر از لحاظ املايي صحيح است يا خير.

En Dash -4 فاصله‌اي معادل نصف عرض اندازه فونت در متن درج ميك‌ند.

معادل گزينه هاي سمت ‌راست را از ستون سمت ‌چپ انتخاب کرده و مقابل هر عبارت بنويسيد.

                                Flow Around Selection                     .است  FreeHand 5- ويرايشگر متن در برنامه
Attach To Path          .6- جلوه‌هاي متني را حذف و آن را به حالت اوليه برمي‌گرداند
Remove Transform                                     .7-  متن را روي مسير قرار مي‌دهد

 Text Editor                                     .8- متن را در اطراف كي مسير قرار مي‌دهد
گزينه صحيح را انتخاب کنيد.

9-گزينه Strikethrough چه کاربردي دارد؟
ب- در روي متن خط رسم مي‌کند. الف- در زير متن  خط ايجاد مي‌کند.	

د- متن را به مسير مي‌چسباند. ج- در پشت متن خط رسم مي‌کند.	
10-گزينه Plain در بخش Text از پنل Object چه عملي را انجام مي‌دهد؟
ب- ايجاد سبک مايل براي قلم  الف- ايجاد سبک پر رنگ براي قلم 	

د- ايجاد سبک مايل و پررنگ براي قلم ج- ايجاد سبک قلم نازک و معمولي	
11- براي چسباندن متن به يک مسير منحني از کدام فرمان استفاده مي‌شود؟

Text از منوي Attach To Path -ب              	Edit از منوي Pointer -الف
د- کشيدن متن روي مسير	 	Text از منوي Detach From Path -ج

12- ک��دام گزينه به منظ��ور ايجاد فاصله بين س��طرها با مقدار دلخواه کاربر اس��تفاده 
مي‌‌شود؟

 Text→Leading→Solid -ب       	 Text→Leading→Other -الف
Text→Leading→Settings -د          	Text→Leading→Auto -ج

13- کدامي‌ک از جلوه‌هاي زير براي حروف متن سايه ايجاد مي‌کند؟
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Shadow -د           	Highlight -ج  	Zoom -ب     	 Inline -الف
14- کدام گزينه براي قرار دادن متن درون يک مسير بسته استفاده مي‌شود؟

 Ctrl+Shift+U -ب 	  Flow Inside Path -الف
د- گزينه‌هاي الف و ب صحيح هستند. 		 Attach  To Path -ج

15- فرمان Convert Case  در منوي Text به چه منظور استفاده مي‌شود؟
الف- تنظيم فاصله سطرها در متن پاراگرافي

ب- تبديل نوع کلمات متن
ج- تبديل حروف کوچک و بزرگ به يکديگر در متون انگليسي

د- تبديل مسير به متن 
16- گزينه Title در Convert Case چه کاربردي دارد؟

الف- براي بزرگ کردن حروف با اندازه کوچک استفاده مي‌شود. 
ب- حرف اول همه كلمات متن انتخابي را بزرگ و بقيه را کوچک مي‌کند.

ج- حروف متن انتخابي را به حروف کوچک تبديل مي‌کند.
د- حرف اول جملات را بزرگ مي‌کند.

17- گزين��ه .............. ح��رف اول جم�الت را ب��زرگ و بقيه را به ح��روف کوچک تبديل 
مي‌کند.

Sentence -ب           		   Upper -الف
Lower -د 	                     Small Caps -ج

در جاي خالي عبارت مناسب را بنويسيد.

 Leading 18- علام��ت % در ايجاد فاصله بين س��طرها مع��ادل ................... از گزينه‌هاي
است.

19- گزينه Convert To Path  ..............................  تبديل ميك‌ند.
به سؤالات زير پاسخ تشريحی دهيد.

FreeHand MX -20 از چند طريق خصوصيات متون را کنترل مي‌کند؟

Stroke Color -21 در متن چه کاربردي دارد؟

22- آيا تغيير اندازه متني که به مسير تبديل شده، تأثيري در کيفيت آن دارد؟ چرا؟
23- گزين��ه Fixed چگون��ه فاصل��ه بين س��طرها را تنظيم مي‌کند و از چ��ه طريق قابل 
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دستيابي است؟
24- کدام جلوه به متن حالت س��ه بعدي مي‌دهد و آيا جلوه‌هاي ويژه )Effect( علاوه بر 

متون براي ساير موضوعات نيز قابل اجراست؟
آزمون عملي

1- نشانه‌هاي زير را ترسيم کنيد.

 

2- كي جلد مجله با مشخصات زير طراحي كنيد.
مجله علمي به نام "راهي به سوي فردا" در كاغذ A4 طراحي كنيد.

با رعايت نكات صفحه‌آرايي، نام مجله، تعداد صفحه، قيمت، ش��ماره چاپ و دو مورد  	
از عناوين مقالات داخل مجله را در محل مناسب روي جلد بنويسيد.

كي نشانه مرتبط با موضوع مجله نيز براي آن طراحي كنيد و در محل مناسب قرار  	
دهيد.
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كليات
در اين واحد کار به بررس��ي امکانات ويرايشي   FreeHand و تکنيک‌هاي اصلاح ترسيمات 
خواهيم پرداخت. عمليات اصلاحي نه تنها پس از پايان ترس��يم مورد استفاده قرار مي‌گيرد، 
بلک��ه در حي��ن انجام کار نيز به آن نياز پيدا خواهيد ک��رد چون با کپي کردن، ادغام و برش 
زدن اجزاي موجود مي‌توان به س��رعت اجزاي ديگر را ايجاد کرد، بدون اين که مس��تقيماً به 

ترسيم آن‌ها بپردازيم.
Group 1-10 گزينه

هنگامي‌که توس��ط ابزارهاي ترسيمي اش��کالي را ايجاد مي‌کنيد، اجزاي اين شکل‌ها هر 
يک منفرد بوده و مس��تقلًا قابل ويرايش يا جابه‌جايي هس��تند. ش��ما مي‌توانيد براي‌ حفظ 
ش��کل موضوع گرافيکي، جا‌به‌جايي دقيق تمامي عناصر يا انتخاب راحت‌تر موضوعات، آن‌ها 

را گروه‌بندي کنيد.
1-1-10 گروه‌بندي موضوعات

1- موضوع موردنظر را توسط ابزار Pointer انتخاب کنيد )شکل 10-1(.
2- فرمانModify→Group  را اجرا کنيد، در اين صورت اش��کال به جاي گره‌هاي متعدد 

و مجزا داراي چهار گره مي‌شوند )شکل 10-2(.

     

 شکل 1-10 انتخاب شکل       شکل 2-10 گروه‌بندي يک شکل

 نكته: با کليد ترکيبي Ctrl+G نيز مي‌توان موضوعات گرافيکي را گروه‌بندي  کرد.
وقتي يک موضوع گروه‌بندي ش��ده را انتخاب مي‌کنيد، اهرم‌هاي کنترلي در اطراف کل 
گروه ظاهر مي‌شوند و امکان تغيير اندازه، جابه‌جايي و تکثير کل اشکال گروه شده را فراهم 
مي‌کنند. در اين حالت نيز با ابزار Subselect مي‌توان قس��متي از اجزاي يک گروه را انتخاب 

کرد.
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 نكت�ه: به منظور لغو گروه‌بندي كي موضوع فرم��ان Modify→Ungroup را اجرا 
كنيد.

 مثال 1: 
1- سه شکل ساده رسم کنيد.

2- توسط ابزارPointer  و نگه داشتن کليد Shift هر سه شکل را انتخاب کنيد.
3- فرمان Modify→Group  را اجرا کنيد تا همه ترسيمات در قالب يک موضوع واحد با 

هم در يک گروه قرار ‌گيرند.
تمرين 1:

1- اش��کال 3-10 را رسم کرده، س��پس هر کدام را به‌صورت جداگانه در يک گروه قرار 
دهيد.

شکل 10-3

Ungroup 2-10 گزينه
درصورتي‌که موضوعات را در يک گروه قرار داده باشيد، به‌طور مجزا قابل انتخاب نيستند. 
ممکن است بخواهيد آن‌ها را تغيير داده و روي جزييات آن‌ها بيشتر کار کنيد، بنابراين براي 
انتخاب و جداس��ازي قسمت‌هاي مختلف موضوع مورد نظر بايد آن‌ها را از حالت گروه خارج 

.  )Modify→Ungroup(كنيد
تمرين 2:

1- آرمي نظير شکل 4-10 رسم کنيد. 

شکل 10-4 
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2- تمام شکل را انتخاب کرده و تصوير را گروه‌بندي کنيد.
3- يک کپي از تصوير را 60 درجه بچرخانيد.

4- تصوير را از حالت گروه خارج کرده و رنگ گوش��ه بالاي س��مت راست تصوير را قرمز 
کنيد. 

 Lock 3-10 گزينه
گاهي اوقات که چندين موضوع روي يکديگر يا درون هم رسم شده‌اند، هنگام انتخاب، به 
اش��تباه انتخاب مي‌شوند. براي جلوگيري از اين امر، برخي از موضوعات بايد به طور ثابت در 
صفحه قرار گيرند تا امکان تغيير مکان يا ويرايش نداشته باشند. براي رسيدن به اين هدف، 
مي‌توانيد موضوع گرافيکي را قفل کنيد. هدف از اين کار، جابه‌جا نش��دن موضوع و اطمينان 

از عدم انتقال و ويرايش آن است.
1-3-10 قفل کردن يک موضوع گرافيکي

1- موضوعي را که مي‌خواهيد قفل شود، انتخاب کنيد.
2- فرمانModify→Lock  را اجرا کنيد. آيکن  )Lock( در نوار ابزارInfo  نشان‌مي‌دهد 

که موضوع قفل شده است. 
موضوعات گرافيکي قفل شده فقط قابل انتخاب و كپي هستند.

 نكته: با کليد ترکيبي Ctrl+L مي‌توان موضوعات گرافيکي را در صفحه قفل کرد.

 مثال 2: شکل 5-10 را رسم کنيد.
1- ابتدا تصوير سيب را به همراه سايه آن رسم کنيد.

2- براي تغيير ش��کل دقيق س��ايه، تصوير اصلي را انتخاب کرده و سپس با فشردن کليد 
ترکيبي Ctrl+L، آن را قفل کنيد.

شکل 10-5
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 Unlock4-10 گزينه
اگر بخواهيد روي موضوعات گرافيکي قفل شده، ويرايشي انجام دهيد، بايد آن را از حالت 

قفل خارج کنيد.
1-4-10 خارج کردن قفل يک موضوع گرافيکي

1- موضوعي را که مي‌خواهيد از حالت قفل خارج شود، انتخاب کنيد.
2- فرمانModify→Unlock  را اجرا کنيد. 

 نكت�ه: با کليد ترکيبي Ctrl+Shift+L مي‌توان موضوعات گرافيکي را از حالت قفل 
خارج کرد.

Join 5-10 گزينه
معمولاً خطوطي که پش��ت سرهم با ابزارLine  ترسيم مي‌شوند، باز هستند. در اين مواقع 

براي اتصال دو پاره‌خط به يکديگر، از فرمانJoin  استفاده مي‌شود.
همچنين براي اين که دو يا چند مس��ير به صورت واحد يا اصطلاحاً يک مس��ير تركيبي 

درآيند، مي‌توانيد از فرمان Join  استفاده کنيد.
1-5-10 اتصال دو پاره‌خط به يکديگر 

1- دو پاره‌خطي را که مي‌خواهيد به هم متصل شوند، انتخاب کنيد.
2- فرمانModify→Join  را اجرا کنيد.

        

  شکل 6-10 انتخاب دو پاره‌خط      شکل 7-10 اتصال دو پاره‌خط

2-5-10 ايجاد يک مسير تركيبي 

1- مس��يرهاي گرافيکي را که مي‌خواهيد به صورت واحد درآيند، انتخاب کنيد )ش��کل 
.)10-8

  

   شکل 8-10 انتخاب مسير

2- فرم��انModify→Join  را اجرا کنيد، در صورتي كه مس��ير مرکب، روي هم افتادگي 
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داشته باشد مي‌توان نوع هم‌پوشاني بخش‌هاي روي هم افتاده را با گزينه Even/odd fill واقع 
در پنل Object کنترل کرد )شکل 10-9(.

شکل 9-10 ايجاد مسير تركيبي

 توج�ه: رن��گ مس��ير تركيبي از رنگ اولين مس��ير تبعيت مي‌کند. اولين مس��ير 
موضوعي است که قبل از همه ترسيم شده است.

 نكته: با کليد ترکيبي Ctrl+J مي‌توان عمل اتصال را انجام داد.

تمرين 3: چند مس��ير رسم کرده و داخل آن‌ها را با رنگ‌هاي متفاوت پر کنيد، 
سپس آن‌ها را به صورت مسير تركيبي درآوريد و به رنگ مسير مرکب دقت کنيد. 

Split 6-10 گزينه
از اين گزينه براي شکس��تن موضوعات بس��ته، جدا کردن گره‌ها از يکديگر، جدا کردن 
خطوط به هم چس��بيده‌اي که با ابزار Pen و Bezigon ترسيم شده‌اند و جدا کردن موضوعات 

Join شده، استفاده مي‌شود.

1-6-10 جدا کردن دو پاره‌خط از يکديگر

 1- با ابزار Pointer روي نقطه اتصال‌دهنده دو خط )گره( کليک ‌کنيد تا گره انتخاب شود
)ش��کل 10-10(. وقت��ي يک گره انتخاب مي‌ش��ود، به صورت چهارگ��وش توخالي يا دايره 

توخالي ديده مي‌شود.
2- فرم��انModify→Split  را اجرا کني��د. پاره‌خط‌ها در نقاط عطف )همان گره‌ها( از هم 

جدا مي‌شوند )شکل 10-11(.

            

Split شکل 10-10 انتخاب گره                شکل 11-10 جدا کردن خطوط‌ متصل با فرمان
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3- سپس در فضاي خالي كليك و بعد گره‌ها را از هم جدا كنيد.
4- حال مي‌توانيد هر پاره‌خط را به تنهايي ويرايش کنيد.

 
 نكته: با کليد ترکيبي Ctrl+Shift+J مي‌توان عمل Split  را انجام داد.

Arrange 7-10 فرمان
فرمان Arrange که در منويModify  قرار دارد، براي تعيين‌ موقعيت موضوعاتي که روي 

يکديگر قرار مي‌گيرند، استفاده مي‌شود و داراي چهار گزينه است:
Bring To Front:	 ب��راي ق��رار دادن موض��وع انتخابي روي تم��ام موضوعات به کار 

مي‌رود.
Move Forward:	 موض��وع انتخ��اب ش��ده را به ان��دازه يک موضوع ب��ه جلو انتقال 

مي‌دهد.
Move Backward:	 موضوع يا موضوعات انتخاب شده را به اندازه يک موضوع به عقب 

مي‌برد.
Send To Back:	 موض��وع ي��ا موضوعات انتخاب ش��ده را زير تم��ام موضوعات قرار 

مي‌دهد.
Align 8-10 گزينه

به وس��يله اين گزينه مي‌توانيد چندين موضوع را نس��بت به هم يا نس��بت به صفحه در 
راستاي دلخواه قرار دهيد، به طوري که نسبت به يکديگر مرتب و هم تراز به نظر برسند.

Align 1-8-10 استفاده از زير منوي

1- موضوعاتي را که مي‌خواهيد هم تراز شوند، مطابق شکل 12-10 انتخاب کنيد.

شکل 12-10 انتخاب اشکال

2- در زير منوي حاصل از اجراي فرمان Modify→Align يکي از گزينه‌هاي زير را انتخاب 
کنيد:
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 Top:	 تمام موضوعات انتخاب شده را نسبت به بالاترين شکل و از بالا با هم تراز مي‌کند 

)شکل 10-13(.
Bottom:	 تمام موضوعات انتخاب شده را نسبت به پايين‌ترين شکل و از پايين با هم 

تراز مي‌کند )شکل 10-14(.

                                  

	Bottom شکل 14-10 اعمال گزينه              Top شکل 13-10 اعمال گزينه                   

Center Horizontal:	 خ��ط افقي مرکزي را نس��بت به بالاترين و پايين‌ترين لبه‌هاي 

تصاوير مش��خص ک��رده و تمام موضوعات انتخاب ش��ده را در جهت افقي هم مرکز 
مي‌کند )شکل 10-15(.

Center Vertical:	 خط عمودي مرکزي را نسبت به منتهي‌اليه لبه‌هاي راست و چپ 

تصاوي��ر تعيين کرده و تمام موضوعات انتخاب ش��ده را در جهت عمودي هم مرکز 
مي‌کند )شکل 10-16(.

                    	                         

Center Vertical شکل 16-10 اعمال گزينه     Center Horizontal  شکل 15-10 اعمال گزينه          

Left:	 تمام موضوعات انتخاب شده را نسبت به اولين تصوير از سمت چپ و در امتداد 

لبه چپ، با هم تراز مي‌کند )شکل 10-17(.
Right:	 تمام موضوعات انتخاب ش��ده را نس��بت به اولين تصوير از سمت راست و در 

امتداد لبه راست، باهم تراز مي‌کند )شکل 10-18(.

      		                                    

Right شکل 18-10 اعمال گزينه             Left شکل 17-10 اعمال گزينه

تمرين 4: اش��کال 19-10 را رس��م کرده و آن‌ها را نس��بت به هم، تراز راس��ت 
کنيد.
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شکل 10-19

Align 2-8-10 استفاده از پنل

1- موضوعاتي را که مي‌خواهيد هم تراز شوند، انتخاب کنيد.
2- گزينه Align را از منوي Window برگزينيد تا پنلAlign  مطابق شکل 20-10 ظاهر 

شود.

Align شکل 20-10 پنل

3- ب��ا اس��تفاده از من��وي بازش��وي Horizontal مطابق ش��کل 21-10، هم‌ترازي افقي 
موضوعات را تنظيم کنيد. 

4- ب��ا اس��تفاده از منوي بازش��وي Vertical مطابق ش��کل 22-10، هم‌ت��رازي عمودي 
موضوعات را تنظيم کنيد.

5- اگ��ر مي‌خواهي��د موضوعات با صفحه هم‌تراز ش��وند، گزين��ه Align to page را فعال 
کنيد.

6- روي دکمه Apply کليک کنيد تا موضوعات به محل مورد‌نظر انتقال يابند.
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شکل 21-10 گزينه‌هاي موجود در منوي 

  Horizontal بازشوي

شکل 22-10 گزينه‌هاي موجود در منوي 

  Vertical بازشوي

 مثال 3: شكل 23-10 را رسم كرده و نسبت به هم كاملًا هم مركز كنيد.
1- براي اينك‌ه دايره‌ها هم مركز شوند ابتدا آن‌ها را انتخاب كنيد.

2- از منويWindow  گزينه Align را برگزينيد.                                        

شكل 10-23

 Horizontal 3- سپس از كادر محاوره ظاهر شده مطابق شكل 24-10 در منوي بازشوي
و Vertical گزينه Align center را انتخاب كنيد.

4- پس از انجام تنظيمات، شكل 23-10 به صورت زير تراز مي‌‌شود )شكل 10-25(.
           

             

Align شكل 25-10 هم ‌ترازي از طريق پنل                 Align شكل 24-10 كادر محاوره        
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 )Transform( 9-10 تغيير در اشياء
هنگامي كه كي ش��ئ را ايجاد ميك‌نيد ممكن اس��ت بخواهيد شكل آن را تغيير دهيد. با 

جابه‌جايي و تغيير شكل اشياء مي‌توانيد شكل‌هاي ساده را به پيچيده تبديل كنيد.
در FreeHand روش‌هاي متنوعي براي تغييرش��كل اش��ياء وجود دارد، نظير تغيير شكل 
به‌صورت دس��تي يا وارد كردن مقادير عددي براي به‌دس��ت آوردن نتايج دقيق‌تر كه در اين 

بخش به بررسي آن‌ها مي‌پردازيم.
 )Scale( 1-9-10 تغيير مقياس

براي ‌ايجاد تغيير ‌در‌ مقياس يا اندازه موضوعات س��ه روش وجود دارد که برحس��ب نياز 
مي‌توان از آن‌ها استفاده کرد.

Scale استفاده از ابزار
اين ابزار واقع در مجموعه ابزار Rotate در جعبه ابزار قرار دارد.

 نكته: استفاده از كليد Shift  هنگام تغيير مقياس باعث مي‌شود که تناسب شکل 
به هم نخورد.

Pointer استفاده از ابزار
1- توس��ط ابزار Pointer روي موضوع دابل کليک کنيد تا دس��تگيره‌هاي تغيير مقياس 

)اندازه( ظاهر شوند.
2- با درگ ماوس به داخل يا خارج، شکل را کوچک يا بزرگ کنيد.

 Transform استفاده از پنل
1- موضوع موردنظر را انتخاب کنيد.

2- از منوي Window پنل Transform را انتخاب كنيد.
3- در پنل Transform مطابق شکل 26-10 روي آيکن Scale کليک کنيد.

4- درصد تغيير مقياس )اندازه( موضوع را در کادرScale %  وارد کنيد.
5- فعال کردن گزينهUniform  باعث مي‌شود که تغيير اندازه طول شکل نسبت به عرض 

آن به صورت متناسب انجام شود.
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Transform از زبانه Scale شکل 26-10 گزينه

 نكت�ه: اگ��ر گزين��ه Uniform  را غيرفعال کنيد، کادره��اي  vوh براي وارد کردن 
درصدهاي مربوط به تغيير مقياس )اندازه( موضوع باز مي‌شوند. در اين حالت براي دستيابي 
 v افقي( و ( h مقاب��ل Scale ب��ه ي��ک مقياس غيريکنواخ��ت، مقادير موردنظر را در قس��مت

)عمودي( وارد کنيد.
 Center 1- براي تغييرمکان نقطه تغيير مقياس از مرکز، مختصات موردنظر را در قسمت

مقابل x و y وارد کنيد.
2- اگر مي‌خواهيد هنگام تغيير مقياس ش��کل، اندازه تمام اجزاي چس��بيده به شکل نيز 

تغيير کند، گزينهContents  را فعال کنيد.
 )Stroke( 3- اگر مي‌خواهيد هنگام تغيير مقياس شکل، مقياس خط رسم شده دور شکل

نيز با شکل تغيير کند، گزينه Strokes را فعال کنيد.
 )Tiled( فعال باش��د مقياس تمام زمينه‌ها مانند كاشيك‌اري Fill 4- در صورتي كه گزينه

تغيير ميي‌ابد.
5- گزينه Strokes را فعال كنيد تا اندازه خطوط دور به همراه مسير تغيير كند.
6- کادر Copies به منظور تکثير و تغيير اندازه شکل تکثير شده به کار مي‌رود.

7- روي دکمه Scale کليک کنيد )يا کليد Enter را بفشاريد(.

 توج�ه: اس��تفـاده از کـ��ادر Copies در ابـزار Transform منجر به ايجاد اش��کال 

گرافيکي جالبي در کنار هم مي‌شود.

تمرين 5: مقياس شكل را طوري تغيير دهيد كه شكل دو برابر شود و متناسب 
اندازه طول و عرض شكل تغيير نكند.
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شکل 10-27
)Move( 2-9-10 جابه‌جايي اشكال

كيي از راه‌هاي جابه‌جايي اش��كال استفاده از پنل Transform است. در اين پنل دكمه‌اي 
به نام Move قرار دارد که موضوعات را با استفاده از مقياس جابه‌جا مي‌کند. 

با استفاده از اين پنل ضمن جابه‌جا کردن موضوع، امکان تکثير آن نيز وجود دارد )شكل 
                   .)10-28

                  

Transform از پنلMove  شکل 28-10 انتخاب دكمه 

 نكته: اگر هنگام درگ شئ با استفاده از ابزار Pointer كليد Alt را نگه داريد كي 
كپي از شئ ايجاد مي‌شود.

 توجه: تفاوت اس��تفاده از پنل Transform نسبت به پنل Object هنگام جابه‌جايي 

موضوعات در اين است که اعداد در پنل Transform نسبي هستند يعني موضوع را به اندازه 
عددي که در قسمت x و y وارد کرده‌ايد )نسبت به موقعيت کنوني موضوع( جابه‌جا مي‌کند، 
اما در پنل Object مقادير ورودي مطلق هستند، يعني مقادير ورودي هميشه نسبت به نقطه 

صفر خط‌کش محاسبه مي‌شوند.
تمري�ن 6: آرم 29-10 را طراح��ي کرده و آن را يک بار با پنل Object  و يک بار 

با پنل Transform به اندازه دلخواه در صفحه جابه‌جا کنيد.
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شکل 10-29
)Rotate( 3-9-10 چرخش

بيش��تر مواقع هنگام رس��م اشکال، لازم اس��ت براي رسيدن به ش��کل موردنظر تمام يا 
قس��متي از شکل را بچرخانيد. براي چرخش موضوعات از چند روش استفاده مي‌شود که به 

شرح آن‌ها مي‌پردازيم:
استفاده از دستگيره‌هاي تغيير شکل

1- ب��ا ابــ��زار Pointer روي ‌مــوض��وع ‌مــورد‌نظر دابل‌کليک ‌کنيــد تا دس��تگيره‌هاي 
تغييرشکل )Transform handles( ظاهر شوند.

2- اش��اره‌گر ماوس را به دس��تگيره‌ها نزدي��ک کنيد، در اين صورت اش��اره‌گر ماوس به 
فلش‌هاي چرخش��ي تبديل مي‌شود. حال با چرخش اشاره‌گر ماوس، موضوع انتخاب شده به 

اندازه دلخواه دوران مي‌کند.

                 

شکل 30-10 دستگيره‌هاي تغيير شکل       شکل 31-10 چرخش اشکال به کمک دستگيره‌هاي تغيير شکل

 نكته: با استفاده از کليد Shift  چرخش با زاويه 45 درجه انجام مي‌شود.

 Rotate نحوه استفاده از ابزار
1- با ابزار Pointer روي ‌موضوع ‌موردنظر کليک‌ کنيد تا شکل انتخاب شود.

2- ابزار Rotate را از جعبه ابزار انتخاب کنيد.
3- در ي��ک ‌نقطه کليک‌ک��رده و كليد‌ ماوس را نگه‌ داريد تا خ��ط ‌راهنماي ‌تعيين‌کننده 
راستاي چرخش ظاهر شود. اکنون با حرکت دادن ماوس مي‌توانيد شکل را درجهات مختلف 



وزارت فرهنگ و ارشاد اسلامی
Free Hand نام استاندارد : کاربر

شماره : 15/7- ف - هـ
266

بچرخانيد.

     

Rotate شکل 33-10 مراحل انجام کار با ابزار      	Pointer شکل 32-10 انتخاب با ابزار

 نكت�ه: اگر مي‌خواهيد به طور همزمان چند موضوع را با هم چرخش دهيد، بهتر 
است ابتدا آن‌ها را با کليد ترکيبي Ctrl+G  در يک گروه قرار دهيد.

 توجه: هنگام‌ اس��تفاده از ‌ابزار Rotate نقطه کليک به‌منزله محور‌ چرخش اس��ت، 

بنابراين اگر مي‌خواهيد ش��کل را به دور خودش بچرخانيد، بهتر است نقطه کليک در حوالي 
مرکز شکل باشد.

 نكته: نگه داش��تن کليد Shift هنگام چرخش باعث مي‌شود که شکل با زاويه 45 
درجه بچرخد.

مثال 4: شکل 34-10 را رسم کنيد.
1- به منظور رسم اين شکل مي‌توانيد از ابزار Bezigon براي رسم خطوط صاف و از ابزار 

Pen براي رسم خطوط منحني استفاده کنيد.

2- شکل را با استفاده از ابزار Rotate به اندازه دلخواه بچرخانيد.                          

شکل 10-34

ب��راي اي��ن کار ابتدا با ابزار Pointer روي موضوع موردنظر کليک کنيد تا ش��کل انتخاب 
شود، سپس ابزار Rotate را از جعبه ابزار برگزينيد و در يک نقطه کليک کرده، كليد ماوس را 
نگه داريد تا خط راهنماي تعيين کننده راس��تاي چرخش ظاهر شود. اکنون با حرکت دادن 
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ماوس شکل را در جهات مختلف بچرخانيد.

 نكته: در هنگام چرخاندن شکل، هر قدر که اشاره‌گر ماوس از مرکز دوران دورتر 
باشد، تغيير زاويه با گام‌هاي آهسته‌تري صورت مي‌پذيرد.

 Transformاستفاده از پنل
اين روش دقيق‌تر از روش‌هاي قبل است، زيرا در اين روش از مقياس استفاده مي‌شود.

1- موضوع مورد نظر را انتخاب کنيد.
2- گزينه  Modify→Transform→Rotateرا برگزينيد.    

3- پنل Transform در حالي كه دكمه Rotate انتخاب شده باز مي‌شود.
4- زاويه‌اي که مي‌خواهيد موضوع را برحس��ب آن بچرخانيد به صورت عدد در قس��مت
‌Rotation angle تاي��پ کني��د و با انتخاب گزينه‌ه��ايContents  و Fills مش��خص کنيد که 

محتويات موضوع، همراه با آن چرخانده شود.
5- براي تغيير دادن مرکز چرخش، مختصات مورد نظر خود را در قس��مت Center وارد 

کنيد.
6- روي دکمه Rotate کليک کنيد.

Transform شکل 35-10 پنل

 نكته: اگر در کادرCopies  عدد صفر را وارد کنيد، خود شکل با زاويه موردنظر چرخش  مي‌کند 
اما اگر عددي غير از صفر وارد کنيد، ش��کل اصلي بدون چرخش باقي مي‌ماند و کپي‌هاي ايجاد ش��ده با زاويه 

دلخواه چرخش مي‌کنند.
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 ، Window→Transform مي‌توانيد از  Transform نكت�ه: براي ظاهر کردن پن��ل 
کليد ميانبرCtrl+Mي  ا دابل کليک روي ابزار Rotate  در جعبه ابزار استفاده کنيد.

 توجه : برای دوران در خلاف جهت عقربه های س��اعت می توانید یک عدد منفی 
در کادر Rotating angle وارد کنید.

مثال 5: شکل 36-10 را رسم کنيد.
1- براي ايجاد ش��کل 36-10 ابتدا با ابزار Ellipse يک بيضي عمودي رس��م کنيد، سپس 
از قسمت Modify→Transform  گزينه Rotate را انتخاب کنيد.                                                            

شکل 10-36

2- در كادر متن��ي Rotation angle عدد 20 را وارد کرده و در كادر متني Copies عدد 8 
را درج کنيد، سپس روي دکمهRotate  کليک کنيد.
تمرين 7: اشکال 37-10 را رسم کنيد.

شکل 10-37



Free Hand پیمانه مهارتی : کاربر
269واحد کار دهم: توانایی انجام کار روی اشیاء 

 )Reflect( 4-9-10 قرينه‌سازي

براي ايجاد قرينه از يک موضوع يا انعکاس آن روي يک س��طح، از ابزار Reflect اس��تفاده 
کنيد. اين ابزار در مجموعه ابزارRotate  در جعبه ابزار قرار دارد.                                

Reflect استفاده از ابزار
1- موضوعي را که مي‌خواهيد قرينه کنيد، برگزينيد.

2- ابزار Reflect را از جعبه ابزار انتخاب کنيد.
3- اش��اره‌گر ماوس را روي صفحه قرار داده و در نقطه‌اي که مي‌خواهيد شکل در اطراف 
آن قرينه ش��ود، کليک کنيد )نقطه تغيير ش��کل(. در اين حالت كلي��د ماوس را رها نکنيد، 
به اين ترتيب يک خط از محل اش��اره‌گر به س��مت خارج گس��ترش ميي‌ابد )اين خط محور 

بازتابش ناميده مي‌شود(.
 4- وقتي موضوع قرينه شده در موقعيت دلخواه ‌شما قرارگرفت، كليد ماوس را رها کنيد 

)شکل 10-39(.

        

                      شکل 38-10 محور بازتابش                                 شکل 39-10 قرينه موضوع انتخاب شده

 نكت�ه: اگر هنگام اس��تفاده از ابزار Reflect کلي��د Shift را پايين نگه داريد، باعث 
مي‌شود قرينه‌سازي در زواياي 45، 90 و 180 درجه صورت گيرد.

 نكت�ه: اگر هنگام اس��تفاده از اب��زار Reflect کليد Alt را پايي��ن نگه داريد، باعث 
مي‌شود از موضوع انتخاب شده کپي گرفته شود و سپس قرينه‌سازي صورت گيرد.

مثال 6: ش��کل 40-10 را رس��م کرده، س��پـس قرينه آن را مطابق شکل ايجاد 
کنيد. 

1- ابتدا تصوير يک ماهي را مطابق شکل 41-10 رسم کنيد.
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2- ابزار Reflect را از جعبه ابزار انتخاب کرده و اشاره‌گر ماوس را روي صفحه قرار دهيد 
و در نقطه‌اي که مي‌خواهيد شکل در اطراف آن قرينه شود، کليک کنيد. در اين حالت كليد 
م��اوس را رها نکنيد و با حرکت دادن ماوس و حرک��ت محور بازتابش هنگامي که قرينه در 
جاي مشخص شده در شکل 40-10 قرار گرفت، کليد Alt را نگه داشته )براي ايجاد کپي از 

شکل( سپس كليد ماوس را رها کنيد.

           	  

		 شکل 10-41                        شکل 40-10 ترسيم شکل به همراه قرينه

Transform استفاده از پنل
1- موضوعي را که مي‌خواهيد قرينه کنيد، برگزينيد.

2- روي دكمه Reflect از پنل Transform کليک کنيد. شکل 42-10 ظاهر مي‌شود.

Transform از پنل Reflect شکل 42-10 دكمه

 Reflect axis 3- زاويه چرخش موضوع را برحسب درجه براي قرينه شدن، در مقابل‌ کادر
وارد کنيد.

4- براي جابه‌جايي نقطه تغيير ش��کل از مرکز موضوع، مختصات موردنظر را در قس��مت 
Center مقابل کادرهاي x و y وارد کنيد.

  Copies 5- براي اين که خود شکل را همراه با قرينه آن داشته باشيد، کافي است در کادر
شکل 42-10 عدد 1 را وارد کنيد.
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تمرين 8: شکل 43-10 را رسم کنيد.

      

 شکل 10-43 

 Skew 5-9-10 ابزار

از ابزار Skew واقع در گروه ابزارهاي Rotate در جعبه ابزار، براي مورب کردن موضوعات و 
 Transform زياد دقيق نيست ولي پنل Skew مورب کردن متون استفاده مي‌شود.کارکرد ابزار

به علت اين که تغييرات را با مقياس انجام مي‌دهد، دقيق‌تر عمل مي‌کند. 
براي مورب کردن )کج کردن( موضوعات از دو روش استفاده مي‌شود:

 Skew استفاده از ابزار
1- موضوعي را که مي‌خواهيد مورب کنيد، برگزينيد.

2- در جعبه ابزار، ابزارSkew  را انتخاب کنيد س��پس اش��اره‌گر ماوس را در نقطه‌اي که 
مي‌خواهي��د موض��وع را از آن نقطه کج کني��د، قرار دهيد )به اين نقطه، نقطه تغيير ش��کل 

مي‌گويند( و كليد ماوس را رها نکنيد )شكل 10-44(.

         

شکل 44-10 انتخاب شکل

3- اش��اره‌گر را دورتر از نقطه تغيير ش��کل بکشيد. با انجام اين عمل، شکل، مطابق شكل 

45-10 تغيير پيدا مي‌کند.

Skew شکل 45-10 مورب کردن شکل با ابزار
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Transform استفاده از پنل
1- موض��وع موردنظر را برگزينيد، س��پس در پن��ل Transform روي دكمه Skew کليک 

کنيد.
2- در کادر h از قسمت Skew angles  زاويه افقي و در کادر v زاويه عمودي را براي مقدار 

کج شدن  وارد کنيد.
  Center3- براي جابه‌جايي نقطه تغيير شکل از مرکز شکل، مختصات جديد را در قسمت

وارد کنيد.
4- روي دکمه Skew کليک کنيد.

Transform شکل 46-10 پنل

Combine 10-10 فرمان‌هاي
در FreeHand MXa قابليت تركيب ساده و پيچيده اشكال و مسيرها وجود دارد كه در زير 
 Modify→Combine فرمان ،Combine به آن‌‌ها اشاره شده است. براي دسترسي به گزينه‌هاي

را انتخاب كنيد.
Blend 1-10-10 فرمان

از اين فرمان براي ترکيب کردن يا به هم رس��اندن دو يا چند موضوع انتخابي اس��تفاده 
مي‌ش��ود. در صورتيك‌ه دو موضوع مختلف را انتخاب كرده، س��پس اين فرمان را اجرا کنيد، 
بين موضوعات انتخاب شده اشکالي ايجاد ‌مي‌شود؛ به‌طوري که به نظر مي‌رسد موضوعي به 

تدريج و طي چند مرحله به موضوع ديگر تبديل شده است.
 Blend استفاده از فرمان

 1- دو ي��ا چن��د موضوع گرافيک��ي را که مي‌خواهي��د باهم ترکيب‌ش��وند، انتخاب کنيد 
)شکل 10-47(.

2- فرمان Modify→Combine→Blend را اجرا کنيد )شکل 10-48(.
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همان‌طور که در شکل 49-10 مشاهده مي‌کنيد، با استفاده از کادر متني Steps  مي‌توان 
تعداد مراحل تبديل موضوعات انتخابي در فرمان Blend را تنظيم کرد.

کادر Range، محدوده توليد اشکال مياني بين دو موضوع انتخاب شده را براساس درصدي 
از فاصله ميان دو موضوع اصلي تعيين مي‌کند.

                                        

Blend شکل 48-10 نتيجه حاصل از فرمان      Blend شکل 47-10 دو موضوع گرافيکي انتخاب شده براي

 

Blend هنگام استفاده از فرمان Object شکل 49-10 پنل

 نكته: با کليد ترکيبي Ctrl+Shift+B مي‌توان عمل Blend   را انجام داد.

مثال 7: شکل 50-10 را با استفاده از Blend رسم کنيد.
1- يک دايره با ابزار Ellipse رسم کنيد.

2- يک بيضي در وسط دايره ترسيم کنيد.
3- بيضي و دايره را باهم انتخاب کنيد.

4- فرمان Modify→Combine→Blend را اجرا کنيد.     
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شکل 10-50

5- در پنل Object در کادر Steps عدد 15 را وارد کنيد.

 توجه: براي جدا کردن موضوعات ترکيبي تکرار ش��ده )Blend( مي‌توانيد دو بار از 

فرمان Modify→Ungroup يا کليد تركيبي Ctrl+Shift+G  استفاده کنيد.

تمرين 9: دو شکل بعد را در صفحه ترسيم و رنگ‌آميزي کرده )شکل 10-51(، 
سپس اعمال ‌زير را انجام دهيد:

1- دستور Blend را روي آن‌ها اجرا کنيد.
2- رنگ هر يک از شکل‌ها را تغيير داده و تغييرات را مشاهده کنيد.

3- تعداد مراحل تبديل دو شکل به يکديگر را 10 قرار دهيد. 

  

شکل 10-51 

Join Blend To Path  2-10-10 فرمان

از اين فرمان براي فرم دادن موضوعات Blend شده استفاده مي‌شود. وقتي دو موضوع را 
توسط فرمان Blend با هم ترکيب مي‌کنيد شکل‌هاي مياني، بين دو موضوع و در يک راستا 
تش��کيل مي‌ش��وند. براي اين که بتوانيد اشکال مياني را با يک مسير دلخواه هم تراز کنيد از 

فرمان Join Blend To Path استفاده کنيد.



Free Hand پیمانه مهارتی : کاربر
275واحد کار دهم: توانایی انجام کار روی اشیاء 

Join Blend To Path استفاده از فرمان
1- دو موضوع گرافيکي مانند ش��کل 52-10 ترس��يم کرده و آن‌ها را با دستور Blend با 

هم ترکيب کنيد.
2- يک مسير دلخواه رسم کنيد )شکل 10-53(.

	                               

شکل 52-10 دو شکلBlend  شده                           شکل 53-10 رسم مسير

3- هر دو موضوع را انتخاب کنيد.
4- فرمان Modify→Combine→Join Blend To Path را اجرا کنيد )شکل 10-54(.

Join Blend To Path شکل 54-10 اعمال

تمرين 10: شكل 55-10 را ترسيم كنيد.

 Join Blend To Path شکل 55-10 نتيجه فرمان
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 توجه: براي جدا کردن موضوعات Blend ش��ده از يک مس��ير، مي‌توانيد از گزينه 

Split در منوي Modify استفاده کنيد.

Union 3-10-10 فرمان

اين فرمان براي ترکيب يا يکپارچه کردن چند مس��ير يا موضوع گرافيکي و تبديل آن‌ها 
به يک موضوع واحد به‌کار مي‌رود. اين مس��يرها طوري با هم ترکيب مي‌ش��وند که خطوط 
مشترک بين آن‌ها حذف مي‌شوند. با کمک اين توانايي، مي‌توانيد مسيرهاي پيچيده‌اي را با 

استفاده از اشکال ساده توليد کنيد.
Union استفاده از فرمان

1- دو ـي��ا چنـد موض��وع را که روي هـم قرار گرفته‌اند، مطابق ش��کل 56-10 انتخاب 
کنيد.

2- فرمان Modify→Combine→Union را اجرا کنيد.   

 توجه: رنگ درون مس��ير ترکيب ش��ده، از رنگ اوليـن مسيـري که تـرسيم شده 

تبعيت خواهد کرد )شکلي که نسبت به بقيه اشکال عقب‌تر قرار گرفته است(.

                           

Union شکل 57-10 نتيجه حاصل از فرمان      Union شکل 56-10 انتخاب اشکال براي فرمان

 نكته: چنانچه مس��يرها با يکديگر هم‌پوشاني نداشته باشند، نتيجه فرمان Join  و 
Union يکسان بوده و منجر به توليد يک مسير يکپارچه خواهد شد.
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تمرين 11: اش��کال 58-10 را رس��م ک��رده و فرم��ان Union را روي آن‌ها اجرا 
کنيد.

شکل 10-58

Divide 4-10-10 فرمان

اين فرمان قس��مت‌هاي مش��ترک موضوع��ات را برش مي‌دهد و از آن يک ش��کل مجزا 
مي‌سازد. در واقع نواحي مشترک از هم جدا مي‌شوند، بدون آن که موضوعات اصلي حذف شوند؛ 

همچنين موضوعات به قطعات کوچک‌تر تقسيم مي‌شوند.
Divide استفاده از فرمان

1- دو يا چند موضوع را که روي هم قرار گرفته‌اند مطابق شکل 59-10 انتخاب کنيد.
2- فرمان Modify→Combine→Divide را اجرا کنيد )شکل 10-60(‌.   

                                                     

Divide شکل 59-10 انتخاب سه شکل                   شکل 60-10 اعمال فرمان

Crop 5-10-10 فرمان
اين فرمان قس��مت‌هاي مشترک موضوعات گرافيکي را برش مي‌دهد. وقتي دو يا چند مسير 
را که با يکديگـر هم‌پوش��انـي و تـداخل دارند، انتخاب كرده و فرمان Crop را روي آن‌هـا اجرا 
کنيد، قسمت‌هايي از مسيرهاي زيرين که به داخل مسير بالايي نفوذ کرده، باقي مي‌مانند و ساير 
قسمت‌ها که در خارج از مرزهاي شکل بالايي واقع شده‌اند، حذف مي‌شوند. در واقع موضوعــي 
که روي ش��کل يا اش��کال ديگر قرار گرفته به عنوان يک چاقو عمل مي‌کند تا قس��مت‌هايي از 
موضوعات زير که خارج از تصوير بالايي قرار گرفته‌اند، حذف ش��وند و فقط بخش‌هاي مش��ترک 
 Union عمل مي‌کند، با اين تفاوت که Union عکس فرمان Crop اش��کال باقي بمانند. فرمـان



وزارت فرهنگ و ارشاد اسلامی
Free Hand نام استاندارد : کاربر

شماره : 15/7- ف - هـ
278

ويژگي رنگي مس��يرها را تغيير مي‌دهد اما Crop عمل برش را با حفظ رنگ‌هاي اوليه مس��ير‌ها 
انجام مي‌دهد.

 Crop استفاده از فرمان
1- موضوعات متنوعي را به همراه موضوعي که در بالاي آن‌ها قرار دارد، انتخاب کنيد.

.)1 2- فرمان Modify→Combine→Crop   را اجرا کنيد )شکل 62-

 	   
Crop شکل 62-10 نتيجه حاصل از اجراي فرمان 	شکل 61-10 انتخاب موضوعات گرافيکي  

3- فقط قس��مت‌هايي از موضوعات انتخاب ش��ده باقي مي‌مانند كه اش��كال زيرين آن با 
شكل بالا تداخل داشته باشد.

Intersect 6-10-10 فرمان

اج��راي اين فرمان روي مس��يرهايي که ب��ا هم تداخل دارند، موجب مي‌ش��ود که فصل 
مشترک موضوعات حفظ شده و ساير قسمت‌ها حذف شود.

Intersect استفاده از فرمان
1- موضوعاتي را که با هم تداخل دارند، رسم و انتخاب کنيد )شکل 10-63(.

2- فرمان Modify→Combine→Intersect  را اجرا کنيد )شکل 10-64(.

                                            
Intersect شکل 63-10 رسم و انتخاب دو شکل متداخل            شکل 64-10 نتيجه حاصل از فرمان

 توجه: تفاوت بين دس��تور Crop و Intersect  در اين اس��ت که فرمان Crop فصل 

 Intersect مش��ترک شکل‌ها را با ش��کل بالايي نگه مي‌دارد و بقيه را حذف مي‌کند اما فرمان
باعث مي‌ش��ود که فصل مش��ترک همه موضوع��ات باقي بماند. تفاوت بين دس��تور Crop و 
Intersect  در ش��کل 65-10 به‌صورت تصويري نشان داده شده است. توجه داشته باشيد كه 
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در اين شكل ابتدا مربع، سپس ستاره و بالاترين شكل بيضي رسم شده است.

Intersect و Crop شکل 65-10 تفاوت

 مثال 8:
1- كي س��تاره، دايره و ش��ش ضلعي متداخل )ش��كل 65-10( رس��م كرده، آن‌ها را به 

دلخواه رنگ كنيد.                                                                 

شكل 10-66

2- ش��كل قبل را انتخاب ك��رده، دس��تور Modify→Combine→Intersect را اجرا كنيد 
)شكل 67-10(. شكل 66-10 را انتخاب كرده و دستور Modify→Combine→Crop را اجرا 

كنيد )شكل 10-68(.

         Intersect شكل 67-10 نتيجه حاصل از تأثير فرمان

3- به تفاوت دو فرمان Crop و Intersect دقت كنيد.
                                                                 

Crop شكل 68-10 نتيجه حاصل از تأثير فرمان   
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Punch 7-10-10 فرمان

با استفاده از اين فرمان مي‌توانيد توسط موضوعي که در رو قرار گرفته بخشي از موضوع 
ديگر را که در زير قرار دارد، حذف کنيد. دو شکل را روي هم قرار دهيد به طوري که شکل 
بزرگ‌تر زير قرار بگيرد، سپس فرمان Punch را اجرا کنيد، مي‌بينيد که قسمت‌هاي مشترک 
دو ش��کل حذف مي‌شوند. بدين وسيله حفره‌اي به اندازه و فرم شکل بالايي در شکل‌ پاييني 
ايجاد ش��ده و شکل رويي حذف مي‌شود. اگر ش��کلي که در رو قرار دارد با شکلي که در زير 

واقع است، هم‌پوشاني داشته باشد، شکل زير برش مي‌خورد.
 Punch استفاده از فرمان

 1- موضوعات��ي‌را ک��ه همه يا قس��متي از آن‌ها روي‌هم ق��رار گرفته‌ان��د، انتخاب کنيد 
)شکل 10-69(.

2- فرمان Modify→Combine→Punch را اجراکنيد )شکل 10-70(.

   		                              

Punch شکل 70-10 پس از اعمال فرمان      Punch شکل 69-10 موضوعات گرافيکي براي اجراي فرمان     

3- موضوع بالايي روي موضوع پاييني، سوراخ ايجاد مي‌کند.

 توج�ه: در هنگام كار با متن )Text( ابتدا بايد متن به موضوع گرافيكي )مس��ير( تبديل 

 ش��ده‏، س��پس فرم��ان Join روي آن اعمال ش��ود، پس از آن مي‌ت��وان فرمان ‍��‍Punch را اجرا كرد 
)شكل 10-71(.

شکل 71-10 نمايش اعمال فرمان Punch روي متن

در شکل 72-10 مي‌توانيد نتيجه حاصل از سه فرمان Punch ، Crop و Union را مشاهده 
کنيد.
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Punchو Union ،Crop شکل 72-10 مقايسه فرمان‌هاي

 Punch تمرين 12: شکل 73-10 را با استفاده از سه شکل الف، ب، ج و با فرمان
رسم کنيد.

                                  )الف(                    )ب(                   )ج( 

شکل 10-73

Alter Path 11-10 ويرايش مسير با فرمان‌هاي
هنگامي كه با استفاده از روش‌هاي مختلف، مسيرهايي را ايجاد كرديد، مي‌توانيد آن‌ها را 
به روش‌هاي گوناگون اصلاح كنيد يا تغيير ش��كل دهيد. براي دسترسي به فرمان‌هاي مزبور 

مسير زير را اجرا كنيد:
Modify →Alter Path

Correct Direction 1-11-10 فرمان

در اي��ن واحد كار اص��ول ادغامك‌ردن موضوعات گرافيك��ي را آموختيد. هنگامي كه چند 
 Even/odd با هم ادغام مي‌ش��وند، مي‌توانيد با اس��تفاده از گزينه Join موضوع توس��ط فرمان
fill موجود در پنل Object )ش��كل 74-10( رنگ قسمت‌هاي روي هم افتاده )هم‌پوشاني( را  
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تعيين كنيد.
اگر اين گزينه فعال باش��د قس��مت‌هاي روي هم افتاده ش��فاف ديده مي‌شوند و اگر اين 
گزينه فعال نباش��د، قس��مت‌هاي روي هم افتاده، هم رنگ بقيه قسمت‌هاي شكل مي‌شوند 

)شكل 10-75(.

                

        شكل 74-10 گزينه Even/odd fill                شكل 75-10 نتيجه حاصل از فعال و غيرفعال بودن

Even/odd fill گزينه                                               Object موجود در پنل               

حال اگر گزينه Even/odd fill فعال باشد اما قسمت‌هاي روي هم افتاده شكل‌ها به صورت 
شفاف ديده نشوند با اجراي فرمانCorrect Direction  قسمت‌هاي روي هم افتاده موضوعات 
گرافيكي ادغام ش��ده و ش��فاف مي‌ش��وند. اين فرمان را مي‌توانيد به كي��ي از روش‌هاي بعد 

انتخاب كنيد:
	 Modify→Alter Path→Correct Direction

	 Xtras→Cleanup→ Correct Direction

	Xtra Operations انتخاب آكين  از نوار ابزار
 Reverse Direction2-11-10 فرمان

هنگامي که مس��يري را ترس��يم مي‌کنيد، جهت مس��يرهاي ايجاد شده به همان ترتيبي 
است كه نقاط لنگر را ايجاد ميك‌نيد. اولين نقطه‌اي كه ايجاد مي‌شود شروع مسير و آخرين 
نقطه، انتهاي مس��ير خواهد بود. گاهي اوقات لازم مي‌ش��ود كه در رسم موضوعات گرافيكي، 
جهت مسيرها را تغيير دهيد؛ براي اين كار از فرمان  Reverse Direction استفاده كنيد. براي 

اجراي اين فرمان كيي از روش‌هاي زير را برگزينيد.
	Modify→Alter Path→Reverse Direction

	Xtras→Cleanup→Reverse Direction

	Xtra Operations انتخاب آكين  از نوار ابزار
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روش تغيير جهت مسير
1- مسيري را كه مي‌خواهيد جهت آن تغيير کند، انتخاب كنيد )شكل 10-76(.

2- فرم��ان Modify→Alter Path→Reverse Direction را اج��را كني��د؛ نتيجه حاصل در 
شكل 77-10 نمايش داده مي‌شود.

                    

Reverse Direction  شكل 77-10 نتيجه حاصل از فرمان       شكل 76-10 انتخاب مسير          	

 تمرين 13: شكل 78-10 را ترسيم كرده و  به 79-10 تبديل كنيد.

                    
                                                 

                   

 Reverse Direction  شكل 78-10                     شكل 79-10 نتيجه حاصل از فرمان                

 توج�ه: ب��راي معكوس كردن ن��وك فلش ابت��دا و انتهاي خط��وط متصل كننده 

)Connector( فرمانReverse Direction بهك‌ار مي‌رود.

Remove Overlap 3-11-10 فرمان

اي��ن فرمـ��ان نواحي را كه در كي مس��ير روي هـم قـرار مي‌گيـرن��د، حذف ميك‌ند. به 
عبارت ديگر فرمانRemove Overlap  مس��ير را طوري تغيير مي‌دهد تا نواحي كه با كيديگر 

هم‌پوشاني دارند، حذف شوند. براي اجراي اين فرمان كيي از روش‌هاي بعد را برگزينيد.
	Modify→Alter Path→Remove Overlap

	Xtras→Cleanup→Remove Overlap

Xtra Operations انتخاب آكين  از نوار ابزار      
Remove Overlap استفاده از فرمان

1- موضوع موردنظر را انتخاب كنيد )شكل 10-80(.
2- فرمان Modify→Alter Path→Remove Overlap را اجرا كنيد. نواحي‌ که روي‌هم قرار 

گرفته‌اند مطابق شكل 81-10 حذف مي‌شوند.
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Remove Overlap شكل 81-10 نتيجه حاصل از فرمان                 شكل 10-80 	

 نكت�ه: بايد توجه داش��ت که موضوع پس از اجراي فرم��ان Remove Overlap به 
صورت يکپارچه خواهد شد.

در اين حالت بخش‌هاي شفاف محصور در داخل مسير به اشکال قابل انتخاب و ويرايش 
تبديل مي‌ش��وند. چنين به نظر مي‌آيد که اين موضوعات که کاملًا هم رنگ مس��ير هستند، 
روي مس��ير قرار گرفته و فرمان Punch به صورت خودکار روي موضوع و مس��ير اجرا ش��ده 

است
مثال 9:

  
1- ابتدا شکل 82-10 را ترسيم و انتخاب کنيد.

2- فرمان Remove Overlap را اجرا کنيد )شکل 10-83(.
3- مي‌توانيد با ابزار Subselect قس��مت داخلي ش��کل را نيز انتخاب و جدا کنيد )ش��کل 

.)10-84

                                          

شکل 82-10                       شکل 83-10                         شکل 10-84

Simplify 4-11-10 فرمان

در بعضي مس��يرها معمولاً تعداد زيادي گره اضافي قرار دارد كه باعث مي‌ش��ود س��رعت 
پردازش و چاپ مسير طولاني شود و در هنگام اصلاح و ويرايش مسير نيز با مشكلاتي مواجه 
شويد. در اين صورت مي‌توانيد با استفاده از فرمانSimplify  تعداد گره‌هاي اضافي موجود در 
مسير را كم كنيد تا مسير ساده‌تر و هموارتر شده و ويرايش آن نيز آسان‌تر شود. براي اجراي 

اين فرمان كيي از روش‌هاي بعدي را برگزينيد.
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	Modify→Alter Path→Simplify

	Xtras→Cleanup→Simplify

	Xtra Operations انتخاب آكين  از نوار ابزار
Simplify روش استفاده از فرمان

1- موضوع موردنظر را كه مي‌خواهيد تعداد گره‌هاي آن كم ش��ود، انتخاب كنيد )ش��كل 
.)10-85

شكل 85-10 انتخاب مسير

2- فرم��ان Modify→Alter Path→Simplify را اجرا كني��د، كادرمحاوره Simplify مطابق 
شكل 86-10 ظاهر مي‌شود.

Simplify شكل 86-10 كادرمحاوره

3- در اين كادر محاوره با اس��تفاده از دکمه لغزنده موجود مي‌توانيد ش��دت تأثير فرمان 
را روي مس��ير انتخاب ش��ده تغيير دهيد. هرچه اين مقدار بيشتر باشد، نقاط بيشتري حذف 

مي‌شوند.
4- براي ديدن نتيجه كار قبل از بستن كادرمحاوره روي دكمه Apply کليک كنيد و اگر 

نتيجه رضايت‌بخش بود روي دكمه OK كليك كنيد )شكل 10-87(.

Simplify شكل 87-10 نتيجه حاصل از فرمان

 Xtras→Distort→AddPoints نكته: براي اضافهك‌ردن نقاط بيشتر به مسير، از فرمان 
استفاده كنيد.
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 مثال 10:
1- كي چند ضلعي مطابق شكل 88-10 رسم كنيد.

شكل 88-10 رسم چند ضلعي

 2- ب��ا اس��تفاده از فرم��ان Add Points به ش��كل رس��م ش��ده، نقاط��ي را اضافه كنيد 
)شكل 10-89(.

 Add Points  شكل 89-10 نتيجه حاصل از تأثير فرمان

را كاه��ش دهي��د  نق��اط روي ش��كل  Simplify تع��داد  فرم��ان  از  اس��تفاده  ب��ا   -3 
)شكل 10-90(.

Simplify شكل 90-10 نتيجه حاصل از تأثير فرمان

Expand Stroke 5-11-10 فرمان

اجراي اين فرمان روي مسيرهاي بسته، باعث افزايش ضخامت خطوط دور مسير مي‌شود 
به طوري كه ش��كل، به كي ش��كل تركيبي )Composite Path( تبديل خواهد شد. همچنين 
اجراي اين فرمان، مسيرهاي باز را به بسته تبديل مي‌كند و باعث گسترش ضخامت خط دور 
مي‌ش��ود، ضخامت خط از 1 تا 50 قابل تنظيم اس��ت و اين ضخامت در واقع به وس��يله كي 

مسير بسته ايجاد مي‌شود. 
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مي‌توان پس از اجراي فرمان Expand Stroke، روي مس��يري که به موضوع تبديل ش��ده،  
ويرايش‌هاي مربوط به موضوعات )از قبيل تمامي گزينه‌هاي منوي بازشو در Fill( را اجرا کرد. 

براي اجراي اين فرمان كيي از روش‌هاي زير را برگزينيد.
	Modify→Alter Path→Expand Stroke

	Xtras→Path Operations→Expand Stroke

Xtra Operations انتخاب آكين  از نوار ابزار        
Expand Stroke روش استفاده از فرمان

1- مسيري را كه مي‌خواهيد تغيير دهيد، انتخاب كنيد )شكل 10-91(.

شكل 91-10 انتخاب مسير

 2- فرم��ان Modify→Alter Path→Expand Stroke را اج��را كني��د.كادر محاوره ش��كل
92-10 ظاهر مي‌شود.

Expand Stroke شكل 92-10 كادر محاوره

تمرين 14: شكل 93-10 را رسم كرده و فرمان Expand Stroke را روي آن اجرا 
كنيد.

شكل 10-93
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Inset Path   6-11-10 فرمان

با استفاده از اين فرمان مي‌توان در اطراف مسيرهاي انتخاب شده، به تعداد دلخواه مسير 
اضافي ايجاد کرد. اين مسيرها متحدالمرکز بوده و مي‌توانند به سمت درون يا بيرون موضوع 

انتخاب شده، ايجاد شوند. 
ب��ه عبارت ديگر فرمان Inset Path كپي‌هاي متع��دد از كي موضوع را ايجاد ميك‌ند. اين 
كپي‌ها مي‌توانند كوچ‌كتر يا بزرگ‌تر از موضوع اوليه باش��ند. براي اجراي اين فرمان كيي از 

روش‌هاي بعد را برگزينيد.
	Modify→Alter Path→Inset Path

	Xtras→Path Operations→Inset Path

	Xtra Operations انتخاب آكين  از نوار ابزار
Inset Path   روش استفاده از فرمان

1- موضوع گرافيكي موردنظر را انتخاب كنيد )شكل 10-94(.
2- فرمان Modify→Alter Path→Inset Path را اجرا كنيد. كادر محاوره ش��كل 10-95 

ظاهر مي‌شود.
3- در کادر Steps تعداد مسيرهايي )كپي‌ها( را كه مي‌خواهيد بر اساس مسير اصلي ايجاد 

شوند، تعيين كنيد.
4- منوي بازشوي Steps داراي سه حالت انتخابي است:

حالت Uniform: باعث مي‌شود فاصله ميان مسيرها كينواخت باشد.
حالت Farther: با اس��تفاده از اين حالت هرچه از موضوع گرافيكي انتخاب ش��ده دورتر 

مي‌شويد، فواصل بين مسيرها بيشتر مي‌شود.
حالت Nearer: با اس��تفاده از اين حالت هرچه از موضوع گرافيكي انتخاب ش��ده دورتر 

مي‌‌شويد، فواصل بين مسيرها كمتر مي‌شود. 

                              

Inset Path شكل 94-10 انتخاب موضوع گرافيكي     شكل 95-10 كادر محاوره
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شكل 96-10 تفاوت بين اين سه حالت را نشان مي‌دهد.

Uniform حالت                                 Farther حالت                              Nearer حالت  

Steps شكل 96-10 تفاوت بين حالات موجود در منوي بازشوي

1- در کادر Inset  مي‌توان مش��خص کرد كه مس��يرهاي اضافه شده، در خارج از شكل يا 
داخل شكل قرار گيرند. اگر مقدار وارد شده در اين کادر مثبت باشد، مسيرهاي اضافه شده، 
داخل ش��كل و اگر منفي باشد، خارج از ش��كل قرار خواهند گرفت. همچنين در اين قسمت 

فاصله ميان مسيرها را نيز مي‌توان كنترل كرد. 
 در شكل 97-10 نمونه‌هايي از تأثيرات فرمان  Inset Path   را روي موضوع گرافيکي واقع در شکل
94-10 ب��ه هم��راه تنظيمات��ي که باي��د در کادر محاوره Inset Path وارد ش��ود، مش��اهده 

مي‌کنيد.
   

 

Inset Path شكل 97-10 نمونه‌هايي از اثر فرمان

2- روي دكمه OK كليك كنيد.
مثال 11:

 
1- شكل 98-10 را رسم كنيد.

2- دو رونوش��ت از ش��كل 98-10 ايجاد كنيد به طوري كه خارج از ش��كل قرار گيرند و 
همان طور كه از شكل اصلي دور مي‌شوند فواصل آن‌ها كمتر شود.
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 Modify→Alter ب��راي اي��ن كار ابت��دا ش��كل 98-10 را انتخاب كنيد، س��پس فرم��ان
Path→Inset Path را اجرا كنيد. در كادر محاوره Inset Path براي تنظيم تعداد كپي‌ها مقدار 

Steps را براب��ر 2 قرار دهيد و حال��ت Nearer را برگزينيد، همچنين مقدار Inset را 10- قرار 

دهيد، نتيجه حاصل به صورت شكل 101-10 خواهد بود.

                  	                      

Inset Path شكل 98-10                    شكل 99-10 نتيجه حاصل از فرمان

 Mirror 12-10 انعكاس اشياء با ابزار
بـا استفاده از اين ابزار مي‌توان قرينه )انعكاس( يک موضوع انتخاب شده را در جهت‌هاي 
افق��ي، عمودي يا چرخش��ي ايجاد کرد. براي اس��تفاده از اين ابزار كي��ي از روش‌هاي بعد را 

انتخاب كنيد.
ابزار Mirror را از جعبه ابزار انتخاب كنيد.	

را  از مس��ير Window→Toolbars نوار ابزار Xtra Tools را باز كرده س��پس ابزار  	
برگزينيد.

Mirror 1-12-10 روش کار با ابزار

1- روي اب��زار Mirror دابل کليک کنيد تا کادر محاوره Mirror مطابق ش��کل 10-100 
باز شود.

Mirror شکل 100-10 کادر محاوره

2- منوي بازشوي موجود در Mirror، شامل حالات زير براي قرينه‌سازي است: 
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"Vertical:	 قرين��ه عم��ودي يعني ش��ئ را از س��مت‌ چپ ‌به ‌راس��ت ‌نش��ان ‌مي‌دهد 

)شکل 10-101(.
Horizontal: قرينه افقي يعني شئ را از بالا به پايين‌ نشان مي‌دهد. 	

Horizontal & Vertical: قرينه افقي و عمودي.	

شکل 101-10 قرينه عمودي

Multiple: موضوعات‌را نسبت ‌به محورهاي مختلف قرينه ‌مي‌کند. در اين حالت مي‌توانيد 

از دکم��ه لغزن��ده موجود در کادر محاوره Mirror براي تنظيم تعداد محورهاي قرينه‌س��ازي 
استفاده کنيد.

 نكته: نگه داشتن كليد Alt  باعث مي‌شود تا هنگام استفاده از ابزار Mirror محور 
قرينه‌سازي دوران كند.

تمرين 15: ش��کل 102-10 را رسم کنيد و با ابزار Mirror شكل 103-10 را به 
دست آوريد.

                                                      

     شکل 102-10                                     شکل 103-10 رسم شکل

مث�ال كاربردي: فايل Project مثال کارب��ردي را باز کنيد. حال مي‌خواهيم آرم 
 

را كامل كنيم.
1- به صفحه ترسيم آرم بازگرديد و ترسيم آرم را از واحدكار ششم ادامه دهيد.
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2- از دايره كي كپي تهيه كرده، سپس پنلTransform  را ظاهر كنيد. در اين پنل دكمه 
Scale را فعال كنيد تا گزينه‌هاي Scale  در دسترس قرار گيرند.

3- در كادر Scale مقدار 42% را وارد كنيد تا دايره دوم به اندازه 58% كوچ‌كتر شود.

شكل 10-104

4- دايره‌ه��ا را انتخ��اب ك��رده و از حالت گروهي خارج كنيد تا نقاط لنگر ظاهر ش��وند. 
 Modify نقاط لنگر دايره‌ه��ا را انتخاب كنيد و از منوي Shift و كليد Subselect توس��ط اب��زار
چند بار فرمان Split را اجرا كنيد تا دايره‌ها در نقاط لنگر شكس��ته و به چهار قطعه تقس��يم 
ش��وند. نيمك‌ره پايين و قطعات سمت راست هر دو دايره را حذف كنيد تا شکل 105-10 به 

دست آيد.
5- اکنون هر دو كمان را انتخاب کرده و از منوي Modify فرمان Join را انتخاب كنيد و 
در پنل Object گزينه Closed را فعال كنيد تا طرف ديگر كمان‌ها نيز به كيديگر چسبيده و 

كي شكل بسته حاصل شود.                       
6- هر دو ش��كل را انتخاب كنيد و از من��وي Modify→Combine فرمان Union را اجرا 
كنيد تا كي مس��ير واحد به وجود آيد، سپس ش��كل را انتخاب کرده از پنل Swatches رنگ 
سياه را براي دكمهFill  انتخاب كنيد تا شكل از رنگ سياه پر شود. اکنون دكمه Stroke را در 

پنل Swatches فعال و None را انتخاب كنيد تا خط دور شكل حذف شود.

              

شكل 105-10                      شكل 10-106

7- شكل 107-10 را انتخاب كنيد و با استفاده از فرمان Edit→Clone كي كپي از شكل 
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ايجاد كرده و با استفاده از ابزار Mirror آن را به شكل 108-10 تبديل كنيد.

	

 شكل 107-10                                  شكل 10-108

8- حال با استفاده از خطوط راهنما و ابزار Pen شكل 109-10 را رسم كنيد.
9- داخل ش��كل را س��ياه رنگ كنيد. مطابق ش��كل 110-10 دو دايره در قس��مت‌هاي 

مشخص شده در شكل رسم كنيد و آن‌ها را نيز با رنگ سياه پر كنيد.

               

شكل 109-10                                              شكل 10-110

10- تغييرات را ذخيره كنيد.

واژه‌نامه
Cropبرش

Divideتقسيم کردن

Intersectاز وسط قطع کردن

Lockقفل کردن

Punchسوراخ کردن

Splitاز هم جدا کردن

Ungroupاز گروه خارج کردن

Unionپيوند، اتحاد

خلاصه مطالب 
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فرمان Join	 باعث اتصال دو خط به يکديگر مي‌شود.
از فرمان Split	 براي شکستن موضوعات بسته و جدا کردن خطوط و گره‌ها از يکديگر و جدا 

کردن موضوعات Join شده استفاده مي‌شود.
به منظور چرخش موضوعات تحت زاويه‌اي خاص مي‌توان از ابزار Rotate	 استفاده کرد.

براي ايجاد قرينه يا انعکاس يک موضوع گرافيکي از ابزار Reflect	 استفاده مي‌شود.
از ابزار Skew	 براي مورب کردن موضوعات استفاده مي‌شود.

گزينه‌هاي Blend و Union	 براي ترکيب گوناگون اشکال به کار مي‌روند.
از گزينه Join Blend To path	 براي قرار دادن موضوع ترکيب ش��ده روي مس��ير اس��تفاده  

مي‌شود.
گزينه Divide	 قس��مت مش��ترک موضوعات را ب��رش مي‌دهد و از موضوع��ات اصلي جدا 

مي‌کند.
از گزينه Intersect	 براي به‌دست آوردن قسمت‌هاي مشترک موضوعاتي که روي يکديگر 

قرار دارند، استفاده مي‌شود. 
گزينه Punch	 ش��کلي را که روي بقيه اش��کال قرار دارد همراه با قس��مت مشترک آن با 

اشکال زير حذف و باقي اشکال را حفظ مي‌کند.
گزينه Crop	 قسمت مشترک موضوعات را برش مي‌دهد.

براي ايجاد تصوير قرينه و آينه اشکال از ابزار Mirror استفاده مي‌شود.	
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آزمون نظري
درستي يا نادرستي گزينه هاي زير را تعيين کنيد.

1- فرمان Split قسمت مشترک موضوعات را برش مي‌دهد.
2- کاربرد فرمان Group گروه کردن موضوعات است.

3- فرمان Expand Stroke در اطراف كي ش��ئ به سمت داخل، كپي‌هاي متعددي ايجاد 
ميك‌ند.

4- عملكرد فرمان Mirror با Rotate كيسان است.
معادل گزينه هاي سمت ‌راست را از ستون سمت ‌چپ انتخاب کرده و مقابل هر عبارت بنويسيد.

    Punch. براي به‌دست آوردن قسمت‌هاي مشترک موضوعاتي که روي يکديگر قرار دارند
شکل روي بقيه اشکال را همراه با قسمت مشترک آن با اشکال زير، حذف و باقي اشکال 
     Crop                                                                                   .را حفظ مي‌کند
     Reverse Direction                              	.قسمت مشترک موضوعات را برش مي‌دهد
                   Intersect                                                     	 اصلاح جهت قرارگيري مسيرها

گزينه صحيح را انتخاب کنيد.

9- فرمانSplit  برعکس کدام فرمان عمل مي‌کند؟
Align -د 	Divide -ج 	Crop -ب 	Join -الف

10- براي حذف روي هم افتادگي موضوعات از كدام فرمان استفاده ميك‌نيد؟
Remove Overlap  -ب 		 Simplify  -الف
Correct Direction‍ -د 		 Delete -ج

11- براي هم تراز کردن موضوعات نسبت به يکديگر، از کدام گزينه استفاده مي‌شود؟
Join -د 	  Divide -ج 	Crop -ب 	Align -الف

12- ازکدام‌گزين��ه براي واحد‌کردن چند ش��کل و تبديل آن‌ها به يک موضوع اس��تفاده 
مي‌شود؟

Ungroup -د 	Union -ج 	Lock  -ب 	Punch -الف
13- براي خارج کردن موضوع گرافيکي از حالت قفل، از کدام فرمان استفاده مي‌شود؟ 

Lock -د 	Unlock -ج 	Union -ب 	Join -الف
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14- براي اتصال دو خط به يکديگر از کدام فرمان استفاده مي‌شود؟
Join -د     	         Blend -ج       	Split -ب    	Align -الف

15- كدام فرمان باعث افزايش ضخامت خطوط دور شكل مي‌شود؟
Union    -د 	Intersect -ج 	Expand Stroke -ب 	Inset Path -الف

16- براي برش قس��مت‌هاي مش��ترك موضوعات، بدون حذف موضوعات اصلي از کدام 
فرمان استفاده مي‌شود؟

Punch -د            	Crop  -ج       	Split -ب      	Divide -الف
17- براي انتخاب اجزاي يک گروه از کدام ابزار استفاده مي‌شود؟

	Subselect -ب 	 	Group -الف
Pen -د 	 	Pointer -ج

در جاي خالي عبارت مناسب را بنويسيد.

18- هنگام اس��تفاده از فرمان ............ رونوشت‌هاي ايجاد شده در داخل‌ شكل اصلي قرار 
مي‌گيرند.

19- براي قرينه‌‌سازي موضوعات به صورت افقي هنگام استفاده از ابزار Mirror از گزينه 
......... استفاده مي‌شود.

20- ابزار .............. موضوعات را مورب ميك‌ند.
به سؤالات زير پاسخ تشريحی دهيد.

21- بعد از قفل کردن يک شکل چه اعمالي را نمي‌توان روي شکل انجام داد؟
22- فرمان Blend چه عملي را انجام مي‌دهد؟

23- چگونه مي‌توان موضوعات گرافيکي داخل صفحه را نسبت به هم، تراز افقي کرد؟
24- فرمانJoin  Blend To Path چه عملي را انجام مي‌دهد؟

25- از ابزارReflect  در چه مواقعي استفاده مي‌شود؟
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 آزمون عملي
1- اشکال زير را با استفاده از ابزارهاي اين واحد كار رسم کنيد.

 
2- شکل الف را ترسيم کرده، سپس آن را با يک فرمان به شکل ب تبديل کنيد.

بالف 

3- با استفاده از ابزارهاي مناسبي كه در اين واحد كار با آن‌ها آشنا شده‌ايد به سليقه خود 
در كي صفحه‌ به اندازه A3 در مورد رش��ته‌هاي گرافيك، كامپيوتر و تعمير موبايل هنرستان 

خود تبليغ كنيد.
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کليات 
در واحدكاره��اي قبل با پنل Object  آش��نا ش��ديد اين پنل نه تنها کنترل بيش��تري بر 
موضوع��ات مختلف دارد، بلکه امکان اف��زودن جلوه‌هاي ويژه )Special effect( به موضوعات را 

نيز دارا است.
Add effect 1-11 اضافه کردن جلوه‌هاي ويژه با استفاده از

با اس��تفاده از گزينه Add effect موج��ود در پنل Object مي‌توان خصوصيات و جلوه‌هاي 
ويژه‌اي را به اشکال اضافه نمود.

شئ، مراحل زير را انجام دهيد: 	 Stroke يا Fill به منظور افزودن جلوه‌هاي ويژه به
1- موضوع مورد نظر را انتخاب نماييد.

2- در پن��ل Object روي دکم��ه Add effect کلي��ک کرده و از منوي ظاهر ش��ده جلوه 
موردنظر را انتخاب کنيد)شكل 11-1(.

Add effect شکل 1-11 گزينه‌هاي
به منظور حذف جلوه ويژه از موضوع انتخابي، مراحل بعد را انجام دهيد: 	

1- در پنل Object جلوه ويژه را انتخاب نماييد.
2- سپس در همان پنل روي دکمه  )Remove item( کليک کنيد.

در اين‌جا به شرح گزينه‌هاي موجود درAdd effect  مي‌پردازيم:

 توجه: برخي از جلوه‌ها به صورت ابزار در نوار ابزار Xtra Tools قرار دارند.

Bend 1-1-11 جلوه
اين گزينه در شکل‌ها و مسيرهاي رسم شده، پيچ و خم و اعوجاج ايجاد مي‌کند، به طوري 
که با کشيدن نقاط محيط به سمت نقطه مرکز يا دور نمودن اين نقاط از مرکز، پاره‌خط‌هاي 
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مسير به سمت داخل يا خارج منحرف مي‌شوند و حالت شکل تغيير پيدا مي‌کند.
Bend تنظيم گزينه‌هاي

1- گزينه Bend را از منوي Effect انتخاب کنيد. 
2- دکم��ه لغزن��ده مربوط به گزينه Size، ميزان فاصله نق��اط از مرکز يا ميزان خميدگي 

اعمال شده به شئ را تعيين ميك‌ند. 
مقادي��ر مثبت، نقاط را از مرکز دورتر و در محل تلاقي كمان‌ها نقاط نوك تيز ايجاد  	

ميك‌ند.
مقادي��ر منف��ي، نقاط را به مرکز نزديک‌تر و انتهاي كمان‌ها را به مركز ش��ئ متصل  	

‌مي‌نمايد )شکل11-3(.   

Bend شکل 2-11 کادر محاوره

Bend شكل اصلي    مقادير مثبت در جلوه    Bend مقادير منفي در جلوه

شکل 11-3

3- با ويرايش مختصات نقاط x و y مي‌توان مکان نقطه مرکز را تغيير داد.

تمرين 1: ش��کل 4-11 را رس��م كرده و جلوه Bend را روي Stroke دور ش��کل 
اعمال نماييد )نتايج حاصل از تغيير مقدار Size را مشاهده كنيد(.
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شکل 11-4

Duet 2-1-11 جلوه

اين جلوه يک يا چند مدل مش��ابه از ش��کل ساخته، آن‌ها را با يکديگر ترکيب مي‌کند تا 
يک شکل پيچيده واحد ايجاد نمايد.

مي‌توان تعداد مدل‌هاي مش��ابه را که ايجاد مي‌ش��وند تعيين كرد و مش��خص نمود که 
مدل‌هاي مشابه چرخش يابند يا انعکاس يافته شکل اوليه باشند.

Reflect شكل اصلي             گزينه              Rotate گزينه

شکل 11-5

براي اعمال جلوه Duet روي موضوع مورد نظر مراحل زير را انجام دهيد:
1- پس از انتخاب موضوع موردنظر، از منوي Effect)شکل 1-11( گزينه Duet را انتخاب 

كنيد.
2- به منظور ايجاد تصوير منعکس ش��ده از تصوير اوليه گزينه Reflect  را انتخاب نماييد 

)شکل 11-6(.
3- به منظور ايجاد کپي چرخش يافته حول نقطه مرکز گزينه Rotate  را انتخاب كنيد.
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Duet شکل 6-11 تنظيم خصوصيات جلوه

4- براي تنظيم موقعيت نقطه مركزي جلوه و جهت اش��کال، مختصات x و y را اس��تفاده 
نماييد.

5- براي تعيين تعداد کپي‌ها از شکل بايد تعداد موردنظر را در کادر Copies وارد كرد.
6- اگر بخواهيد ش��کل اوليه با ش��کل‌هاي ايجاد شده به‌طور خودکار متصل شوند گزينه 

Joined را در حالت انتخاب قرار دهيد.

7- اگر كپي‌ها نزدكي به هم هس��تند گزينه Closed باعث بس��تن اش��کال ايجاد شده يا 
مسيرهاي باز مي‌شود.

8- براي ش��فاف نمودن نواحي همپوش��اني بين كپي‌ها، گزينه Even/Odd fill را انتخاب 
كنيد.

 مثال 1: براي درك بيشتر جلوه Duet مراحل زير را انجام دهيد:
1- شکل 7-11 را رسم نماييد.

2- گزينه Duet را از منوي Add effect انتخاب کنيد. تصوير منعکس شده از شکل اصلي 
همراه با خود شکل به صورت زير ايجاد مي‌شود.

3- از قس��مت Style گزينه Rotate را انتخاب کرده، در کادر Copies عدد 6 را وارد نموده 
و گزينه Joined را انتخاب کنيد در اين صورت شکل 9-11 به‌وجود مي‌آيد.

 



Free Hand پیمانه مهارتی : کاربر
303واحد کار یازدهم: توانایی استفاده از جلوه های ویژه  

          

    شکل 7-11                           شکل 8-11                                                   شکل 11-9                                            

4- گزينه Closed را برگزينيد تا شکل 10-11 ايجاد شود.

      

شکل 11-10

تمرين 2: شکل 11-11را ايجاد كنيد.

شکل 11-11

Expand path 3-1-11 جلوه

اين جلوه مس��ير را پهن نموده و طرح کلي )Outline( شکل حاصله را ايجاد ميك‌ند. اين 
جلوه تنها ظاهر مسير را تغيير مي‌دهد و باعث تغيير خود مسير نمي‌شود.
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Expand Path شکل 12-11 نمايش 
به منظور اعمال جلوه Expand Path روي موضوع موردنظر، مراحل زير را انجام دهيد:

 Expand 1- پس از انتخاب موضوع موردنظر، از منوي ظاهر ش��ده )ش��کل 1-11( گزينه
Path را انتخاب كنيد.

2- تنظيمات موردنظر را اعمال نماييد:
باعث گس��ترش مس��ير به س��مت  	    Inside only انتخاب گزينه Direction در من��وي
درون و گزينه Outside only باعث گس��ترش مس��ير به سمت بيرون مي‌شود. گزينه 
"Both مس��ير را به‌ط��ور كيس��ان به هر دو ط��رف درون و بيرون گس��ترش مي‌دهد 

)شکل 11-13(.

Direction شکل 13-11 گزينه‌هاي منو

در کادر متني Width مقادير 0 تا 50	 را مي‌توان وارد نمود. هرچه مقدار وارد شده در 
اين قسمت کمتر باشد، مسير کمتر گسترش ميي‌ابد. از دكمه لغزنده در اين قسمت 

نيز براي تنظيم اندازه مسير گسترش يافته استفاده مي‌شود. 
با عملکرد بقيه گزينه‌ها در واحد كار 9 آشنا شده‌ايد.	

  Ragged4-1-11جلوه
اي��ن جلوه با افزودن نقاط تصادفي جديد، ظاهر ش��کل را تغيي��ر داده و ظاهري ناهموار، 

صاف يا يکدست به شکل مي‌دهد. اين جلوه شبيه ابزار Roughen كار ميك‌ند.

Both شکل اصلی      گزینه       Inside only گزینه     outside only گزینه                 
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Ragged شکل 14-11 جلوه

به منظور اعمال جلوه Ragged روي موضوع موردنظر مراحل زير را انجام دهيد:
1- پس از انتخاب موضوع موردنظر از منوي ظاهر ش��ده )شکل 1-11( گزينه Ragged را 

انتخاب نماييد.
2- تنظيمات موردنظر را اعمال نماييد:

در كادر Size	 يا با كمك لغزنده آن مي‌توان فاصله نقاط افزوده ش��ده تا‌ ش��کل اصلي‌ 
را تغيير داد.

در قسمت Frequency مي‌توان تعداد نقاط افزوده را تعيين نمود.	
در صورتي که بخواهيد از ش��کل موردنظر کپي ايجاد كنيد در قس��متCopy 	 تعداد 

کپي‌هاي مورد نظر را وارد نماييد.

Ragged شکل 15-11 تنظيمات جلوه

كيي از گزينه‌هاي  Edgeكه در زير بيان شده انتخاب كنيد:	
انتخاب گزينه Rough ، نقاط گوشه تيز را اضافه مي‌کند )شكل 11-16(.	
انتخاب گزينه Smooth، نقاط انحنادار را اضافه مي‌کند )شكل 11-16(.	

انتخاب گزينه Uniform باعث مي‌ش��ود تا جلوه Ragged	 به صورت يکنواخت اعمال 
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شود.

شكل 11-16

تمرين 3: شکل‌هاي زير را با استفاده از جلوه‌هاي Ragged و Expand Path ايجاد 
کنيد.

شکل 11-17

  Sketch 5-1-11 جلوه
اين جلوه نمايي از مسير را شبيه‌سازي مي‌کند که به نظر مي‌رسد شکل مورد نظر با مداد 

و به سرعت طراحي شده است.

اعمال جلوه Sketch در صورت                                    شكل اصلي                       اعمال جلوه Sketch در صورت
               بسته بودن خطوط دور شكل                                                                               باز بودن خطوط دور شكل 

Copies با Sketch شکل 18-11 اعمال جلوه

به منظور اعمال جلوهSketch  روي موضوع موردنظر، مراحل زير را انجام دهيد:
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1- پس از انتخاب موضوع موردنظر، از منوي ظاهر شده گزينهSketch  را انتخاب كنيد.
2- تنظيمات موردنظر را اعمال نماييد.

وارد کردن عدد بزرگ‌تر در قسمت Amount	 باعث مي‌شود که اختلاف شکل با شکل 
اوليه بيشتر شود.

براي ايجاد کپي از ش��کل ايجاد ش��ده، تعداد کپي موردنظر را در قسمت Copy	 وارد 
كنيد. در اين صورت مسيرهاي جديدي به وجود مي‌آيند كه به طور تصادفي با ساير 

كپي‌ها متفاوتند )شكل 11-19(.

شکل 19-11 مثال‌هايي از تنظيم كادر كپي روي دو شكل

انتخاب گزينه Closed باعث مي‌ش��ود تا نقاط انتهايي شکل ايجاد شده به يکديگر متصل 
شوند و شکل بسته ايجاد شود. 

Close غيرفعال بودن گزينه   		 Close فعال بودن گزينه                  

شکل 11-20

  Bevel and Emboss6-1-11 جلوه
جلوهBevel  باعث مي‌ش��ود لبه‌هاي ش��کل به حالت برجسته نمايش داده شوند و با جلوه 

Emboss  مي‌توان شکل يا متن را به صورت برجسته نمايش داد.

ب��ا انتخاب جل��وه  Bevel and Emboss )ش��کل 1-11( زيرمنويي به‌ص��ورت بعد نمايان 
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مي‌شود. 
انتخ��اب Inner Bevel و Outer Bevel	 باعث مي‌ش��ود تا لبه‌هاي ش��کل به ترتيب به 

سمت درون و بيرون شکل متمايل شوند و به حالت برجسته نمايش داده شوند.

 
شکل 22-11                                                                       شکل 11-23  

 ب��ا انتخ��اب Outer Bevel در پن��ل Object	 مي‌ت��وان تنظيم��ات زير را انج��ام داد: 
)شکل 11-24(

از پالت رنگ مي‌توان رنگ مورد‌‌نظر براي برجستگي به سمت خارج شكل‌ را انتخاب  	
نمود.

در ليست بازشوي Width مقدار مورد نظر براي پهناي برجستگي‌ را وارد نماييد.	
مقادير تعيين ش��ده در ليست بازش��وي Contrast	 ميزان روشني و تيرگي سايه‌ها را 

معين مي‌کند.
مي‌توان مقاديري براي تأثير بر صافي برجستگي، بدون  	  Softness در ليس��ت بازشوي
تأثي��ر ب��ر پهناي آن وارد كرد. ب��ه عبارت ديگر هر خط ضخيم در س��ايه‌زني حذف 

مي‌شود.
در ليس��ت بازش��وي Angle	 مي‌توان با وارد کردن مقدار موردنظر، زاويه تابش نور را 

تنظيم نمود.
در ليست بازشوي Edge shape شکل لبه را مي‌توان به دلخواه انتخاب كرد.	

در ليس��ت بازش��ويButton Preset 	 پيش‌تنظيم‌هايي براي تغيير ظاهر ش��ئ وجود 
دارد.
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شکل 11-24

 Raised اس��تفاده كرد. اگر گزينه Emboss براي برجس��ته کردن ش��کل مي‌توان از جلوه
Emboss را انتخاب کنيد کادر شکل 25-11 نمايش داده مي‌‌شود.

Raised Emboss شکل 25-11 تنظيمات جلوه

مقدار مشخص شده در ليست بازشوي Width، اندازه عمق را تعيين مي‌کند.	
مقدار تعيين ش��ده در ليست بازش��وي Contrast	 ميزان روشني و تيرگي سايه‌ها را 

معين ‌‌مي‌کند.
مي‌توان مقاديري براي تأثير بر صافي برجستگي، بدون  	 Softness  در ليست بازش��وي

تأثير بر پهناي آن وارد كرد.
در قسمت Angle	 مي‌توان با وارد کردن مقدار مورد نظر يا استفاده از عقربه کشويي، 

زاويه تابش نور را تنظيم نمود.
در شكل 26-11 نمونه‌هايي از جلوه Emboss نشان داده شده است.
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شکل 11-26

در Inset Emboss برجسته‌س��ازي به نحوي است كه گويي شئ در صفحه فشار داده شده 
است.

در Raised Emboss برجسته‌سازي به نحوي است كه گويي شئ از صفحه بالاآمده   است.
تمرين 4: شکل 27-11 را طوري رسم كنيد که برجسته به نظر آيد.

شکل 11-27
Blur 7-1-11 جلوه

اين جلوه جزييات تصوير را تيره و تار مي‌کند. اين جلوه دو حالت دارد.
حال��تBasic ، جل��وه غيرمتمرکز به ش��کل مي‌دهد و حال��ت Gaussian ظاهري مبهم به 
 ش��کل مي‌دهد به طوري که به نظر مي‌آيد از پش��ت شيشه نيمه مات به شکل نگاه مي‌کنيد 

)شکل 11-28(.

شکل 11-28

پ��س از اعمال جلوه Blur در کادر نمايش داده ش��ده )ش��کل 29-11( به منظور تعيين 
ميزان مات شدن شکل، عدد مورد نظر را وارد كنيد.
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     Blur شکل 29-11 تنظيمات جلوه

تمرين 5: ش��کل 30-11 را رس��م كرده و جلوه Gaussian Blur را روي آن اعمال 
كنيد.

شکل 11-30

Shadow and Glow 8-1-11 جلوه
براي ايجاد سايه دور شکل از جلوه Shadow استفاده مي‌شود و جلوه Glow درون يا بيرون 

شکل هاله ايجاد مي‌نمايد )شکل 11-31(.
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Glow و Shadow شکل 31-11 نتيجه حاصل از تأثير جلوه

به منظور اعمال جلوه Shadow روي شکل مراحل زير را انجام دهيد:
 Shadow andش��کل 1-11( گزينه( Effect 1- پس از انتخاب موضوع مورد نظر، از منوي

Glow  را انتخاب كرده سپس كيي از جلوه‌هاي زير منوي مربوطه را برگزينيد.

) Drop Shadow: جلوه ‌را به‌گونه‌اي ايجاد‌ ميك‌ند كه به شئ سايه‌ مي‌دهد )شكل11-32	

جلوه به‌گونه‌اي اس��ت كه گويي سوراخي از شئ در صفحه به‌وجود  	 :Inner Shadow

آمده است )شكل 11-32(.
Glow: در بخش بيروني شئ درخشندگي يا هاله ايجاد ميك‌ند )شكل 11-32(.	

Inner Glow: در درون شئ درخشندگي ايجاد ميك‌ند )شكل 11-32(.	

Glowو Shadow شکل 32-11 اعمال جلوه‌هاي

2- تنظيمات موردنظر را اعمال كنيد.
از قسمت Color	 رنگ موردنظر براي ايجاد سايه يا هاله را انتخاب نماييد.

ميزان فاصله سايه از لبه شئ را در ليست بازشويOffset 	 تنظيم كنيد.
به منظور تعيين ميزان ش��فافيت س��ايه يا هاله در ليس��ت بازش��وي Opacity	 عدد 

موردنظر را وارد نماييد.
براي اين‌که س��ايه يکدس��ت و نرم روي تصوير اعمال ش��ود به طوري که پهناي آن  	
تغيير نکند مي‌توان در ليست بازشوي Softness عدد موردنظر را وارد نمود. به عبارت 

ديگر براي اعمال تارشدگي به لبه سايه استفاده مي‌شود.
براي تعيين زاويه تابش نور بر جسم، عدد موجود در ليست بازشوي Angle	 را تنظيم 

كنيد.
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Shadow and Glow شکل 33-11 تنظيمات جلوه

در تنظيمات جلوه س��ايه براي پنهان كردن شئ و باقي ماندن سايه، Knock Out	 را 
انتخاب كنيد )شكل 11-34(.

 Shadowدر انواع حالات جلوه Knock Out شکل 34-11 تنظيم گزينه

تمرين 6: ش��کل 35-11 را رس��م كنيد. )به جلوه‌هاي اعمال ش��ده روي شکل 
توجه کنيد.(

شکل 11-35
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Sharpen 9-1-11 جلوه

اين جلوه با تنظيم Contrast پيکسل‌هاي همجوار در شکل، وضوح يا تيزي لبه‌هاي شکل 
را افزايش مي‌دهد )شکل 11-36(.

Sharpen شکل 36-11 نتيجه حاصل از تأثير جلوه

به منظور اعمال جلوهSharpen  روي موضوع موردنظر مراحل زير را انجام دهيد:
1- پ��س از انتخاب موض��وع موردنظر، از منوي Effect )ش��کل 1-11( جلوه Sharpen را 

انتخاب كنيد، سپس از زيرمنوي آن گزينه‌هاي زير را برگزينيد. 
2- تنظيمات موردنظر را اعمال كنيد. )شکل 11-37(

در ليست بازشوي Amount  ميزان شدت اعمال جلوه را تعيين کنيد.	
زماني که Unsharp mask انتخاب ش��ده باش��د از ليست بازشوي Pixel Radius	 براي 
تنظيم اندازه ناحيه‌اي استفاده كنيد كه جلوه Sharpen به آن اعمال شده باشد. اعداد 

بالاتر به معناي اعمال جلوه كمتري به تصوير است.

Sharpen شکل 37-11 تنظيمات جلوه

Transparency 10-1-11جلوه

با اس��تفاده از اين جلوه مي‌توان تمام يا قس��متي از رنگ داخل شکل يا خط دور شکل را 
به صورت واضح يا نيمه کدر نمايش داد.
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شکل 11-38

با انتخاب گزينهTransparency  زيرمنوي زير نمايش داده مي‌شود )شکل 11-39(.

شکل 11-39

جلوه Basic Transparency	 تمام شکل را به‌طور يکنواخت شفاف مي‌نمايد. به‌طوريك‌ه 
موضوعات ديگر از زير آن ديده شوند.

با انتخاب اين جلوه مي‌توان ميزان ش��فافيت را در کادر Transparency	 با كش��يدن 
دكمه لغزنده تعيين نمود.

جلوه Feather	 موضوع را از داخل به سمت بيرون محو ميك‌ند به‌طوريك‌ه محو شدن 
در  لبه‌هاي شکل صورت مي‌گيرد.

در کادر Radius براي تعيين شعاع محوشدگي )Transparency( از مرکز شکل، عدد	 
موردنظر را وارد ‌نماييد. 

ه��اي موجود در  جل��وه Gradient Mask باع��ث محو ش��دن موضوع به صورت طيف‌	
FreeHand، مي‌ش��ود. رنگ س��فيد 100% شفافيت و رنگ مش��کي 100% تاري را 

توليد مي‌کند.
تمري�ن 7: پرچم ايران را رس��م كنيد و بين رنگ‌ه��ا را Transparency كنيد تا 

رنگ‌ها بدون مرز باشند.
Envelope 2-11 فرمان

فرمان Envelope امکان فرم‌دهي به تصاوير و نوشته‌ها را فراهم مي‌نمايد. با استفاده از اين 
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دستور مي‌توان ظاهر شکل را تغيير داد. 
براي اجراي اين دستور از منوي Modify گزينه Envelope را انتخاب نماييد در اين صورت 
 Envelope زيرمنوي��ي نمايش داده مي‌ش��ود که ش��امل گزينه‌هاي مورد اس��تفاده در فرمان

است.

 Envelope نوار ابـزار Window → Toolbars → Envelope نكته: با انتـخاب ‌گزينـه

 نمـايش ‌ميي‌ابد.

)شکل 11-40(.

Envelope شكل 40-11 نوار ابزار

با کليک روي منوي بازشوي موجود در اين نوار ابزار، ليست اشکال مختلف نمايش داده 
مي‌شود. براي تغيير يا فرم‌دهي شکل مراحل بعد را انجام دهيد:

1- شکل موردنظر را انتخاب كنيد.
2- روي آيک��ن Create  در ن��وار ابزار Envelope کليک نماييد. گره‌ها و اهرم‌هايي در 
اطراف ش��کل نمايش داده مي‌شود و شما مي‌توانيد با استفاده از ابزارهاي تغيير مسير، ظاهر 

شکل را به صورت موردنظر تغيير دهيد. 

 مثال 2:
1- شکل 44-11 را رسم نماييد.

2- از منوي بازشوي نوار ابزار Envelope گزينه Heart را انتخاب كنيد.

   شکل 41-11                شکل 42-11 انتخاب گزينه Heart                    شکل 11-43
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3- روي آيکن )Create(  يا گزينه Envelope→Create از منوي Modify کليک کنيد. 
شکل به اين صورت نمايش داده مي‌شود.

يا   Remove نكت�ه: براي حذف تمام تغييرات انجام ش��ده روي ش��کل، آيکن 
گزينه Envelope→Remove از منوي Modify را کليک كنيد.

 Envelope→Show Map يا گزينه  Show Map توج�ه: با کليک روي آيک��ن 

از منوي Modify مي‌توانيد س��اختار و خطوط نقش��ه فرم اعمال ش��ده را مشاهده كرده و در 
صورت نياز آن را تغيير دهيد.

1-2-11 اعمال يک مسير دلخواه روي تصوير به‌عنوان Envelope)پوشش( 
1- مسير موردنظر را رسم نموده روي گزينه Edit→Copy کليک نماييد.

2- شکلي را که مي‌خواهيد مسير موردنظر به عنوان Envelope به آن اعمال شود، انتخاب 
کنيد.

 3- روي دکم��ه Paste as envelope  از ن��وار‌ اب��زار Envelope كلي��ك كنيد يا گزينه
 Envelope→Paste as envelope را از منوي Modify اجرا كنيد.

در اين صورت Envelope به شكل موردنظر‌ اعمال مي‌شود )شكل 11-44(.

شكل 44-11 اعمال مسير به متن

2-2-11 ذخيره‌سازي مسير اعمال شده به شکل
هنگامي كه كي Envelope جديد ايجاد كرديد ممكن اس��ت بخواهيد آن را ذخيره كنيد 
تا روي اش��ياي ديگر اعمال كنيد. به منظور ذخيره‌س��ازي مس��ير اعمال شده به شئ مراحل 

زير را انجام دهيد:  
1- شکلي را انتخاب كنيد که داراي Envelope مورد نظر شما براي ذخيره است. 

 Envelope→save as ياگزينه Envelope از نوار اب��زار  save as preset 2- روي دکم��ه
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preset از منوي Modify کليک كنيد.

3- کادر محاوره New Envelope نمايش داده مي‌ش��ود )ش��کل 45-11(. در كادر متني 
Name نام موردنظر را درج نموده و روي دكمه OK کليک نماييد تا مسير موردنظر به عنوان 

يک فرم به بالاي منوي بازشوي موجود در نوار ابزار Envelope اضافه شود.

شکل 11-45

 نكته: به منظور حذف يک فرم از منوي بازش��وي نوار ابزار Envelope، نام فرم را 
 Envelope→Delete يا گزينه  Delete preset از ليس��ت انتخاب كرده س��پس روي دکمه

preset از منوي Modify کليک كنيد.

3-2-11 استفاده از يک فرم Envelope براي ساخت مسير 
پس از ايجاد كي Envelope مي‌توانيد آن را به مسير تبديل كنيد. در اين صورت تغييرات 
قابل اعمال  روي مس��ير را مي‌توانيد روي آن فرم اعمال نماييد. براي اين منظور مراحل زير 

را انجام دهيد:
1- ش��کل موردنظر که فرم Envelope را روي آن اعمال نموده‌ايد، انتخاب کنيد )ش��کل 

.)11-46
 Modify از منوي Envelope→Copy as Path يا گزينه  Copy as Path 2- روي دکمه

کليک نماييد.
3- از منوي Edit گزينه Paste را انتخاب كنيد )ش��کل 47-11(. مي‌توانيد كي زمينه يا 

خط دور به مسير اضافه نماييد.

      

		       شکل 11-47                                 شکل 11-46

 نكته: براي حذف پوشش )Envelope( از روي شکل به‌طوري که تغييرات اعمال شده 
به ش��کل حفظ ش��ود، روي دکم��ه  Release  يا گزين��ه Envelope→Release  از منوي 

Modify کليک كنيد.
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  Fisheye Lens3-11 ابزار
با اس��تفاده از اين ابزار مي‌توان به موضوعات انتخاب ش��ده، حالت تقعر يا تحدب داد. به 
عبارت ديگر اين ابزار مانند لنز چش��م ماهي باعث ايجاد اعوجاج در اش��ياء مي‌شود به طوري 

كه اشياء را برجسته مي‌بينيد.
Fisheye Lens 1-3-11 روش کار با ابزار

 Fisheye Lens در جعبه ابزار دابل کليک کنيد تا کادر محاوره Fisheye Lens 1- روي ابزار
مطابق شکل 48-11 باز شود.

         

 Fisheye Lens  شکل 48-11 کادر محاوره

2- با استفاده از ماوس، دکمه لغزنده Perspective را درگ کنيد.
Convex )محدب( يا اعداد مثبت، شئ را برجسته مي‌کند.	

Concave )مقعر( يا اعداد منفي، در شئ تورفتگي ايجاد مي‌کند.	

3- روي دکمه OK کليک کنيد. 
4- روي ش��کل انتخاب شده، کليک کرده و اشاره‌گر ماوس را بکشيد تا در ناحيه دلخواه 

شكل مقعر يا محدب شود.
مثال 3:

 
1- متن Freehand MX را مطابق شکل 49-11 روي صفحه تايپ کنيد.                                                                                           

شکل 49-11 تايپ متن

2- رنگ متن را آبي کنيد.
3- روي متن کليک راست کرده، گزينهConvert To Paths  را انتخاب کنيد تا حالت متن 

به مسير تبديل شود.
4- روي ابزار Fisheye Lens دابل کليک کنيد تا کادر محاوره Fisheye Lens باز شود.

5- در قسمت Perspective نوع لنز را محدب قرار دهيد )شکل 11-51(.
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 شکل 50-11 روش تبديل حالت متن به مسير               شکل 51-11 تنظيم محدب بودن جلوه

6- اش��اره‌گر ماوس را روي متن نوش��ته ش��ده در ناحيه‌اي که مي‌خواهيد محدب شود، 
بکشيد تا شکل يک بيضي ايجاد شود )شکل 11-52(.

7- كليد ماوس را رها کنيد تا مطابق شکل 53-11 جلوه ايجاد شود. 
     

             

Fisheye Lens شکل 53-11 نتيجه استفاده از ابزار         Fisheye Lens شکل 52-11 اعمال ابزار

 نكته: كليد Alt را نگه داريد تا اعوجاج از مركز به سمت خارج ايجاد شود.

تمرين 8: اسم خود را بنويسيد و جلوه مقعر به آن بدهيد.
 3D Rotation4-11 ابزار

اين‌اب��زار به‌موضوع��ات گرافيک��ي ام��کان تغيي��ر ش��کل و دوران به صورت س��ه‌بعدي 
)چرخش‌فضايي( را مي‌دهد.

3D Rotation1-4-11 روش کار با ابزار
 3D Rotation 3 در جعبه ابزار دابل کليک کنيد تا کادر محاورهD Rotation 1- روي ابزار
مطابق شکل 54-11 باز شود. در اين کادر مي‌توانيد خصوصيات چرخش را به دلخواه تغيير 

دهيد.

        

  3D Rotation شکل 54-11 کادر محاوره

2- در اين کادر محاوره دو گزينه وجود دارد:
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Easy  )ساده(

Expert )حرفه‌اي( که داراي گزينه‌هاي بيشتري نسبت به Easy است.

3- منوي بازش��و Rotate from نقطه ش��روع چرخش را تعيين مي‌کند که داراي حالات 
زير است:

Mouse click )کليک ماوس(:	 محلي را که در آن جا کليک مي‌کنيد به عنوان نقطه 

چرخش قرار مي‌دهد )شکل 11-55(.

شکل 55-11 انتخاب Mouse click براي نقطه چرخش

Center Of Selection:	 مرکز شکل انتخاب شده را نقطه چرخش دوران قرار مي‌دهد 

)شکل 11-56(.

شکل 56-11 انتخاب Center Of Selection براي نقطه چرخش

Center Of Gravity )مرکز جاذبه(:	 هنگام دوران شکل‌هاي نامسطح، نقطه چرخش 

را در مرکز ثقل شکل قرار مي‌دهد )شکل 11-57(.

شکل 57-11 انتخاب Center Of Gravity  براي نقطه چرخش

نقطه چرخش را در گوش��ه سمت چپ و پايين ناحيه انتخاب شده،  Origin )مبدأ(: 	

براي دوران قرار مي‌دهد )شکل 11-58(.
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شکل 58-11 انتخاب Origin براي نقطه چرخش

  )Perspective(ميزان چرخش يا اعوجاج تصاوير به صورت پرسپکتيو Distance 4- در کادر
بزرگ و کوچک تنظيم مي‌شود )شکل 59-11(. براي ايجاد اعوجاج بيشتر، اعداد پايين‌تر از 

اين ميزان استفاده مي‌شود.

Distance شکل 59-11 تنظيم کادر

5- اکنون اش��اره‌گر ماوس به ش��کل + درآمده است، آن را روي قسمت موردنظر از شکل 
قرار داده، کليک و درگ کنيد. با حرکت اش��اره‌گر، پيش‌نمايش��ي از چرخش موضوع نمايش 
داده مي‌ش��ود. همان‌طور که مشاهده مي‌کنيد در امتداد محل کليک و حرکت ماوس خطي 
ايجاد مي‌ش��ود که به آن محور چرخش مي‌گويند. براي تعيين ميزان چرخش، کافي اس��ت 

اشاره‌گر را در طول اين محور جابه‌جا کنيد.
6- وقتي چرخش موضوع به دلخواه شما بود، كليد ماوس را رها کنيد.

 توج�ه: اگر در هنگام اس��تفاده از ابزار چرخش س��ه بعدي، کلي��د Shift را به‌طور 
همزمان فشار دهيد چرخش به صورت 45 درجه درمي‌آيد.

در حالت Expert، منوي بازشوي Project from به کادر محاوره 3D Rotation اضافه مي‌شود 
که توس��ط اين منو مي‌توانيد نقط��ه گريز موضوع را هن��گام دوران تنظيم کنيد. گزينه‌هاي 

موجود در اين منو عبارتند از:
Center Of Gravity ،Center Of Selection ،Mouse click و Origin كه توضيح داده ش��ده 

است. همچنين گزينه ديگري در اين منو به‌صورت زير قرار دارد:
 	x با انتخاب اين گزينه مي‌توانيد در کادرهاي مربوطه، مختصات :X/Y Coordinates
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و y نقطه گريز را به صورت عددي وارد کنيد.

تمرين 9: ش��کل 60-11 را رسم کرده، س��پس آن را دوران دهيد به طوري که 
نقطه دوران شکل در سمت چپ و پايين شکل قرار گيرد.

شکل  11-60
 Shadow 5-11 ابزار

از اين ابزار براي ايجاد س��ايه در پش��ت موضوعات يا متوني که به مس��ير تبديل شده‌اند، 
استفاده مي‌شود.

1-5-11 روش اعمال سايه
1- موضوعي را که مي‌خواهيد سايه‌دار شود، انتخاب کنيد.

2- ابزار Shadow را از جعبه ابزار انتخاب کرده )ش��کل 61-11( سپس اشاره‌گر ماوس را 
روي شکل قرار داده و به سمت پايين بکشيد تا سايه در زير شکل ايجاد شود

شکل 11-61

3- براي اعمال تنظيمات بيش��تر، روي ابزار Shadow داب��ل کليک کنيد تا کادر محاوره 
Shadow ظاهر شود )شکل 11-62(.

Shadow شکل 62-11 کادر محاوره
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4- در کادر محاوره Shadow ، منوي بازش��وي Type داراي چند حالت انتخابي به ش��رح 
زير است:

                         

 سايه با لبه‌هاي سخت                  سايه با لبه‌هاي نرم                    سايه با بزرگنمايي 

شکل 11-63

هن��گام انتخاب حالت Soft Edge مي‌تواني��د با درگ رنگ به کادر Stroke، رنگ پس‌زمينه 
سايه را تنظيم کنيد که به‌طور پيش‌فرض سفيد است.

همچنين با انتخاب حالت Zoom مي‌توانيد رنگ داخل س��ايه و خط دور س��ايه را تعيين 
کنيد.

5- با انتخاب يکي از حالت‌هاي Hard Edge يا Soft Edge منوي بازش��وي Fill داراي س��ه 
گزينه انتخابي مطابق شکل 64-11 خواهد شد:  

Fill شکل 64-11 حالات موجود در منوي بازشوي
Color:	 ب��ا انتخ��اب اين گزينه، س��ايه با رنگ تعيين ش��ده در کادر رنگي زير آن پر 

مي‌شود.
Shade:	 با استفاده از دکمه لغزنده يا وارد کردن عدد در کادر مربوطه، سايه‌اي ايجاد 

مي‌شود که رنگ آن تيره‌تر از موضوع اصلي است.
Tint:	 ب��ه کمک دکمه لغزنده ي��ا وارد کردن عدد در کادر مربوطه، س��ايه‌اي ايجاد 

مي‌شود که رنگ آن روشن‌تر از موضوع اصلي است.
6- با استفاده از دکمه لغزنده Scale يا وارد کردن عدد در کادر مربوطه، اندازه سايه از 1 

تا 200% تنظيم مي‌شود.

 توجه: مقدار کمتر از 100%، س��ايه‌اي کوچک‌تر از موضوع اصلي و مقدار بيشتر از 
100%، سايه‌اي بزرگ‌تر از موضوع اصلي ايجاد مي‌کند.
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7- در قس��مت Offset با تنظيمx  و y، محل قرار گرفتن س��ايه يا فاصله س��ايه از موضوع 
اصلي تنظيم مي‌شود.

8- روي دکمه OK کليک کنيد، سايه دلخواه روي موضوع اعمال مي‌شود.

  Subselectنكته: پس از اعمال يک سايه به موضوع مي‌توانيد با استفاده از ابزار 
و درگ ماوس سايه را به محل جديدي انتقال دهيد.

مثال 4: شکل 65-11 را رسم کرده، سپس سايه‌اي با لبه‌هاي سخت در آن ايجاد 
کنيد، به‌طوري که سايه از تصوير بزرگ‌تر و رنگ آن روشن‌تر از موضوع اصلي باشد. 

شکل 11-65

1- ابتدا شکل مورد نظر را انتخاب کنيد.
2- روي ابزار Shadow دابل کليک کنيد تا کادر محاوره Shadow باز شود.

3- در منوي بازشوType  نوع سايه را Hard Edge انتخاب کنيد.
4- در منوي بازشو Fill حالت Tint را انتخاب کرده و در کادر مقابل دکمه لغزنده عدد50 

را وارد کنيد.
5- در کادرScale  عدد 120 را وارد کنيد تا سايه از خود شکل بزرگ‌تر باشد.

6- در قسمت Offset  محل قرارگيري سايه را مشخص کنيد.
7- روي دکمهOK کليک کنيد، شکل به‌   دست آمده    مشابه     شکل66-11 خواهد شد.

Shadow شکل 66-11 نتيجه حاصل از اعمال ابزار
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تمرين 10: شکل‌هاي 67-11 را رسم کرده، به نوع سايه‌ها دقت کنيد.

شکل 11-67

 Smudge 6-11 ابزار
با استفاده از اين ابزار مي‌توان به موضوعات بعد، عمق يا جلوه حرکت نسبت داد. همچنين 

کاربرد ديگر اين ابزار، ايجاد سايه براي شکل و متن تبديل شده به مسير است.
 Smudge 1-6-11 روش کار با ابزار

1- ابزار Smudge را از جعبه ابزار انتخاب نماييد.
2- ب��راي اعمال تنظيمات بيش��تر روي ابزار Smudge دابل کلي��ک کنيد تا کادر محاوره 

Smudge مطابق شکل 68-11 ظاهر شود.

Smudge شکل 68-11 کادر محاوره

3- در اي��ن کادرمحاوره براي انتخاب رنگ دلخواه داخل و خطوط دور ش��کل، دو گزينه 
قرار دارد:

براي پر کردن رنگ داخل موضوع گرافيکي به‌کار مي‌رود به ش��رطي که  	 :Fill گزينه
قبلًا داخل موضوع با رنگ پر شده باشد.

براي رنگ‌آميزي خط��وط پيرامون موضوع گرافيک��ي رنگي به‌کار  	 :Stroke گزين�ه
م��ي‌رود. با اس��تفاده از اين گزين��ه مي‌توانيد رنگ‌هاي دلخ��واه را براي خطوط دور 

موضوع يا سايه انتخاب کنيد.
4- روي دکمه OK کليک کنيد.

5- اش��اره‌گر ماوس ش��بيه به دست مي‌شود، روي ش��کل کليک کرده و آن را به سمت 
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خارج درگ کنيد.
شکل 69-11 استفاده از اين ابزار را روي شکل نشان مي‌دهد.

    

Smudge شکل 69-11 اعمال ابزار

 توجه: براي افزودن س��ايه به اطراف ش��کل يا رسم س��ايه از مرکز شکل به سمت 

خارج، هنگام استفاده از ابزار Smudge کليد Alt را به‌طور همزمان نگه داريد.
مثال 5:

1- با استفاده از ابزار Ellipse يک بيضي مطابق شکل 70-11 رسم کنيد. 
2- روي ابزار Smudge از نوار ابزار دابل کليک کنيد.

3- ب��راي اي��ن که رنگ داخ��ل موضوع را قرمز کني��د، در قس��متFill  در کادر محاوره  
Smudgeرنگ قرمز را برگزينيد.

4- براي اين که رنگ خطوط دور ش��کل س��بز شود در قس��متStroke  در کادر محاوره 
Smudge رنگ سبز را انتخاب کنيد.

5- روي دکمهOK  کليک کنيد.
6- اش��اره‌گر ماوس ش��بيه ‌دست مي‌شود، آن‌را روي ش��کل برده و به سمت خارج درگ 

کنيد )شکل 11-71(.

                              

Smudge شکل 70-11                              شکل 71-11 اعمال ابزار   

تمرين 11: ش��کل 72-11 را رس��م کرده، سپس به وس��يله ابزار Smudge به آن 
بعُد دهيد.
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شکل 72-11 رسم شکل
 Bend 7-11 ابزار

اين ابزار در ش��کل‌ها و مسيرهاي رسم ش��ده، تاب خوردگي ايجاد مي‌کند، به‌طوري که 
پاره‌خط‌هاي مسير به سمت داخل يا خارج  منحرف مي‌شوند.

Bend 1-7-11 تنظيم گزينه‌هاي ابزار

1- ابزار Bend را از نوار ابزار Xtra tools انتخاب کنيد )شکل 11-73(.

Bend   شکل 73-11 انتخاب ابزار

2- روي اب��زارBend  دابل کلي��ک کنيد تا کادر محاوره Bend مطابق ش��کل 74-11 باز 
شود.

Bend شکل 74-11 کادر محاوره

Bend 2-7-11 روش استفاده از ابزار
1- شكل 75-11 را رسم كنيد.

2- روي ابزارBend  دابل کليک کنيد و با حرکت دکمه لغزنده Amount، ش��دت عملکرد 
اين ابزار را روي شکل تعيين کنيد.

3- اش��اره‌گر ماوس )+( را روي ش��کل انتخاب شده قرار دهيد، سپس ماوس را به سمت 
پايين درگ کنيد اکنون لبه‌هاي ش��کل گرد مي‌ش��ود )شکل 76-11- الف(. اگر ماوس را به 

سمت بالا درگ کنيد، لبه‌هاي شکل به صورت تيز درمي‌آيند )شکل 76- 11- ب(.
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 ماوس به سمت بالا کشيده شده                  ماوس به سمت پايين کشيده شده

Bend شکل 75-11 رسم و انتخاب شکل                شکل 76-11 نتايج حاصل از اعمال ابزار

 مثال 6: شکل 77-11 را ايجاد کنيد.
1- ابتدا با ابزار Ellipse و نگه داشتن کليد Shift يک دايره رسم کرده و داخل آن را رنگ 

کنيد )شکل 11-78(.

            

     شکل 77-11               شکل 78-11 رسم دايره

2- ابزار Bend را انتخاب کنيد.
3- با ماوس روي مرکز دايره کليک کرده آن را به س��مت پايين درگ کنيد تا به ش��کل 

موردنظر برسيد.
 Roughen 8-11 ابزار

اين ابزار باعث شکستگي خطوط تشکيل دهنده شکل مي‌شود و مسيرهاي هموار را نوک 
تيز و ناهموار مي‌سازد.

Roughen 1-8-11 تنظيم گزينه‌هاي ابزار

1- ابزار Roughen را از جعبه ابزار انتخاب نماييد.
2- روي ابزار Roughen دابل کليک کنيد تا کادر محاوره Roughen مطابق شکل 11-79 

باز شود.
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Amount  شکل 80-11 نتيجه استفاده از تنظيمات دکمه لغزنده     Roughen شکل 79-11 کادر محاوره    

3- روي دكمهOK  کليک کنيد.
  Roughen 2-8-11 روش استفاده از ابزار

 1- ابت��دا ش��کل دلخواه��ي رس��م کني��د، س��پس اب��زارRoughen  را انتخ��اب کني��د 
)شکل 11-81(.

2- با استفاده از ماوس، ابزار Roughen را در طول موضوع بکشيد.

                    	            	                             

   Roughen  شکل 82-11 نتيجه استفاده از                شکل 81-11 رسم شکل  	

تمرين 12: اشکال 83-11را با استفاده از ابزار Roughen رسم کنيد.

شکل 11-83 

  )Perspective( 9-11 ايجاد پرسپکتيو
 گاهي اوقات لازم است براي واقعي جلوه دادن اشياء يا نشان دادن عمق و حجم در ترسيم‌هاي 

دو بعدي از پرسپکتيو استفاده کنيم.
در FreeHand MXa به سادگي مي‌توانيد فضاي سه بعدي )شبکه شطرنجي سه بعدي( يا 

پرسپکتيو را در يک محيط دو بعدي بازسازي کنيد.
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بدين منظور مراحل زير را دنبال کنيد: 
1- گزينه View→Perspective Grid→Show را انتخاب کنيد.

2- ش��کل يا متن موردنظ��ر را انتخاب کرده و اب��زار پرس��پکتيو را از جعبه‌ابزار انتخاب 
کنيد.

3- اش��اره‌گر را روي اش��ياي موردنظر قرار داده و از کليدهاي جهت‌دار صفحه کليد براي 
قراردادن اش��ياء روي محورهاي پرسپکتيو استفاده کنيد. کليد جهت‌دار را پايين نگه داشته، 

سپس روي موضوع درگ کنيد )شکل 11-84(.

شکل 11-84

زيرمنوي Perspective شامل گزينه‌هايي است كه در جدول 1-11	 آمده است:

  Alt توجه: براي کپي کردن موضوع در حين اس��تفاده از ابزار پرس��پکتيو از کليد 

استفاده کنيد.
جدول 11-1

Show.نماي پرسپکتيو را فعال مي‌سازد

Define Grid)11-85 تنظيم و ويرايش خطوط شبکه و ايجاد نماي جديدي از شبکه )شکل

Previous.براي تعويض نماها به کار مي‌رود

Remove  Perspective.نماي پرسپکتيو شئ را حذف مي‌کند

 Release With
Perspective

جلوه پرسپکتيو را براي موضوع تثبيت مي‌کند به طوري‌که بعد از اجراي اين فرمان پرسپکتيو 
داده شده به شئ، قابل ويرايش نخواهد بود.
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Define Grids شکل 85-11 کادر محاوره

 Extrude 10-11 ابزار
با اس��تفاده از اين ابزار مي‌توان اشکال ايجاد ش��ده در FreeHand را به صورت سه بعدي 

نمايش داد. 

شکل 11-86

به منظور سه بعدي کردن اشکال مراحل زير را انجام دهيد:
1- ابزار Extrude را از جعبه ابزار انتخاب نماييد.

2- اش��اره‌گر ماوس را روي ش��کلي که قرار است س��ه بعدي شود قرار داده و آن را درگ 
كنيد.

شکل 11-87

 Modify→Extrude→Remove نكته: به‌منظور حذف حالت سه بعدي شکل، گزينه 
را انتخاب نماييد.

1-10-11 ويرايش شکل سه بعدي



Free Hand پیمانه مهارتی : کاربر
333واحد کار یازدهم: توانایی استفاده از جلوه های ویژه  

به منظور ويرايش جلوه س��ه بعدي اشکال از ابزار Extrude استفاده مي‌شود. اين ابزار دو 
حالت ويرايش دارد: 

حالت 1: امکان ويرايش محل، عمق و نقطه تلاقي را فراهم ميك‌ند.
حالت 2: امکان چرخش اشکال سه بعدي را فراهم مي‌نمايد.  

مث�ال كاربردي: فاي��ل Project مثال كاربردي واحد كار قبل را باز كنيد و مراحل زير را 
انجام دهيد:

1- وارد صفحه ايجاد شده براي كارت ويزيت شويد )شكل 88-11( و نشانه طراحي شده 
در صفحه آرم را در نقطه‌اي از صفحه درج كنيد.

2- آرم را انتخ��اب و گروه‌بن��دي كنيد و از پانل Transform زبانه Scale، نش��انه را %30 
بزرگ‌تر كنيد. اکنون با استفاده از پانل Align  آن را به وسط صفحه منتقل کنيد.

3- س��پس آرم را خاكستري كرده و با اس��تفاده از جلوه Transparency آن را به صورت 
محو در وسط صفحه قرار دهيد. 

 

شكل 11-88

4- كي كپي از آرم ايجاد كرده، آن را با Scale 70% كوچ‌كتر كنيد و در جاي مش��خص 
شده در شكل 88-11 قرار دهيد.

5- طراحي كارت ويزيت به پايان رسيد، سعي كنيد كارت‌هاي زيباتري طراحي كنيد.
واژه‌نامه
Convexمحدب

Edgeلبه

Expertمتخصص
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Expandگسترش

Envelopeپوشش 

Fisheyeچشم ماهي

Glowبرافروختگي

Raggedناصاف، ناهموار

Raisedبرجسته، برآمده 

Releaseرهايي، واگذاري كردن

Roughenزبرکردن، خشن شدن

Sketchطرح ساده

Sharpenنوک تيز کردن 

Smudgeلکه، سياه شدن

خلاصه مطالب 
جلوه Bend	 در شکل‌ها و مسيرهاي رسم شده، پيچ و خم و اعوجاج ايجاد مي‌کند.

جلوه Duet	 يک يا چند مدل مش��ابه از ش��کل س��اخته، آن‌ها را ب��ا يکديگر ترکيب 
مي‌کند تا يک شکل پيچيده واحد ايجاد نمايد.

جل��وه Expand Path	 مس��ير را په��ن نم��وده و طرح کلي ش��کل حاصل��ه را ايجاد 
مي‌نمايد.

با افزودن نقاط تصادفي جديد، ظاهر ش��کل را تغيير داده و ظاهري  	 Ragged جل��وه
ناهموار، صاف يا يکدست به شکل مي‌دهد.

جلوه Bevel 	 باعث مي‌ش��ود لبه‌هاي ش��کل به حالت برجسته نمايش داده شوند و با 
جلوه Emboss ‌مي‌توان شکل يا متن را به صورت برجسته نمايش داد. 

جلوه Blur جزييات تصوير را تيره و تار مي‌کند.	 
جل��وه Sharpen با تنظيم Contrast	 پيکس��ل‌هاي همجوار در ش��کل، وضوح يا تيزي 

لبه‌هاي شکل را افزايش مي‌دهد.
با استفاده از جلوه Transparency	 مي‌توان تمام يا قسمتي از رنگ داخل شکل يا خط 

دور شکل را به صورت واضح يا نيمه کدر نمايش داد.
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فرمان Envelope امکان فرم‌دهي به تصاوير و نوشته‌ها را فراهم مي‌نمايد. 	
با اس��تفاده از ابزار Fisheye Lens	 مي‌توان به موضوعات انتخاب ش��ده، حالت تقعر يا 

تحدب داد.
از ابزار Shadow	 براي ايجاد س��ايه در پش��ت موضوعات يا متوني که به مسير تبديل 

شده‌اند، استفاده مي‌شود.
مي‌توان به موضوعات بعد، عمق يا جلوه حرکت نس��بت  	 Smudge با اس��تفاده از ابزار
داد. همچنين کاربرد ديگر اين ابزار، ايجاد س��ايه براي ش��کل و متن تبديل شده به 

مسير است.
باعث شکس��تگي خطوط تش��کيل دهنده شکل مي‌شود و مسيرهاي  	Roughen  ابزار

هموار را نوک تيز و ناهموار مي‌سازد.
با ابزار Extrude مي‌توان به اشکال ايجاد شده در FreeHand، جلوه سه بعدي داد.	
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آزمون نظري
درستي يا نادرستي گزينه هاي زير را تعيين کنيد.

 1- براي واقعي جلوه دادن موضوعات يا نشان دادن عمق و حجم در ترسيمات دو بعدي از ابزار
3D Rotation استفاده مي‌کنيم.

2- فرمان Envelope امکان فرم‌دهي به تصاوير و نوشته‌ها را فراهم مي‌نمايد.
3- جلوه Duet يک يا چند مدل مشابه از شکل ساخته، آن‌ها را با يکديگر ترکيب مي‌کند 

تا يک شکل پيچيده واحد ايجاد كند.
4- جلوه Blur در شکل‌ها و مسيرهاي رسم شده، پيچ و خم و اعوجاج ايجاد مي‌کند.

معادل گزينه هاي سمت‌راست را از ستون سمت‌چپ انتخاب کرده و مقابل هر عبارت بنويسيد.

Bend جلوه                            	5- جزييات تصوير را تيره و تار مي‌کند.             
  Bevel6- در شکل‌ها و مسيرهاي رسم شده، پيچ‌و‌خم و اعوجاج ايجاد مي‌کند.      جلوه
  Emboss 7- باعث مي‌شود لبه‌هاي شکل به حالت برجسته نمايش داده شوند.      جلوه

Blur 8- مي‌توان شکل يا متن را به صورت برجسته نمايش داد.                      جلوه
گزينه صحيح را انتخاب کنيد.

9- هنگام استفاده از ابزار3D Rotation   نقطه چرخش در کدام قسمت تعيين مي‌شود؟
Expert -د             Rotate from -ج 	Easy -ب                 	Distance -الف

10- از کدام گزينه براي محدب کردن اشکال استفاده مي‌شود؟
Shadow -د         	Fisheye Lens -ج 	Smudge -ب 	3D Rotation -الف

11- شکل زير توسط چه ابزاري طراحي شده است؟
Roughen -الف

 Bend -ب
Smudge -ج

Spiral -د
12- با اس��تفاده از کدام جلوه مي‌توان تمام يا قس��متي از رنگ داخل ش��کل يا خط دور 

شکل را به صورت واضح يا نيمه کدر نمايش داد؟
Emboss -د 	     Sharpen -ج	 Transparency-ب 	 Blur -الف
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13- ب��ه منظور اعمال كي مس��ير دلخواه روي تصوير به‌عنوان ي��ک Envelope  از کدام 
گزينه استفاده مي‌کنيم؟

Paste as envelope -د        Save as preset -ج       Show map -ب    Release -الف
در جاي خالي عبارت مناسب را بنويسيد.

14- جل��وه  ........................... مس��ير را په��ن نم��وده و طرح کلي ش��کل حاصله را ايجاد 
مي‌نمايد.

15- جلوه .............................. با افزودن نقاط تصادفي جديد، ظاهر ش��کل را تغيير داده و 
ظاهري ناهموار، صاف يا يکدست به شکل مي‌دهد.

16- جلوه ......................... نمايي از ش��کل را شبيه‌سازي مي‌کند که به نظر مي‌رسد شکل 
مورد نظر با مداد طراحي شده است.

به سؤالات زير پاسخ تشريحی دهيد.

17-  ابزار Roughen چه عملي انجام مي‌دهد؟
18-  تفاوت نوعHard Edge  و Zoom هنگام استفاده از ابزار Shadow چيست؟

19-  در چه مواقعي از ابزارهاي زير استفاده مي‌کنيد؟
  Perspective-الف
3D Rotation -ب

Roughen -ج
20- از ابزار Extrude به چه منظور استفاده مي‌شود؟

آزمون عملي
1- تصوير مقابل را با استفاده از ابزارSmudge  طراحي کنيد.
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2- با استفاده از ابزار Fisheye Lens شکل روبه‌رو را طراحي کنيد.

3- شکل روبه‌رو را رسم کرده، سپس توسط 3D Rotation  تصوير ب را ترسيم کنيد.

 Expand4- در ش��کل ابتدا تصوير س��مت چپ را طراحي کرده سپس با استفاده از جلوه
Path  آن را به شکل سمت راست تبديل کنيد.

  Ragged5- در ش��کل روبه‌رو تصوير سمت چپ را طراحي کرده سپس با استفاده از جلوه
آن را به شکل سمت راست تبديل کنيد.

6- با استفاده از ابزار Shadow شکل‌هاي زير را رسم ک

7- شكل زير را با استفاده از ابزار Envelope ترسيم كرده سپس آن را سه بعدي كنيد.
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كليات
با پيچيده‌تر شدن كار هنري نياز به روش‌هاي ديگري براي سازمان‌دهي موضوعات پيش 
 Chart و Graphic Hose و ابزارهاي Style ،Library ،Layers مي‌آيد. در اين واحد کار پنل‌هاي

Tool بررسي مي‌شوند.

 )Layers( 1-12 لايه‌ها
در برنامه FreeHand MXa هنگام ترس��يم طرح‌هاي موردنظر براي آس��ان‌تر کردن کار با 
موضوع‌هاي ترس��يمي، آن‌ها را با اس��تفاده از لايه‌ها از يکديگر مجزا مي‌کنند. اين کار شبيه 
به اين اس��ت که هر موضوع و شئ ترس��يمي در يک صفحه مجزا رسم شود و صفحه‌ها روي 

يکديگر قرار گيرند.

Layer شکل 1-12 مجزاسازي موضوع ترسيمي در پنل

 Layers 1-1-12 کار با پنل

پن��ل Layers، هم��ه لايه‌ه��اي موجود در س��ند ج��اري را نمايش داده و ام��کان اضافه، 
نس��خه‌برداري، مرتب کردن و حذف لايه‌ها را فراهم مي‌کند. با استفاده از اين پنل مي‌توانيد 

لايه‌ها را انتخاب، ايجاد و حذف کنيد.
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  Layersنمايش پنل
براي ظاهر کردن پنل به يکي از روش‌هاي زير عمل کنيد:

از نوار ابزار Main روي دکمه  کليک کنيد.	
از طريق منوي Window، مسير Window→Layers را اجرا کنيد.	
كليد ميانبر F2 را بفشاريد.	

همان‌طورکه در شکل 1-12 نشان داده شده است، در يک سند به صورت پيش‌فرض سه 
لايه وجود دارد که عبارتند از:

لايه Foreground )پيش‌زمينه(
ب��ه لايه‌هايي که در بالاي خط افق��ي جدا کننده قرار مي‌گيرند، لاي��ه پيش‌زمينه گفته 

مي‌شود. موضوع‌هاي ترسيمي که در اين لايه‌ها قرار دارند؛ قابل چاپ هستند.
لايه Guides )خطوط راهنما(

در اين لايه خط‌هاي راهنما که با استفاده از خط‌کش يا ويرايشگر خطوط راهنما در سند 
ايجاد ش��ده‌اند، قرار مي‌گيرند. همچنين مسيرهايي که به خط‌هاي راهنما تبديل شده‌اند، در 
اين لايه قرار دارند )شکل 2-12(. در بخش10-1-12 چگونگي تبديل مسير به خط راهنما 

توضيح داده مي‌شود.
موضوع‌هايي که در لايه Guides	 قرار دارند، چه بالاي خط جدا کننده باش��ند يا در 

پايين آن قرار گيرند چاپ نمي‌شوند.

Guides شکل 2-12 مسير تبديل شده به خط راهنما با استفاده از لايه

لايه Background )پس‌زمينه(
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اي��ن لايه ب��ه صورت پيش‌فرض در زير خ��ط جداکننده قرار مي‌گي��رد و غير قابل چاپ 
است.

 توجه: با درگ و جا‌به‌جايي لايه‌هاي انتخاب ش��ده و انتقال آن‌ها به زير خط جدا 

کننده، يک لايه Background )پس‌زمينه‌( جديد ايجاد مي‌شود.

در برنامه FreeHand	 هر شئ طراحي‌ شده در سند، درون لايه قرار مي‌گيرد، همچنين 
مي‌توانيد مجموعه‌اي از اشياء را در يک لايه قرار دهيد.

2-1-12 ايجاد لايه جديد

با اس��تفاده از پنل Layers مي‌توانيد يک لايه جديد ايجاد کنيد و موضوع ترس��يمي را در 
لايه ايجاد شده قرار دهيد.

 توجه: مي‌توانيد قبل يا بعد از ترسيم موضوع‌هاي گرافيکي، لايه‌هاي مورد نيازتان 

را ايجاد کنيد.
براي ايجاد لايه جديد مراحل زير را انجام دهيد:

1- پنل Layers را باز كنيد.
2- منوي کنترلي پنل لايه را انتخاب کرده و روي گزينه New کليک کنيد.

3-1-12 تغيير نام لايه 

براي تغيير نام لايه به روش زير عمل کنيد:
1- در پنل Layers روي نام لايه مورد نظر دابل کليک کنيد.

2- نام جديد را تايپ و کليد Enter را فشار دهيد يا با ماوس روي پنل كليك كنيد.

 نكته: نام لايه Guides تغيير نمي‌کند.

 Fish در لايه‌اي با نام  C:0 و  M:98 ، Y:100 ، K:0 مثال 1: ش��کل 3-12 را با رنگ 
رسم کرده و فايل را با نام Example12 -1 ذخيره کنيد. 

1- در صفحه کاري مورد نظر، ابتدا پنل Layers را فعال کنيد.
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2- يک لايه جديد از طريق منوي کنترلي پنل ايجاد کنيد )شکل 12-4(.

                             

شکل 3-12                                            شکل 4-12 ايجاد لايه جديد

3- روي نام لايه جديد دابل کليک کرده و نام Fish را درج و کليد Enter را فشار دهيد.
4- شکل 3-12 را رسم و فايل را با نام گفته شده ذخيره کنيد.

4-1-12 انتخاب لايه

در پنل Layers، به لايه‌اي که انتخاب ش��ده و در س��مت راست آن علامت  قرار دارد، 
لايه فعال )Active( مي‌گويند. مراحل کار در انتخاب لايه به شرح زير است:

1- مس��ير Edit→Select→None را اجرا کرده يا کليد Tab را فش��ار دهيد تا ش��يئي در 
وضعيت انتخاب نباشد.

2- روي نام لايه کليک کرده تا علامت  را در سمت راست لايه مشاهده کنيد.

 نكته: اش��ياء و موضوع‌هايي که  ترسيم مي‌کنيد يا در سند Import مي‌شوند؛ در 
لايه Active )فعال( قرار مي‌گيرند.

با نگه داش��تن کليدAlt 	 همراه با کليک روي نام لايه مورد نظر، تمامي اش��ياي لايه 
فعال )Active( در حالت انتخاب قرار مي‌گيرند.

5-1-12 قفل و عدم قفل لايه

در پنل Layers براي محافظت اشياء درون لايه‌ها از تغييراتي که بر ساير لايه‌ها در هنگام 
نمايش محتويات آن‌ها انجام مي‌شود؛ روي علامت  )قفل باز( که در سمت چپ لايه قرار 

دارد کليک کنيد تا لايه قفل شود. بر همين اساس تعاريف زير مطرح مي‌شود:
لايه قفل شده )Lock(: لايه‌اي که در سمت چپ آن علامت 	 قرار دارد.

لايه قفل نشده )Unlock(: لايه‌اي که در سمت چپ آن علامت	 قرار دارد .
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6-1-12 نمايش و پنهان کردن محتويات لايه

 يکي ديگر از امکانات پنل Layers، پنهان کردن محتويات لايه‌ها بدون نياز به حذف لايه‌ها است 
)شکل 12-5(.

شکل 5-12 پنهان کردن محتويات لايه

روش اجرا:
1- لايه مورد نظر را انتخاب کنيد.

2- روي‌علامت P در س��مت چپ لايه کليک کنيد تا‌ علامت ‌برداش��ته ‌شود و محتويات‌ 
لايه ‌پنهان ‌شود.

کليک مجدد سبب نمايش و آشكار شدن )Visible( لايه مي‌شود.	

 نكته: نگه داش��تن همزمان کليد Ctrl و کليک روي اولين س��تون سمت چپ در 
پنل Layers تمام لايه‌هاي پنل را پنهان مي‌کند.

اگر لايه فعال پنهان باش��د؛ موضوع گرافيکي جديدي که ايجاد مي‌ش��ود نيز نش��ان داده 
نمي‌شود و براي نمايش آن بايد لايه در حالت Visible )آشكار( قرار گيرد.

 توجه: براي ويرايش لايه‌ها، بايد آن‌ها را در وضعيت قفل نشده )Unlock( و نمايش 

)Visible( قرار دهيد.

7-1-12 ايجاد نسخه کپي از لايه موجود

با استفاده از پنل Layers و منوي کنترل آن مي‌توانيد از لايه موجود در پنل، يک نسخه 
کپي تهيه کنيد. روش کار به ترتيب زير است )شکل 12-6(:
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Layers شکل 6-12 منوي کنترلي پنل

1- مس��ير Edit→Select→None را اجرا کرده يا کليد Tab را فش��ار دهيد تا ش��يئي در 
وضعيت انتخاب نباشد.

2- روي نام لايه کليک کنيد.
3- از منوي کنترل در پنل لايه گزينه Duplicate را برگزينيد.

 نكته: لايه Guides حذف نمي‌شود.

تمرين 1:
1- با اس��تفاده از نوار ابزار Main،پنل Layers را آش��کارکنيد و شکل7-12 را در لايه‌اي به نام 

Rainbow1 رسم کرده و آن را با نام T12-1 ذخيره کنيد.

شکل 12-7

2- ي��ک لايه مش��ابه لايه Rainbow1 با نام Rainbow2 ايج��اد، آن را قفل کرده و فايل را 
ذخيره کنيد.

3- لايه Rainbow1 را حذف کنيد.
8-1-12 جابه‌جايي لايه‌ها و محتويات آن‌ها

ب��راي ويراي��ش لايه‌ها مي‌توانيد ترتيب قرار گرفتن آن‌ه��ا را در پنل Layers تغيير دهيد 
يا اش��ياء يک لايه را به لاي��ه ديگر منتقل کنيد و موضوع‌ه��اي گرافيکي لايه‌هاي يک فايل 

FreeHand را کپي کرده و در فايل ديگر، Paste کنيد.
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 توج�ه: اگ��ر گزين��ه Remember layer info در زبان��ه General از کادر مح��اوره

Preferences  انتخاب شده باشد، اطلاعات لايه‌ها در زمان کپي محتويات آن‌ها حفظ مي‌شود 

)شکل 12-8(.

FreeHand در زمان کپي محتويات آن‌ها در سندهاي ديگر ،FreeHandشکل 8-12 تنظيم مربوط به حفظ اطلاعات لايه‌هاي يک سند

تغيير ترتيب لايه‌ها 	
1- در پنل Layers، نام لايه مورد نظر را انتخاب كنيد.

2- نام لايه را به مكان دلخواه در ليست لايه‌ها درگ كنيد.
3- با رها كردن ماوس، نام لايه از مكان قبلي حذف و در محل جديد پنل Layers ظاهر 

مي‌شود. در اين صورت موقعيت تمام اشياء در سند تغيير ميك‌ند.
انتقال شئ به لايه مورد نظر 	

1- شئ موردنظر را كه در شكل 9-12 تصوير ماه است، انتخاب كنيد. در اين صورت لايه 
مربوط به شئ انتخاب شده در پنل Layers به طور خودكار انتخاب مي‌شود.

2- لايه مقصد )لايه‌اي كه مي‌خواهيد ش��ئ به آن‌جا منتقل شود( را انتخاب كنيد. بدين 
ترتيب شئ مزبور به لايه جديد انتقال ميي‌ابد. 

   

  شکل 9-12 انتخاب شئ                                     شکل 10-12 انتقال شئ به لايه موردنظر

  Preferencesاگر جابه‌جايي انجام نشد، بررسي کنيد که طبق شکل 11-12در كادر محاوره
گزين��ه Clicking on a layer name moves selected objects در زبانه Panels در حالت انتخاب 
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قرار گيرد تا جا‌به‌جايي اشياء با انتخاب نام لايه انجام شود.
ه��اي گرافيکي مي‌توانيد آن‌ه��ا را جا‌به‌جا  همان‌طورک��ه گفته ش��د با درگ موضوع‌	

کنيد.

شکل 11-12 تنظيم مربوط به جابه‌جايي لايه‌ها با انتخاب نام لايه

 توجه: نمي‌توان موضوعات را به كي لايه قفل شده، انتقال داد.

 نكت�ه: اگ��ر در زمان جابه‌جاي��ي موضوعات گرافيکي، اش��يايي را که در لايه‌هاي 
جداگانه هس��تند،  با يکديگر Group کنيد، در اين صورت اش��ياء Group شده به لايه فعال 

منتقل مي‌شوند.

 توج�ه: انتخاب گزين��ه Remember layer info در زبان��ه General از کادر محاوره 

 Join شده به لايه‌هايي مي‌شود که قبل از Split و   Ungroup سبب بازگشت اشياء Preferences

و Group  شدن در آن قرار داشتند.

Guides 9-1-12 کار با لايه

همان‌طور که گفته شد، خط‌هاي راهنما در لايه Guides قرار مي‌گيرند. با استفاده از پنل 
layers مي‌توانيد مسير انتخابي را به خط راهنما و بالعکس تبديل کنيد.

تبديل مسير )باز يا بسته( به خط راهنما  	

1- مسير مورد نظر را انتخاب کنيد )شكل 12-12(.
2- روي لايه Guides کليک کنيد تا مس��ير، رنگ خط راهنما را به خود بگيرد و مس��ير 

انتخابي نيز با انتقال به لايه Guides، به خط راهنما تبديل شود )شكل 12-13(.
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              شکل 12-12 يک مسير بسته	                شکل 13-12 مسير تبديل شده به خط راهنما

تبديل خط راهنما به مسير معمولي 	

1- روي مس��ير تبديل ش��ده به خط راهنما يا خط راهنماي ايجاد شده با خط‌کش، دابل 
کليک کنيد.

2- در کادر مح��اوره Guides روي دکم��ه Release کليک کنيد تا خط راهنما به مس��ير 
تبديل شود و در لايه معمولي قرار بگيرد.

10-1-12 ادغام لايه‌ها 

پس از پايان کار در FreeHand مي‌توانيد لايه‌ها را با هم يکي کنيد.
روش اجرا:

1- لايه يا لايه‌هاي مورد نظر را در پنل Layer انتخاب کنيد.
 	Shift ب��راي انتخ��اب بيش از يک لايه  همزم��ان با کليک روي لايه‌ه��ا از کليدهاي
يا Ctrl اس��تفاده کنيد؛ کليد Shift، لايه‌هاي پش��ت س��رهم و کلي��د Ctrl، لايه‌هاي 

غيرمتوالي را انتخاب مي‌کند.   
2- گزينه Merge Selected Layers را  از منوي کنترلي پنل Layers برگزينيد.

 توج�ه: در هنگام ادغام لايه‌ها، پايين‌ترين لايه انتخابي به عنوان لايه ادغام ش��ده 

در نظر گرفته مي‌شود.

Foreground ادغام لايه‌هاي 
ب��راي ادغام محتويات لايه‌هاي بالاي خط جدا کننده با لايه Foreground پس از انتخاب 
لايه‌ها به روش��ي که در مطالب قبل گفته ش��ده، روي گزينه Merge Foreground Layers، از 
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منوي کنترل پنل Layers کليک کنيد.

 نكته: لايه Guides با ساير لايه‌ها ادغام نمي‌شود.

 مثال 2: س��ه موض��وع گرافيکي تصوير آدم��ك، ماهي و س��تاره را به ترتيب در 
لايه‌هاي��ي با نام‌هاي fish ،human و Foreground رس��م کرده و آن‌ه��ا را در لايه Fish ادغام 

کنيد.
1- ابتدا در صفحه کاري ايجاد ش��ده، لايه‌اي با نام human رس��م کرده و شکل آدمک را 

در آن رسم کنيد.
2- در لايه‌اي که به نام fish ايجاد کرده‌ايد، ش��کل ماهي و در لايه Foreground س��تاره 

صورتي رنگ را ترسيم کنيد.
3- لاي��ه fish را ب��ه عنوان لايه فعال انتخاب کرده و با فش��ردن همزمان كليد Shift روي 

لايه‌هاي Foreground و human کليک کنيد.
4- با استفاده از گزينه Merge Foreground Layers، از منوي کنترلي پنل Layers لايه‌هاي 

Foreground )پيش‌زمينه( را با يکديگر ادغام کنيد.

 

 Foreground شکل 14-12 ادغام لايه‌هاي

تمرين 2: 
 ،Animal 1 1- ش��کل‌هاي 15-12، 16-12و 17-12را ب��ه ترتي��ب در لايه‌هايي با ن��ام

Animal 2 و Animal 3 ايجاد کنيد.

2- محتويات لايه Animal 1 را به لايه Animal 2 منتقل کنيد.
3- لايه‌هاي Foreground را ادغام کنيد.

4- شکل 18-12 را به خط راهنما تبديل کنيد.
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شکل 15-12          شکل 16-12           شکل 17-12            شکل 12-18

11-1-12 قابل چاپ کردن يا غيرقابل چاپ کردن لايه

همان‌ط��ور که در بخش 1-12 گفته ش��د جابه‌جايي لايه‌ها به بالا و زير‌خط جدا کننده؛ 
به ترتيب س��بب چاپ شدن محتويات آن‌ها و عدم چاپ موضوع‌هاي گرافيکي قرار گرفته در 

لايه موردنظر مي‌شوند.
ايجاد لايه چاپي 	

1- در پنل Layers با درگ ماوس لايه غيرچاپي را به بالاي خط جداكننده بكشيد.
2- پ��س از انتقال لايه ب��ه بالاي خط جداكننده، تمام اش��ياي موجود در آن قابل چاپ 

مي‌شوند )شكل 12-19(.

شکل 19-12 ايجاد لايه چاپي

ايجاد لايه غيرچاپي
1- در پنل Layers با درگ ماوس لايه موردنظر را به زير خط جداكننده بكشيد.

2- پس از انتقال لايه به زير خط جداكننده، تمام اش��ياي موجود در آن كم‌رنگ ش��ده و 
چاپ نمي‌شوند )شكل 12-20(.
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شکل 20-12 ايجاد لايه غيرچاپي

12-1-12 حالت نمايش چاپي يا خطي محتويات لايه

علامت دايره‌اي که در دومين س��تون سمت چپ پنل Layers قرار دارد )شكل 21-12(؛ 
محتويات لايه را در حالت نمايش يا Preview )چاپي(  و حالت خطي )KeyLine(  نشان 
مي‌دهد. اين علامت دايره‌اي به صورت دو وضعيتي اس��ت و کليک روي آن س��بب تغيير آن 

بين دو حالت مي‌شود.

Keyline شکل 21-12 نمايش لايه به صورت

13-1-12 تغييررنگ لايه‌ها

همان‌طورکه در ش��کل 22-12 نش��ان داده شده است؛ براي تش��خيص آسان‌تر لايه‌ها و 
محتوي��ات آن‌ها و ايجاد تمايز بين لايه‌ها، مي‌توانيد براي ه��ر لايه، رنگي را در نظر بگيريد. 
ب��ه اي��ن صورت كه رنگ را از پنل‌هاي رنگ يا اب��زار رنگ‌آميزي درگ كرده و كليد ماوس را 
روي لاي��ه موردنظر رها كنيد. بدين ترتيب رنگ موضوعات ترس��يمي نيز به رنگ لايه تغيير 

ميك‌ند.
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شکل 12-22
1 Library2-12 پنل

س��مبل‌ها )Symbols( و صفحه‌هاي اصلي )Master Page( براي استفاده در بين سندهاي 
FreeHand، در پنل Library نگهداري مي‌شوند. موارد کاربرد پنل Library به طور خلاصه به 

شرح زير است:
ايجاد سمبل از اشياء و متن يا سمبلي ترکيبي از متن و شئ	

) 	Symbols(‌ حذف و اضافه کردن سمبل‌ها يا نمادها
وارد ک��ردن و ص��ادر ک��ردن س��مبل‌ها و صفحه‌ه��اي اصلي در صفحه‌هاي س��ند  	

FreeHand

بااس��تفاده از پن��ل Library	 مي‌توانيد بي��ش ‌از يک نمونه از س��مبل‌موردنظر را در 
سندجاري به‌کار ببريد. اين نمونه‌ها به‌صورت جداگانه و تکي با ويژگي‌هاي متفاوت، 

در بين سندهاي FreeHand قابل انتقال هستند.
	Library 1-2-12 نمايش پنل

براي نمايش پنل Library به يکي از موارد زير عمل کنيد:
مسير Window→Library را پيگيري کنيد.	
در نوار ابزار Main، روي آيکن  )Library(، کليک کنيد.	

در اين صورت پنل Library مطابق با شكل 23-12 باز مي‌شود.

1- کتابخانه
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Libraryشکل 23-12 پنل

2-2-12 ايجاد يک سمبل جديد

همان‌طورکه گفته ش��د، مي‌توانيد از يک موضوع گرافيک��ي، متني يا هر دو آن‌ها که در 
يک گروه قرار گرفته‌اند، براي ايجاد سمبل استفاده کنيد و با Duplicate سمبل‌هاي موجود، 

نمونه‌هايي با ويژگي مشابه نمونه اصلي داشته باشيد.
روش اجرا:

براي ايجاد س��مبل جديد مطابق شکل 24-12، پس از نمايش پنل Library موارد زير را 
اجرا کنيد:

1- شيئي را که مي‌خواهيد از آن يک سمبل ايجاد شود، انتخاب کنيد.
2- يکي از کارهاي گفته شده را انجام دهيد:

روي آيکن 	 که در پايين پنل قرار دارد کليک کنيد.
شئ مورد نظر را از صفحه کاري به ليست سمبل‌ها درگ کنيد. 	

از منوي کنترلي پنل Library گزينه New Graphic	 را انتخاب کنيد.
مسير  Modify→Symbol→Convert to Symbol	 را اجرا کنيد.

مسير  Modify→Symbol→Copy Symbolرا پيگيري کنيد.	
هر كدام از اين 5 روش كي سمبل جديد ايجاد ميك‌ند.
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شکل 24-12 ايجاد يک سمبل

3-2-12 ايجاد کپي از نمونه اصلي

پس از باز کردن پنل  Libraryبه طريق زير عمل کنيد:
1- از فهرست سمبل‌ها، سمبل مورد نظر را برگزينيد.

2- يکي از دو مورد زير را انجام دهيد )شکل 12-25(:
3- روي گزينه Duplicate از منوي کنترلي پنل کليک کنيد.

4- کليد Ctrl را نگه‌داشته و آن را به ليست سمبل‌ها درگ کنيد.       	   

 شکل 25-12 ايجاد کپي از نمونه اصلي سمبل

Library 4-2-12 پيش‌نمايش سمبل در پنل

روش اجرا:
1- بررس��ي کنيد که از من��وي کنترلي پنل Library گزين��ه Preview در حالت انتخاب 

باشد. 
2- سمبل مورد نظر را از فهرست سمبل‌ها انتخاب کنيد.

3- پيش‌نمايش آن در پنل Library مانند شکل 25-12 قابل مشاهده است.
5-2-12 گروه‌بندي سمبل‌ها

1- يکي از اين دو مورد را اجرا کنيد:



Free Hand پیمانه مهارتی : کاربر
   Graphic Hose و Styles  ، 355واحد کار دوازدهم: توانایی استفاده از لایه ها ، سمبل ها

روي آيکن  در پايين پنلLibrary  کليک کنيد.	
گزينه New Group را از منوي کنترل در پنل Library انتخاب كنيد.	

2- نام گروه مورد نظر را وارد کنيد.
3- سمبل‌هاي مورد نظر را به ليست گروه ايجاد شده وارد کنيد )شکل 12-26(. 

شکل 26-12 قرار دادن سمبل‌ها در يک گروه

 توجه: براي انتخاب بيش از يک س��مبل و قرار دادن آن‌ها در ليس��ت گروه مورد 

نظر، از کليد Shift استفاده کنيد.

6-2-12 حذف سمبل‌ها

1- سمبل مورد نظر را انتخاب کنيد.
2- يکي از دو مورد بعد را انجام دهيد:

روي آيکن  که در پايين پنل Library	 قرار دارد، کليک کنيد.
از منوي کنترل در پنل Library، گزينه Remove	 را برگزينيد.

7-2-12 ايجاد نمونه1 از سمبل

يکي ديگر از امکانات پنل Library ايجاد نمونه‌هايي از س��مبل اس��ت که با تغيير سمبل، 
نمونه‌هاي ايجاد شده از آن نيز تغيير مي‌کنند.

روش اجرا:
به يکي از حالت‌هاي گفته شده عمل کنيد )شكل 12-28(:

 1-    Instance 
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سمبل مورد نظر را از پنل Library به سند درگ کنيد.	
عمل Copy و Paste يا Duplicate را روي نمونه سمبل موجود، انجام دهيد. 	

شکل 27-12 ايجاد نمونه از سمبل

8-2-12 ويرايش سمبل	

1- براي ويرايش سمبل به ترتيب زير عمل کنيد:
روي نام سمبل يا پيش‌نمايش آن در پنل Library دابل کليک کنيد.	
گزينه Edit از منوي کنترلي پنل Library را برگزينيد.	

2- پنجره ويرايش سمبل باز مي‌شود؛ تغييرات دلخواه را روي آن انجام دهيد. 
3- پنجره ويرايش سمبل را ببنديد.

 توجه: در س��مت چپ پنجره ويرايش سمبل، گزينه Auto-Update به صورت پيش‌فرض فعال 

است و امکان اجرا و مشاهده تغييرات را به صورت همزمان فراهم مي‌کند.

 نكته: تغييرات انجام ش��ده روي س��مبل‌ها تا زماني که پنجره ويرايش آن بس��ته نشده است يا 
سند ديگري را فعال نکرده‌ايد، روي آن‌ها اعمال نمي‌شود.

، اگ��ر در کادر ظاهر  	Library با درگ يک ش��ئ به محل س��مبل مورد نظ��ر در پنل
ش��ده روي دکمه Replace کليک کنيد، شئ انتخاب ش��ده جايگزين سمبل و همه 

نمونه‌هاي ايجاد شده از آن در سندهاي FreeHand مي‌شود.
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9-2-12 جايگزيني سمبل با اشياء و نمونه‌هاي )Instance( سند

روش اجرا:
1- ابتدا اشياء مورد نظر را انتخاب کنيد )شکل 12-28(.

   

شکل 28-12جايگزيني سمبل با اشياء انتخابي و نمونه‌هاي ايجاد شده از سمبل 

2- سمبل مورد نظر را از پنل Library انتخاب کنيد.
3- يکي از دو مورد زير را اجرا کنيد.

روي آيکن    کليک کنيد.	
از منوي کنترلي پنل، گزينه Swap	 را برگزينيد. در اين صورت س��مبل با اشياء سند 

جايگزين مي‌شود )شكل 12-29(.

شکل 29-12 سمبل جايگزين شده با اشياء سند

Release 12-2-10 سمبل

1- در پنل Library سمبل موردنظر را انتخاب کنيد.
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2- مسير Modify→Symbol→Release Instance را پيگيري کنيد.
مثال 3: يک س��ند دوصفحه‌اي با اندازه دلخواه ايجاد کنيد. ش��کل 30-12 را در 

   Library که در پنل Flower به فهرس��ت گ��روه Fl-red صفحه اول رس��م کرده و آن را با نام
ايجاد کرده‌ايد اضافه کنيد؛ س��پس نمون��ه‌اي از آن را در صفحه دوم قرار دهيد و رنگ آن را 

تغيير دهيد.

شکل 12-30

2- فايل دو صفحه‌اي ايجاد کرده و در صفحه اول شکل 30-12 را رسم کنيد.
 Library را از منوي کنترلي در پنل  New Group را فعال کرده و گزينه Library 3- پن��ل

برگزينيد و گروهي با نام Flower در آن ايجاد کنيد.
4- شکل رسم شده را به داخل گروه Flower درگ و نام سمبل را Fl-red قراردهيد.
5- سمبل Fl-red را از پنل Library به صفحه دوم سند درگ کنيد )شکل 12-31(.

6- با استفاده از گزينه Edit در منوي کنترلي پنل، سمبل را ويرايش کرده و رنگ آن را 
تغيير دهيد.

      

 

 

        
شکل 12-31

11-2-12 وارد کردن سمبل‌ها

1- از منوي کنترلي پنل Library ، گزينه Import را اجرا کنيد.
2- فايل��ي که س��مبل م��ورد نظر در آن ق��رار دارد، انتخاب و روي دکم��ه Open کليک 

کنيد.



Free Hand پیمانه مهارتی : کاربر
   Graphic Hose و Styles  ، 359واحد کار دوازدهم: توانایی استفاده از لایه ها ، سمبل ها

 Import س��مبل موردنظر را انتخ��اب و روي دکمه Import Symbols  3- درکادرمح��اوره
کليک کنيد.

12-2-12 صادر کردن سمبل‌ها

1- از منوي كنترل در پنل Library گزينه Export را برگزينيد.
2- سمبل يا سمبل‌هايي را که مي‌خواهيد صادر کنيد، انتخاب کنيد.

3- روي دکمه Export کليک کنيد.
4- در کادر محاوره Export Symbols، فايل FreeHand را که مي‌خواهيد سمبلي در آن به 

کار ببريد، مشخص کرده و پس از وارد کردن نام فايل روي دکمه Save کليک کنيد.
مثال 4: ش��کل 32-12 را رسم کرده و با نام fl-green به فهرست گروه flower که 
در پنل Library ايجاد کرده‌ايد اضافه کنيد؛ س��پس آن‌را به فايلي با نام Example12 -3 صادر 

کنيد.
1- ابتدا شکل 32-12 را رسم و با استفاده از يکي از پنل‌هاي رنگ، رنگ‌آميزي کنيد.

2- پنل Library را از طريق منوي Window فعال کنيد.
3- روي آيک��ن  که در پايين پنل اس��ت کليک ک��رده و گروهي با نام Flower ايجاد 

کنيد.

شکل 12-32

 Fl-green درگ و نام آن را Flower 4- ش��کل رسم شده را انتخاب کرده و به داخل گروه
بگذاريد.

 Example12 -3 در منوي کنترلي پنل، شکل را به فايلي با نام Export 5- با استفاده از گزينه
صادر کنيد.

 FreeHand ايجاد کرده و يکي از سمبل‌هاي برنامه T12 -4 تمرين 3: سندي به نام
را به دلخواه انتخاب کرده و در آن وارد کنيد.

  (Style)3-12 سبك
س��ب‌كهاي گرافيکي و متني آماده، يکي از امکانات مهم برنامهFreeHand  اس��ت که اين 
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موارد به صورت از قبل تعريف ش��ده و آماده در دس��ترس شماست و مي‌توانيد از ويژگي‌هاي 
هر کدام براي ايجاد قالب طرح و سبک مورد نظر استفاده کنيد، اين ويژگي‌ها عبارتند از:

 ) 	strokes(خط‌هاي دور اشياء
) 	fills( پرکردني‌هاي داخل موضوع‌هاي ترسيمي

) 	colors( رنگ‌ها
) 	effects( جلوه‌ها

	Halftone ويژگي‌هاي
س��ب‌كهاي متني نيز امکان قالب‌بندي و پايه‌ريزي سبك متني و پاراگرافي را با توجه به 

ويژگي‌هاي متني موجود، فراهم مي‌کند.

Halftones و Object شکل 33-12 سبك گرافيکي و ويژگي‌هاي پيش‌فرض در پنل

س��بک‌ها )طرح‌ها( همچنين امکان ايجاد تغييرات س��ريع در متن و گرافيک سند جاري 
را فراهم مي‌کنند.

همان‌طورکه مي‌توانيد از الگوهاي آماده )Template( در سند بهره بگيريد، امکان ايجاد و 
ذخيره Style و کاربرد آن در سندFreeHand  نيز وجود دارد.

 توج�ه: اين م��وارد و ويژگي‌ها در پنل‌هاي Object و Halftones  1  قابل دسترس��ي 

1- پنل Halftones براي تنظيم صفحات سفارشي براي اشيايي مانند ته‌رنگ‌ها، طيف رنگ‌ها (Gradients)، تركيبات و تصاوير اسكن شده 
استفاده مي‌شود.
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هستند )12-33(.
 Styles 1-3-12 پنل

پن��ل Styles براي نمايش س��بک و طرح گرافيکي و متني ب��ه‌کار مي‌رود. همچنين براي 
ايجاد يک س��بك جدي��د )new styles(، حذف )remove(، اضافه ))add، تهيه کپي از س��بك 

موجود duplicate(( و براي ويرايش سبك‌ها از پنلObject  و Styles استفاده مي‌شود.

 نكته: اگر ش��ئ يا موضوع گرافيکي در س��ند انتخاب نباش��د و يک سبك از پنل 
Styles در وضعي��ت انتخاب قرار بگيرد؛ آن س��بك به‌ط��ور پيش‌فرض به عنوان خصوصيت 

اشياء ترسيمي جديد، در نظر گرفته مي‌شود.

Styles نمايش پنل
براي نمايش پنل Styles  مسير Window→Styles  را اجرا کنيد.

Styles 1-1-3-12 حالت‌هاي نمايش
ب��راي انتخاب حالت‌هاي نمايش Styles روي من��وي کنترلي پنل Styles کليک کنيد و با 

توجه به حالت نمايشي مورد نظر، يکي از موارد زير را انتخاب کنيد:
Compact List View:	 س��ب‌كها به صورت پيش‌نمايش کوچکي از شکل آن‌ها همراه 

با نام سبك، نشان داده مي‌شود.
Large List View:	 س��ب‌كها به صورت پيش‌نمايش بزرگي از شکل آن‌ها همراه با نام 

سبك، نشان داده مي‌شود.
 	Styles سب‌كها به صورت پيش‌نمايش بزرگي از شکل آن‌ها در پنل :Previews Only

نشان داده مي‌شود.
Normal 2-1-3-12 اعمال سبك

هر سند FreeHand همراه با سه سبك Normal پيش‌فرض به صورت زير ارائه مي‌شود:
1- سبك مختص ترسيم اشياي جديد

2- ايجاد متن جديد
 )Normal Connector( 3- اعمال نمودن خطوط متصل كننده جديد

2-3-12 ايجاد يکStyle  جديد
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در اين بخش موارد مختلف ايجاد سبك بررسي مي‌شود:
Normal ايجاد سبك يا طرح جديد بر اساس يک سبک گرافيکي

در حالتي که س��بك نرمال در پنل Styles  انتخاب شده است، طبق شکل 34-12 به اين 
ترتيب عمل کنيد:

1- روي منوي کنترل در پنل Styles کليک کنيد.
2- گزينه New را برگزينيد.

شکل 34-12 ايجاد سبك نرمال

ايجاد سبك جديد بر اساس يک شئ
1- شئ يا متن )موضوع( مورد نظر را انتخاب کنيد.

2- سپس يکي از روش‌هاي زير را انجام دهيد:
طب��ق ش��کل 35-12 از منوي کنترلي پنل Styles گزينه New	 را برگزينيد، س��بك 

ايجاد شده بر اساس موضوع در ليست Style ها ديده مي‌شود.

Styles در منوي كنترلي پنل New شکل 35-12 ايجاد سبك جديد با استفاده از گزينه
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 موض��وع ‌موردنظ��ر را از صفح��ه‌کاري ب��ه فض��اي خال��ي پن��ل Styles	 درگ کنيد 
)شکل12-36(. 

Styles شکل 36-12 ايجاد سبك جديد با درگ شئ به پنل

، پيش‌نمايش ش��يئي را که در س��مت چپ نام آن قرار دارد، به فضاي  	Object از پنل
خالي پنل Styles درگ کنيد )شکل 12-37(.

Object شکل 37-12 پيش‌نمايش شئ در پنل

پ��س از ره��ا كردن ماوس ‌اگر در فضاي خالي صفحه كليك كنيد، پنل Object به صورت 
شكل 38-‌12 خواهد شد. 

Object شکل 38-12 پيش‌نمايش سبك ايجاد شده در پنل

Styles ايجاد سبك جديد بر اساس طرح موجود در پنل
1- مس��ير Edit→Select→None را پيگيري کرده يا کليد Tab را فشار دهيد تا شيئي در 

وضعيت انتخاب نباشد.
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2- در پنل Styles، سبكي را که مي‌خواهيد Style جديد بر اساس آن ايجاد شود، انتخاب 
کنيد )شکل 12-39(.

شکل 39-12 شئ رسم شده بر اساس سبك انتخابي

 توجه: اگر ش��يئي در صفحه انتخاب نشده باشد؛ انتخاب يک طرح، سبب مي‌شود که 

خصوصيات سبك انتخابي به صورت پيش فرض به اشياء جديدي که رسم مي‌شوند، داده شود.

1- يکي از موارد ذكر شده را اجرا کنيد:
گزينه New را از منوي کنترل در پنل Styles انتخاب کنيد.	

 پيش‌نماي��ش س��بك را از پن��ل Object به‌فضاي‌خال��ي پن��ل Styles	 درگ کني��د 
)شکل12-40(.

Object وپيش نمايش آن درپنل Stylesشکل 40-12سبك انتخاب شده در پنل
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Object ايجاد طرح جديد براساس ويژگي‌هاي تنظيم شده در پنل
1- مس��ير Edit→Select→None را پيگيري کرده يا کليد Tab را فشار دهيد تا شيئي در 

وضعيت انتخاب نباشد.
2- ويژگي‌هاي موردنظر را در پنل  Object تنظيم کنيد .

3- يکي از موارد زير را انجام دهيد:
. پيش نمايش سبك را از پنل  Object به فضاي خالي پنل Styles درگ کنيد	

گزينه New را از منوي کنترل در پنل Styles انتخاب کنيد.    	
Style 3-3-12 کاربرد

براي اعمال سبک به موضوع انتخاب شده پس از نمايش پنل Styles، يکي از کارهاي زير 
را انجام دهيد:

Style موردنظر را به شئ انتخاب شده درگ کنيد )شکل 12-41(.	

Style را از موضوع ترس��يمي دلخواه کپي کرده و با انجام عمل Paste	 به ش��ئ ديگر 

اعمال کنيد.
برای نسخه‌برداري از ويژگي‌هاي يک Style به ترتيب گفته شده عمل کنيد:

انتخاب موضوع ترسيمي که مي‌خواهيد از ويژگي‌هاي آن استفاده کنيد.
2- مسير Edit→Special→Copy Attributes را اجرا کنيد )شکل 12-42(.

Styles به شئ انتخاب شده با درگ طرح از پنل Style شکل 41-12 اعمال



وزارت فرهنگ و ارشاد اسلامی
Free Hand نام استاندارد : کاربر

شماره : 15/7- ف - هـ
366

    

شکل 42-12 کپي سبک شئ مورد نظر

3- انتخاب موضوع ترس��يمي ک��ه مي‌خواهيد ويژگي‌هاي س��بک موردنظر به آن اعمال 
شود.

4- مسير  Edit→Special→Paste Attributesرا اجرا کنيد. مشاهده ميك‌نيد كه سبك به 
شئ اعمال مي‌شود )شكل 12-43(.

شکل 43-12 اعمال سبک يک شئ به شئ ديگر

Style 4-3-12 ايجاد يک کپي از

1- مسير Edit→Select→None را اجرا کرده يا کليد Tab را فشار دهيد تا شئ در وضعيت 
انتخاب نباشد.

2- در پنل Styles سبك مورد نظر را انتخاب کنيد.
 Duplicate يا كليك راس��ت روي سبك موردنظر، گزينه Styles 3- از منوي کنترلي پنل

را برگزينيد )شكل 12-44(.
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شکل 44-12 كپي سبك موردنظر

Style 5-3-12 حذف يک

1- مس��ير Edit→Select→None را پيگيري کرده يا کليد Tab را فشار دهيد تا شيئي در 
وضعيت انتخاب نباشد.

2- در پنل Styles، سبك موردنظر را براي حذف، انتخاب کنيد.
3- گزينه Remove را از منوي کنترل در پنل Style برگزينيد.

 توجه: با کليک راس��ت روي س��بك انتخابي مي‌توانيد، آن را حذف کرده )گزينه 

Remove( يا از آن نسخه کپي ايجاد کنيد )گزينه Duplicate( )شکل 12-45(.

شکل 12-45

Style 6-3-12 وارد کردن و صادر کردن

لازم نيست هر زمان كه كي سند جديد FreeHand را ايجاد ميك‌نيد، سب‌كهاي جديدي 
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 FreeHand تعريف نماييد. به سادگي مي‌توانيد سب‌كهايي را كه قبلًا تعريف كرده‌ايد در اسناد
وارد كرده يا س��بك ايجاد ش��ده را صادر کنيد. با اين تفاوت که به جاي پنل Library از پنل 
Styles اس��تفاده ک��رده و از طري��ق کادر مح��اوره Import Styles و Export Styles وارد کردن 

)Import( و صادر کردن )Export( سب‌كها انجام مي‌شود.
براي وارد کردن س��بك به س��ند جاري، از سند‌هاي FreeHand	 يا کتابخانه‌ سبک‌ها 

كه سبك مورد نظر را دارند، استفاده مي‌شود.
در ش��کل 46-12 تعدادي از گروه‌هاي متفاوت Style	 که از طريق منوي کنترلي در 

پنل Styles قابل دسترسي هستند، نشان داده شده است. 

Style شکل 46-12 فايل گروه‌هاي مختلف

 Styles را در پنل    Crystal Button سبك ،Button Styles تمرين 4: از گروه س��بک
وارد کرده و آن را به شکل‌هاي 47-12 که در صفحه کاري رسم کرده‌ايد، اعمال کنيد.

شکل 12-47

 Graphic Hose 4-12 ابزار
به کمک اين ابزار و با اس��تفاده از ش��کل‌هاي گرافيکي از پيش تعريف ش��ده يا طراحي 
شده توسط خود و کليک يا درگ ماوس روي صفحه، قادر خواهيد بود تا جلوه‌هاي گرافيکي 

جالبي را ايجاد کنيد. 
Graphic Hose 1-4-12 روش کار با ابزار

1- روي ابزار Graphic Hose دابل کليک کنيد تا کادر محاوره Hose مطابق شکل 12-48 
باز شود.

2- با انتخاب گزينهHose  مي‌توان نمونه‌هاي از پيش تعريف ش��ده‌اي مانند گل، ستاره و 
مشابه آن‌ها را براي ايجاد جلوه انتخاب کرد.
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 Graphic Hose مي‌توان يک Hose از منوي بازشو کادر محاوره  New3- با انتخاب گزينه
جديد ايجاد کرد.

با انتخاب گزينه Rename   مي‌توان نام Graphic Hose	 را تغيير داد.
با انتخاب گزينه Duplicate مي‌توان از Graphic Hose	 جاري يک کپي تهيه کرد.

(، تعداد  منوي بازش��وي Contents واقع در پايين کادر محاوره Hose )شکل 12-48	
شکل‌هاي Graphic Hose جاري را نمايش مي‌دهد.

             Hose شکل 48-12 کادر محاوره

 توج�ه: در کادر مح��اورهHose ، تصاوير قرار گرفته در يک نوع ش��کل مي‌توانند حداکثر تا 10 

عدد باشند.

2-4-12 روش ايجاد يک Graphic Hose جديد

1- اين شکل‌ها را طراحي کنيد )شکل 12-49(.

شکل 12-49 

2- روي ابزار Graphic Hose دابل کليک کنيد تا کادر محاوره Hose باز شود.
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3- در منوي بازشوي کادر محاوره Hose گزينه New را انتخاب کنيد.
 4- در کادر محاوره ظاهر ش��ده )شکل 50-12( در کادر متني Name نام مورد نظر براي

Graphic Hose جديد را وارد کرده، سپس روي دکمه Save کليک کنيد.

شکل 50-12 تايپ نام جديد

5- شکل اول را انتخاب کرده سپس کپي کنيد، سپس در کادر محاورهHose  روي دکمه
Paste in  کليک نماييد )شكل 12-51(.

شکل 51-12 کپي شکل در Graphic Hose جديد

6- براي ش��کل دوم و سوم همان مراحل را طي کنيد. از منوي بازشوي Contents تعداد 
اشکال موجود در مجموعه ساخته شده خود را مي‌توانيد مشاهده کنيد. 

7- اکنون با هر بار کليک، شکل‌هاي موجود در Graphic Hose روي صفحه ظاهر مي‌شوند.
  Graphic Hoseمي‌ت��وان تنظيمات مربوط به  Optionsبا انتخاب گزينه Hose درکادرمح��اوره

را انجام داد.
 Graphicتمرين 5: ش��کل‌هاي 52-12 را طراحي کرده و با اس��تفاده از آن‌ها يک

Hose  جديد ايجاد کنيد.

شکل 12-52
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 Chart  5-12 ابزار
  Xtra Toolsواقع در ن��وار ابزار Chart ب��راي ايج��اد نمودار از اب��زاري به نام Freehand در

استفاده مي‌شود.
Chart 1-5-12 روش کار با ابزار

ابزار Chart را انتخاب کنيد و کادري در صفحه بکشيد تا محدوده ترسيم نمودار تعيين شود.
کادر محاوره Chart مطابق شکل 53-12 ظاهر مي‌شود.

در بالاي کادر محاوره Chart، دو آيکن به شرح زير وجود دارد:
آيک��ن داده‌ه��ا  که در ش��کل 54-12 نمايش داده ش��ده و مخص��وص وارد کردن 

اطلاعات است.
آيکن گراف يا نمودار  که در صورت انتخاب آن، شکل 54-12 نمايش داده مي‌شود 

و مي‌توان در اين قسمت شکل‌هاي مختلفي را براي نمودار تعيين کرد.

 

شکل 53-12 کادرمحاوره Chart براي وارد کردن داده

Chart شکل 54-12 نحوه تنظيم نمودار  از کادرمحاوره
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 Chart 2-5-12 نحوه تنظيم نمودار از کادر محاوره

گزينه‌ه��اي اي��ن کادر محاوره، نوع نمودار را از لحاظ ش��کل ظاه��ري و گرافيکي تعيين 
مي‌کنند.

Grouped Column  : نمودار را به صورت ميله‌اي رسم مي‌کند.

Stacked Column  : در اين نوع نمودار، داده‌ها به صورت افزايش��ي با هم مقايس��ه 

مي‌شوند.
Line  : نمودار را به صورت خطي رسم مي‌کند.

Pie : ب��راي ارايه‌داده‌ه��ا به‌عن��وان درصدهاي��ي از کل، از نمودار دايره‌اي اس��تفاده 

‌مي‌شود.
Area  : س��طح اشغال شده توسط هر نمودار از رنگ پر مي‌شود و نحوه قرار گرفتن 

نمودار به صورت افزايش��ي اس��ت. از اين نوع ترسيم آماري براي نمايش داده‌ها در طول يک 
دوره زماني استفاده مي‌شود.

Scatter : داده‌ه��اي هر دو خانه در يک رديف با يکديگر مقايس��ه و به صورت يک 

نقطه در نمودار ظاهر مي‌شوند.

واژه‌نامه
Auto-Updateبه‌روز شدن، به‌صورت خودکار

Chartنمودار

Compactفشرده

Decimalاعشاري، دهدهي

Foregroundپيش‌زمينه
Halftone)در ليتوگرافي( هاف‌تن، تصوير ترام‌دار، )در طراحي( خاکستري ميانه

Layersلايه‌ها

Line Chartنمودارخطي

Parent Styleسبك مبنا، سبك والد، سبك اصلي

Pie Chartنمودار دايره‌اي
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Replaceجايگزين کردن

Scatterپخش کردن

Separatorجداکننده

Symbolsسمبل‌ها

Uniformهم‌شکل، يکسان

خلاصه مطالب
موارد کاربرد پنل Library	 به‌طور خلاصه به شرح زير است:

ايجاد سمبل از اشياء و متن يا سمبلي ترکيبي از متن و شئ	
	)Symbols( حذف و اضافه کردن سمبل‌ها

وارد ک��ردن و ص��ادر ک��ردن س��مبل‌ها و صفحه‌ه��اي اصلي در صفحه‌هاي س��ند  	
FreeHand

، ايجاد يک  	 )add( اضاف��ه ،)remove( حذف ،)new( براي ايجاد يک س��بك جدي��د
نس��خه کپي از س��بك موجود )duplicate( و براي ويرايش سب‌كها از پنل Object و 

Styles استفاده مي‌شود.

ابزار Graphic Hose	 با استفاده از شکل‌هاي گرافيکي از پيش تعريف شده و با کليک 
يا درگ ماوس روي صفحه، جلوه‌هاي گرافيکي جالبي ايجاد مي‌کند. 

از ابزار Chart	 براي ايجاد نمودارهاي گرافيکي استفاده مي‌شود.
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آزمون نظري
درستي يا نادرستي گزينه هاي زير را تعيين کنيد.

 Background 1- ب��ه لايه‌هاي��ي ک��ه در بالاي خط افق��ي جدا کننده ق��رار مي‌گيرند، لاي��ه
مي‌گويند. 

2- موضوع‌هاي ترسيمي که در لايه Foreground قرار دارند، چاپ شدني هستند.
3- انتخاب گزينه Clicking on a Layer name moves selected objects در زبانه Panels در 

كادر محاوره Preferences سبب جا‌به‌جايي اشياء با انتخاب نام لايه مي‌شود.
4- براي ايجاد سمبل جديد، روي آيکن  که در پايين پنل قرار دارد، کليک کنيد.

5- اگر ش��يئي در صفحه انتخاب نش��ده باش��د؛ انتخاب يک طرح، س��بب مي‌ش��ود که 
خصوصيات طرح انتخابي به صورت پيش‌فرض به اش��ياء جديدي که رس��م مي‌ش��وند، داده 

شود.
 Graphic Hose در کادر محاوره Spacing از منوي بازش��و ،Variable 6- ب��ا انتخاب گزينه

فاصله ميان موضوعات به طور تصادفي تعيين مي‌شود.
معادل گزينه هاي سمت‌راست را از ستون سمت‌چپ انتخاب کرده و مقابل هر عبارت بنويسيد.

7- اشياء و موضوع‌هايي که  ترسيم مي‌کنيد يا در سند Import مي‌شوند، در اين لايه قرار 
             Remove                                                                                                                  .مي‌گيرند
              Edit         .8- براي ويرايش لايه‌ها، بايد آن‌ها را در وضعيت ......... و ............. قرار دهيد
9- ب��راي ويراي��ش س��مبل گزين��ه ......... از من��و کنت��رل پن��ل Library را برگزيني��د.                                                                                                                                        
     Remove Unused                                                                                         
10- اين گزينه براي حذف يک سمبل در پنل Library و با استفاده از منوي کنترلي اين 
Active                                                                                                        .پنل به‌کار‌ مي‌رود

11- براي حذف طرح‌هايي اس��ت که در س��ند به‌کار نمي‌رون��د و از منو کنترل در پنل 
	Visible-UnLock                                                               انتخاب مي‌شود Styles

گزينه صحيح را انتخاب کنيد.

12- هنگام استفاده از ابزار Chart مقدار اعشار در کدام قسمت تعيين مي‌شود؟
Thousands separator -ب 		 Transpose  -الف
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Column -د 	             Decimal precision -ج
13- هنگام اس��تفاده از ابزار Graphic Hose با انتخاب کدام گزينه مي‌توان از مدل جاري 

يک کپي تهيه کرد؟
Delete -د 	Rename -ج 	Duplicate -ب 	Contents  -الف

14- براي ادغام محتويات لايه‌هاي بالاي خط جدا کننده با لايه Foreground کدام گزينه 
مناسب است؟

Remember Layer Info  -ب          	Merge Foreground Layers  -الف
Merge Selected Layer  -د 	  Move Objects to Current Layer  -ج

15- براي جايگزيني سمبل با اشياء و Instanceهاي سند به‌کار مي‌رود:
الف-             ب-               ج-                د- 

16- در اين حالت، نمايش طرح‌ها به صورت پيش‌نمايش بزرگي از ش��کل آن‌ها همراه با 
نامشان، نشان داده مي‌شود:

	Normal View -ب           	Large List View  -الف
Compact List View  -د 		 Previews Only  -ج

در جاي خالي عبارت مناسب را بنويسيد.

17-  موضوع‌هايي که در لايه ............... قرار دارند، چه بالاي خط جدا کننده باشند يا در 
پايين آن قرار بگيرند، چاپ نمي‌شوند.

18- در س��مت چپ پنجره ويرايش س��مبل، گزينه ............... به صورت پيش‌فرض فعال 
است و امکان اجرا و مشاهده تغييرات را به صورت همزمان فراهم مي‌کند.

19- ب��ه ي��كStyle  که مبناي توليد س��بك‌هاي ديگر قرار داده مي‌ش��ود، س��بك ......... 
مي‌گويند.

20- ه��ر تغيي��ري در س��بك ..........، س��بب تغيير در اس��اس اوليه س��بك‌هاي ............ 
مي‌شود.

به سؤالات زير پاسخ تشريحی دهيد.

21- منظور از لايه قفل شده و قفل نشده، چيست؟
22- علامت + کنار طِرح نشان‌دهنده چيست؟

23- سه مورد از موارد کاربرد پنل Library را بيان کنيد.
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24- چگونه مي‌توان يک Graphic Hose جديد ايجاد کرد؟	

آزمون عملي
1- شکل زير را رسم کرده، آن را با نام Style 12-85 در ليست سب‌كهاي پنل Styles وارد 

کنيد، با استفاده از پنل Object ويژگي‌هاي آن را تغيير دهيد و سبك را Redefine کنيد.

2- شکل‌هاي زير را به ترتيب در لايه‌هايي با نام Design 1 و Design 2 ايجاد كرده و لايه 
Design 2 را پنهان كنيد و لايه Design 1 را در حالت نمايش خطي قرار دهيد و قفل کنيد.

3- شکل زير را رسم کرده، موارد خواسته شده را روي آن انجام دهيد:
به عنوان يک سمبل در پنل Library قرار دهيد. 	

ي��ک کپ��ي از آن ايجاد كني��د و در نمونه کپي ش��ده رنگ آن را تغيي��ر دهيد و از  	
س��مبل‌هايي که ايج��اد کرده‌ايد در طراحي ي��ک کاغذ کادو با اندازه A4 اس��تفاده 

کنيد.
موضوع‌هاي ترسيمي را در لايه‌هاي مجزا قرار دهيد و در پايان کار ادغام کنيد.	

4- توسط تصاوير زير يک Graphic Hose جديد ايجاد کنيد.
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5- نمودار ميله‌اي و دايره‌اي نمرات درس FreeHand خود را در ماه جاري ترسيم کنيد.


